summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2010-07-31 07:44:22 +0000
committerAkinori Hattori <hattya@gentoo.org>2010-07-31 07:44:22 +0000
commit6e33bb5b2edd27db7141bdddcd34fa9ed3a50ac4 (patch)
treed2929ea56c3b2808123d75a34a00bf64a546bfaf /mail-client
parentstable on x86. (diff)
downloadgentoo-2-6e33bb5b2edd27db7141bdddcd34fa9ed3a50ac4.tar.gz
gentoo-2-6e33bb5b2edd27db7141bdddcd34fa9ed3a50ac4.tar.bz2
gentoo-2-6e33bb5b2edd27db7141bdddcd34fa9ed3a50ac4.zip
new upstream release.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/sylpheed-3.0.3.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 843aab0968e0..2a54085f1c4a 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.285 2010/07/31 07:41:08 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.286 2010/07/31 07:44:22 hattya Exp $
+
+*sylpheed-3.0.3 (31 Jul 2010)
+
+ 31 Jul 2010; Akinori Hattori <hattya@gentoo.org> +sylpheed-3.0.3.ebuild:
+ new upstream release.
31 Jul 2010; Akinori Hattori <hattya@gentoo.org> -sylpheed-2.7.1.ebuild,
-sylpheed-3.0.0.ebuild, sylpheed-3.0.2.ebuild:
diff --git a/mail-client/sylpheed/sylpheed-3.0.3.ebuild b/mail-client/sylpheed/sylpheed-3.0.3.ebuild
new file mode 100644
index 000000000000..291ada2887d3
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.0.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-3.0.3.ebuild,v 1.1 2010/07/31 07:44:22 hattya Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-1 )
+ ldap? ( net-nds/openldap )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${COMMON_DEPEND}
+ app-misc/mime-types
+ net-misc/curl
+ x11-misc/shared-mime-info"
+
+AT_M4DIR="ac"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${PN}-2.7-*.diff
+ epatch "${FILESDIR}"/${PN}-3.*.diff
+
+ use crypt || cp ac/missing/gpgme.m4 ac
+
+ eautoreconf
+
+}
+
+src_configure() {
+
+ local htmldir=/usr/share/doc/${PF}/html
+
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck \
+ || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+ doicon *.png
+ domenu *.desktop
+
+}