summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2013-05-08 04:36:33 +0000
committerChristian Faulhammer <fauli@gentoo.org>2013-05-08 04:36:33 +0000
commit8231f5b7d407695005170f5db1ef41e3c406a959 (patch)
tree3913f1ca418bbe72072dfc0fd66cd4077029f073 /mail-client
parentMake detection of boottime non-fatal and add user patch capability, see bug 4... (diff)
downloadgentoo-2-8231f5b7d407695005170f5db1ef41e3c406a959.tar.gz
gentoo-2-8231f5b7d407695005170f5db1ef41e3c406a959.tar.bz2
gentoo-2-8231f5b7d407695005170f5db1ef41e3c406a959.zip
version bump
(Portage version: 2.1.11.62/cvs/Linux i686, signed Manifest commit with key 2B859DE3)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail/ChangeLog20
-rw-r--r--mail-client/claws-mail/claws-mail-3.9.1.ebuild196
-rw-r--r--mail-client/claws-mail/metadata.xml9
3 files changed, 222 insertions, 3 deletions
diff --git a/mail-client/claws-mail/ChangeLog b/mail-client/claws-mail/ChangeLog
index 9e35d9fa5767..dcd617a57816 100644
--- a/mail-client/claws-mail/ChangeLog
+++ b/mail-client/claws-mail/ChangeLog
@@ -1,6 +1,24 @@
# ChangeLog for mail-client/claws-mail
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.227 2013/02/11 21:38:59 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.228 2013/05/08 04:36:33 fauli Exp $
+
+*claws-mail-3.9.1 (08 May 2013)
+
+ 08 May 2013; Christian Faulhammer <fauli@gentoo.org>
+ +claws-mail-3.9.1.ebuild, metadata.xml:
+ Version bump with some bigger organisational changes:
+
+ - all plugins are integrated now
+
+ - dropped Dillo, GTKHtml2 and Trayicon plugins
+
+ - built all plugins that need no special dependencies
+
+ - use EAPI 5
+
+ - cleaned up dependencies
+
+ - reorganised USE flags (name changes crypt -> pgp e.g.)
*claws-mail-3.9.0-r1 (11 Feb 2013)
diff --git a/mail-client/claws-mail/claws-mail-3.9.1.ebuild b/mail-client/claws-mail/claws-mail-3.9.1.ebuild
new file mode 100644
index 000000000000..2c95d459189b
--- /dev/null
+++ b/mail-client/claws-mail/claws-mail-3.9.1.ebuild
@@ -0,0 +1,196 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-3.9.1.ebuild,v 1.1 2013/05/08 04:36:33 fauli Exp $
+
+EAPI="5"
+
+inherit autotools-utils multilib gnome2-utils eutils
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="http://www.claws-mail.org/"
+
+SRC_URI="mirror://sourceforge/sylpheed-claws/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+
+IUSE="archive bogofilter calendar clamav debug dbus doc gdata gtk3 +imap ipv6 ldap networkmanager nntp +libnotify pda pdf perl +pgp python rss session smime spamassassin spam-report spell +gnutls startup-notification webkit xface"
+REQUIRED_USE="networkmanager? ( dbus )"
+
+# Plugins are all integrated or dropped since 3.9.1
+PLUGINBLOCK="!!mail-client/claws-mail-acpi-notifier
+ !!mail-client/claws-mail-archive
+ !!mail-client/claws-mail-att-remover
+ !!mail-client/claws-mail-attachwarner
+ !!mail-client/claws-mail-clamd
+ !!mail-client/claws-mail-fancy
+ !!mail-client/claws-mail-fetchinfo
+ !mail-client/claws-mail-gdata
+ !!mail-client/claws-mail-geolocation
+ !!mail-client/claws-mail-gtkhtml
+ !!mail-client/claws-mail-mailmbox
+ !!mail-client/claws-mail-newmail
+ !!mail-client/claws-mail-notification
+ !!mail-client/claws-mail-perl
+ !!mail-client/claws-mail-python
+ !!mail-client/claws-mail-rssyl
+ !!mail-client/claws-mail-spam-report
+ !!mail-client/claws-mail-tnef-parse
+ !!mail-client/claws-mail-vcalendar
+ !!mail-client/claws-mail-address_keeper
+ !!mail-client/claws-mail-pdf-viewer"
+
+COMMONDEPEND=">=sys-devel/gettext-0.12.1
+ gdata? ( >=dev-libs/libgdata-0.6.4 )
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( >=x11-libs/gtk+-2.20:2 )
+ pda? ( >=app-pda/jpilot-0.99 )
+ gnutls? ( >=net-libs/gnutls-2.2.0 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ pgp? ( >=app-crypt/gpgme-0.4.5 )
+ debug? ( dev-util/valgrind )
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ spell? ( >=app-text/enchant-1.0.0 )
+ imap? ( >=net-libs/libetpan-0.57 )
+ nntp? ( >=net-libs/libetpan-0.57 )
+ startup-notification? ( x11-libs/startup-notification )
+ session? ( x11-libs/libSM
+ x11-libs/libICE )
+ archive? ( app-arch/libarchive
+ >=net-misc/curl-7.9.7 )
+ bogofilter? ( mail-filter/bogofilter )
+ libnotify? ( x11-libs/libnotify
+ media-libs/libcanberra[gtk]
+ dev-libs/libindicate:3[gtk]
+ )
+ smime? ( >=app-crypt/gpgme-0.4.5 )
+ calendar? ( >=net-misc/curl-7.9.7 )
+ pdf? ( app-text/poppler:=[cairo] )
+ spam-report? ( >=net-misc/curl-7.9.7 )
+ webkit? ( >=net-libs/webkit-gtk-1.0:2
+ >=net-libs/libsoup-gnome-2.26:2.4
+ )"
+
+DEPEND="${PLUGINBLOCK}
+ ${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+ virtual/pkgconfig"
+
+RDEPEND="${COMMONDEPEND}
+ pdf? ( app-text/ghostscript-gpl )
+ clamav? ( app-antivirus/clamav )
+ networkmanager? ( net-misc/networkmanager )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python
+ >=dev-python/pygtk-2.10.3 )
+ rss? ( net-misc/curl
+ dev-libs/libxml2 )
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug crash-dialog)
+ $(use_enable debug valgrind)
+ $(use_enable doc manual)
+ $(use_enable gtk3)
+ $(use_enable ipv6)
+ $(use_enable ldap)
+ $(use_enable dbus dbus)
+ $(use_enable networkmanager)
+ $(use_enable pda jpilot)
+ $(use_enable session libsm)
+ $(use_enable spell enchant)
+ $(use_enable gnutls)
+ $(use_enable startup-notification)
+ $(use_enable xface compface)
+ $(use_enable archive archive-plugin)
+ $(use_enable bogofilter bogofilter-plugin)
+ $(use_enable calendar vcalendar-plugin)
+ $(use_enable clamav clamd-plugin)
+ $(use_enable gdata gdata-plugin)
+ $(use_enable libnotify notification-plugin)
+ $(use_enable pdf pdf_viewer-plugin)
+ $(use_enable perl perl-plugin)
+ $(use_enable pgp pgpmime-plugin)
+ $(use_enable pgp pgpinline-plugin)
+ $(use_enable pgp pgpcore-plugin)
+ $(use_enable python python-plugin)
+ $(use_enable rss rssyl-plugin)
+ $(use_enable spamassassin spamassassin-plugin)
+ $(use_enable smime smime-plugin)
+ $(use_enable spam-report spam_report-plugin)
+ $(use_enable webkit fancy-plugin)
+ --enable-new-addrbook
+ --enable-nls
+ --enable-acpi_notifier-plugin
+ --enable-address_keeper-plugin
+ --enable-att_remover-plugin
+ --enable-attachwarner-plugin
+ --enable-fetchinfo-plugin
+ --enable-mailmbox-plugin
+ --enable-newmail-plugin
+ --enable-tnef_parse-plugin
+ --disable-generic-umpc
+ --disable-maemo
+ --disable-bsfilter-plugin
+ --disable-geolocation-plugin
+ )
+
+ # libetpan is needed if user wants nntp or imap functionality
+ if use imap || use nntp; then
+ myeconfargs+=( --enable-libetpan )
+ else
+ myeconfargs+=( --disable-libetpan )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog* INSTALL* NEWS README* TODO* )
+ autotools-utils_src_install
+
+ # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins ${PN}.png || die
+ local res resdir
+ for res in 64x64 128x128 ; do
+ resdir="/usr/share/icons/hicolor/${res}/apps"
+ insinto ${resdir}
+ newins ${PN}-${res}.png ${PN}.png || die
+ done
+
+ docinto tools
+ dodoc tools/README*
+
+ domenu ${PN}.desktop
+
+ einfo "Installing extra tools"
+ cd "${S}"/tools
+ exeinto /usr/$(get_libdir)/${PN}/tools
+ doexe *.pl *.py *.conf *.sh || die
+ doexe tb2claws-mail update-po uudec uuooffice || die
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ ewarn "When upgrading from version 3.9.0 or below some changes have happened:"
+ ewarn "- There are no individual plugins in mail-client/claws-mail-* anymore, but they are integrated mostly controlled through USE flags"
+ ewarn "- Plugins with no special dependencies are just built and can be loaded through the interface"
+ ewarn "- The gtkhtml2, dillo and trayicon plugins have been dropped entirely"
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/mail-client/claws-mail/metadata.xml b/mail-client/claws-mail/metadata.xml
index 4e436cf8026b..ad6ee5e58a2a 100644
--- a/mail-client/claws-mail/metadata.xml
+++ b/mail-client/claws-mail/metadata.xml
@@ -7,13 +7,18 @@
<name>Christian Faulhammer</name>
</maintainer>
<use>
+ <flag name='archive'>Enable archiving plugin</flag>
+ <flag name='gdata'>Enable plugin for access to Google
+ data providers</flag>
+ <flag name='gtk3'>Build support for GTK+3</flag>
+ <flag name='pgp'>Enable PGP support</flag>
+ <flag name='spam-report'>Enable plugin for spam
+ reporting to various services</flag>
<flag name='bogofilter'>Build <pkg>mail-filter/bogofilter</pkg>
plugin</flag>
<flag name='dillo'>Enables support for inline HTTP email viewing with a
plugin (which depends on the <pkg>www-client/dillo</pkg>
browser)</flag>
- <flag name='ssl'>Use gnutls for Secure Socket Layer
- transactions (deprecated, USE=gnutls should be used)</flag>
<flag name='smime'>Build plugin for S/MIME support</flag>
<flag name='spamassassin'>Build <pkg>mail-filter/spamassassin</pkg>
plugin</flag>