summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-03-17 18:46:46 +0000
committerAron Griffis <agriffis@gentoo.org>2005-03-17 18:46:46 +0000
commitbe43dc5e1369fc9def7ac01f706e9b3ccfb20433 (patch)
tree1d1d18e590d87fdb22b3c39c84e6dfdef3f34ae2 /mail-client
parentStable on hppa. (diff)
downloadgentoo-2-be43dc5e1369fc9def7ac01f706e9b3ccfb20433.tar.gz
gentoo-2-be43dc5e1369fc9def7ac01f706e9b3ccfb20433.tar.bz2
gentoo-2-be43dc5e1369fc9def7ac01f706e9b3ccfb20433.zip
Add muttng, thanks to Christopher Korn #81900
(Portage version: 2.0.51.19)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/muttng/ChangeLog10
-rw-r--r--mail-client/muttng/Manifest2
-rw-r--r--mail-client/muttng/files/digest-muttng-200503171
-rw-r--r--mail-client/muttng/metadata.xml9
-rw-r--r--mail-client/muttng/muttng-20050317.ebuild101
5 files changed, 123 insertions, 0 deletions
diff --git a/mail-client/muttng/ChangeLog b/mail-client/muttng/ChangeLog
new file mode 100644
index 000000000000..9b284814c09b
--- /dev/null
+++ b/mail-client/muttng/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for mail-client/muttng
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/ChangeLog,v 1.1 2005/03/17 18:46:46 agriffis Exp $
+
+*muttng-20050317 (17 Mar 2005)
+
+ 17 Mar 2005; Aron Griffis <agriffis@gentoo.org> +metadata.xml,
+ +muttng-20050317.ebuild:
+ Add muttng, thanks to Christopher Korn #81900
+
diff --git a/mail-client/muttng/Manifest b/mail-client/muttng/Manifest
new file mode 100644
index 000000000000..d359ab42ae83
--- /dev/null
+++ b/mail-client/muttng/Manifest
@@ -0,0 +1,2 @@
+MD5 9e4f7d6c5bbabd0c1846e7a8dde5fc83 muttng-20050317.ebuild 2547
+MD5 e8992882a1c72fd8d97ea7eb60084283 files/digest-muttng-20050317 68
diff --git a/mail-client/muttng/files/digest-muttng-20050317 b/mail-client/muttng/files/digest-muttng-20050317
new file mode 100644
index 000000000000..778c5eae466c
--- /dev/null
+++ b/mail-client/muttng/files/digest-muttng-20050317
@@ -0,0 +1 @@
+MD5 944de30422cd430d882197c2e9f5ea07 muttng-20050317.tar.gz 2260198
diff --git a/mail-client/muttng/metadata.xml b/mail-client/muttng/metadata.xml
new file mode 100644
index 000000000000..27aa1d1dbc79
--- /dev/null
+++ b/mail-client/muttng/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<maintainer>
+ <email>agriffis@gentoo.org</email>
+ <name>Aron Griffis</name>
+</maintainer>
+</pkgmetadata>
diff --git a/mail-client/muttng/muttng-20050317.ebuild b/mail-client/muttng/muttng-20050317.ebuild
new file mode 100644
index 000000000000..53970ad26662
--- /dev/null
+++ b/mail-client/muttng/muttng-20050317.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2005 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20050317.ebuild,v 1.1 2005/03/17 18:46:46 agriffis Exp $
+
+DESCRIPTION="mutt-ng is the next generation of mutt."
+HOMEPAGE="http://www.muttng.org/"
+SRC_URI="http://www.muttng.org/snapshots/${P}.tar.gz"
+RESTRICT=nomirror
+IUSE="crypt debug gnutls gpgme imap mbox nls nntp sasl slang smtp ssl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha"
+RDEPEND="nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.2
+ sys-devel/automake
+ sys-devel/autoconf
+ net-dns/libidn
+ smtp? ( net-libs/libesmtp )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ gpgme? ( >=app-crypt/gpgme-0.9.0 )
+ sasl? ( >=cyrus-sasl-2 )"
+DEPEND="${RDEPEND}
+ net-mail/mailbase"
+
+src_unpack() {
+ unpack ${P}.tar.gz && cd ${S} || die "unpacking failed"
+
+ aclocal -I m4 || die "aclocal failed"
+ autoheader || die "autoheader failed"
+ make -C m4 -f Makefile.am.in || die "make in m4 failed"
+ automake --foreign || die "automake failed"
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ local myconf="
+ $(use_enable nls) \
+ $(use_enable gpgme) \
+ $(use_enable imap) \
+ $(use_with sasl sasl2) \
+ $(use_enable crypt pgp) \
+ $(use_enable nntp) \
+ $(use_enable debug) \
+ $(use_with smtp libesmtp) \
+ --enable-hcache \
+ --enable-compressed \
+ --sysconfdir=/etc/muttng \
+ --with-docdir=/usr/share/doc/muttng-${PVR} \
+ --with-regex \
+ --enable-pop \
+ --disable-fcntl \
+ --enable-flock \
+ --enable-external-dotlock"
+
+ if useq gnutls; then
+ myconf="${myconf} --with-gnutls"
+ elif useq ssl; then
+ myconf="${myconf} --with-ssl"
+ fi
+
+ if useq slang; then
+ myconf="${myconf} --with-slang"
+ ewarn "To use a transparend background merge muttng with USE=-slang"
+ else
+ # --without-slang doesn't work;
+ # specify --with-curses if you don't want slang
+ myconf="${myconf} --with-curses"
+ fi
+
+ if useq mbox; then
+ myconf="${myconf} --with-maildir=/var/spool/mail"
+ else
+ myconf="${myconf} --with-homespool=Maildir"
+ fi
+
+ econf ${myconf}
+ emake || die "emake failed (myconf=${myconf})"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ find ${D}/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ if useq mbox; then
+ insinto /etc/muttng
+ newins ${FILESDIR}/Muttngrc.mbox Muttngrc
+ else
+ insinto /etc/muttng
+ doins ${FILESDIR}/Muttngrc
+ fi
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}
+
+pkg_postinst() {
+ echo
+ einfo "NOTE: muttng is still under heavy development"
+ einfo "If you find a bug please report at http://bugs.gentoo.org"
+ echo
+}