summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2005-08-21 11:44:07 +0000
committerTom Martin <slarti@gentoo.org>2005-08-21 11:44:07 +0000
commit7b94cc5830cf6dc6dbd97b08a92e045e58d8651c (patch)
tree4f43b3bed3138283aa6190f147d06020efc3838f /mail-filter/gld
parentAdded gnome-vfsmm-2.11 and libgnomecanvasmm-2.11 to the gnome 2.12 mask list (diff)
downloadgentoo-2-7b94cc5830cf6dc6dbd97b08a92e045e58d8651c.tar.gz
gentoo-2-7b94cc5830cf6dc6dbd97b08a92e045e58d8651c.tar.bz2
gentoo-2-7b94cc5830cf6dc6dbd97b08a92e045e58d8651c.zip
Applied patch from bbbbmartinsw@linux-net.dnsalias.net to resolve bug 102769.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'mail-filter/gld')
-rw-r--r--mail-filter/gld/ChangeLog6
-rw-r--r--mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch36
-rw-r--r--mail-filter/gld/gld-1.5.2.ebuild10
3 files changed, 50 insertions, 2 deletions
diff --git a/mail-filter/gld/ChangeLog b/mail-filter/gld/ChangeLog
index 217549244086..adea2191a105 100644
--- a/mail-filter/gld/ChangeLog
+++ b/mail-filter/gld/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-filter/gld
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/ChangeLog,v 1.23 2005/08/14 10:10:58 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/ChangeLog,v 1.24 2005/08/21 11:44:07 slarti Exp $
+
+ 21 Aug 2005; Tom Martin <slarti@gentoo.org>
+ +files/gld-1.5.2-mxgrey-fix.patch, gld-1.5.2.ebuild:
+ Applied patch from martinsw@linux-net.dnsalias.net to resolve bug 102769.
14 Aug 2005; Michael Hanselmann <hansmi@gentoo.org> gld-1.5.2.ebuild:
Stable on ppc.
diff --git a/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch b/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch
new file mode 100644
index 000000000000..c13e4dc8f971
--- /dev/null
+++ b/mail-filter/gld/files/gld-1.5.2-mxgrey-fix.patch
@@ -0,0 +1,36 @@
+--- gld-1.5.2/greylist.c.orig 2005-08-17 00:44:06.000000000 +0200
++++ gld-1.5.2/greylist.c 2005-08-17 00:40:32.000000000 +0200
+@@ -181,10 +181,29 @@
+
+ if(conf->update==1)
+ {
+- if(conf->lightd==1 && fnotdomain==1)
+- snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and recipient='%s'",ts,ip,osender,orecipient);
+-
+- snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and recipient='%s'",ts,ip,sender,recipient);
++
++ if(ts-n>conf->mini)
++ {
++ if(conf->lightd==1 && fnotdomain==1)
++ snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and recipient='%s'",ts,ip,osender,orecipient);
++
++ snprintf(query,sizeof(query)-1,"update greylist set last=%d,n=n+1 where ip='%s' and sender='%s' and recipient='%s'",ts,ip,sender,recipient);
++ }
++ else
++ {
++ //
++ // We have NOT reached the greylist-timeout, so we do NOT increase the message-counter (SQL-field n),
++ // because otherwise we will braek the MXGREY-option.
++ // In fact this means that the THIRD retry will immidiately pass the greylist, as mxgrey checks only for ip and (n>1).
++ //
++ // 2005-08-16 martin@it4linux.de
++ //
++
++ if(conf->lightd==1 && fnotdomain==1)
++ snprintf(query,sizeof(query)-1,"update greylist set last=%d where ip='%s' and sender='%s' and recipient='%s'",ts,ip,osender,orecipient);
++
++ snprintf(query,sizeof(query)-1,"update greylist set last=%d where ip='%s' and sender='%s' and recipient='%s'",ts,ip,sender,recipient);
++ }
+
+ SQLQuery(query);
+ if(conf->debug==1) printf("%d: Query=(%s)\n",pid,query);
diff --git a/mail-filter/gld/gld-1.5.2.ebuild b/mail-filter/gld/gld-1.5.2.ebuild
index 1a9792f89721..95221f4f154c 100644
--- a/mail-filter/gld/gld-1.5.2.ebuild
+++ b/mail-filter/gld/gld-1.5.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/gld-1.5.2.ebuild,v 1.3 2005/08/14 10:10:58 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/gld/gld-1.5.2.ebuild,v 1.4 2005/08/21 11:44:07 slarti Exp $
+
+inherit eutils
DESCRIPTION="A standalone anti-spam greylisting algorithm on top of Postfix"
HOMEPAGE="http://www.gasmi.net/gld.html"
@@ -19,6 +21,12 @@ DEPEND="virtual/libc
RDEPEND="${DEPEND}
>=mail-mta/postfix-2.1"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-mxgrey-fix.patch
+}
+
src_compile() {
# It's kind of weird. $(use_with postgres pgsql) won't work...
if use postgres ; then