summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-11-07 18:26:04 +0000
committerTim Harder <radhermit@gentoo.org>2010-11-07 18:26:04 +0000
commitc0002dbafd6dccf30cefd1d16e7bc1705cf95542 (patch)
tree50d3066562da1d52bf8ab047d15416f2b49c7914 /mail-filter/postgrey
parentdev-lisp/cl-sb-readline removal, p.masked from 17Sep2010, wrt bug #337963 (diff)
downloadgentoo-2-c0002dbafd6dccf30cefd1d16e7bc1705cf95542.tar.gz
gentoo-2-c0002dbafd6dccf30cefd1d16e7bc1705cf95542.tar.bz2
gentoo-2-c0002dbafd6dccf30cefd1d16e7bc1705cf95542.zip
Revision bump to re-add targrey support (bug #342625 by Kazunori Kojima). Update to EAPI 3 and reorder lines.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter/postgrey')
-rw-r--r--mail-filter/postgrey/ChangeLog8
-rw-r--r--mail-filter/postgrey/postgrey-1.33-r1.ebuild96
2 files changed, 103 insertions, 1 deletions
diff --git a/mail-filter/postgrey/ChangeLog b/mail-filter/postgrey/ChangeLog
index 5ffc9017aaec..93a707b6a47a 100644
--- a/mail-filter/postgrey/ChangeLog
+++ b/mail-filter/postgrey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/postgrey
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/postgrey/ChangeLog,v 1.64 2010/07/30 16:33:12 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/postgrey/ChangeLog,v 1.65 2010/11/07 18:26:04 radhermit Exp $
+
+*postgrey-1.33-r1 (07 Nov 2010)
+
+ 07 Nov 2010; Tim Harder <radhermit@gentoo.org> +postgrey-1.33-r1.ebuild:
+ Revision bump to re-add targrey support (bug #342625 by Kazunori Kojima).
+ Update to EAPI 3 and reorder lines.
30 Jul 2010; Tobias Scherbaum <dertobi123@gentoo.org>
postgrey-1.32.ebuild, postgrey-1.33.ebuild:
diff --git a/mail-filter/postgrey/postgrey-1.33-r1.ebuild b/mail-filter/postgrey/postgrey-1.33-r1.ebuild
new file mode 100644
index 000000000000..986fee17b82c
--- /dev/null
+++ b/mail-filter/postgrey/postgrey-1.33-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/postgrey/postgrey-1.33-r1.ebuild,v 1.1 2010/11/07 18:26:04 radhermit Exp $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="Postgrey is a Postfix policy server implementing greylisting"
+HOMEPAGE="http://postgrey.schweikert.ch/"
+SRC_URI="http://postgrey.schweikert.ch/pub/${P}.tar.gz
+ http://postgrey.schweikert.ch/pub/old/${P}.tar.gz
+ targrey? ( http://k2net.hakuba.jp/pub/targrey-0.31-${P}.patch )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="targrey"
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/net-server
+ dev-perl/IO-Multiplex
+ dev-perl/BerkeleyDB
+ dev-perl/Net-DNS
+ dev-perl/Parse-Syslog
+ dev-perl/Net-RBLClient
+ >=sys-libs/db-4.1"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_prepare() {
+ if use targrey ; then
+ epatch "${DISTDIR}/targrey-0.31-${P}.patch"
+ fi
+}
+
+src_install() {
+ # postgrey data/DB in /var
+ diropts -m0770 -o ${PN} -g ${PN}
+ dodir /var/spool/postfix/${PN}
+ keepdir /var/spool/postfix/${PN}
+ fowners postgrey:postgrey /var/spool/postfix/${PN}
+ fperms 0770 /var/spool/postfix/${PN}
+
+ # postgrey binary
+ dosbin ${PN}
+ dosbin contrib/postgreyreport
+
+ # policy-test script
+ dosbin policy-test
+
+ # postgrey data in /etc/postfix
+ insinto /etc/postfix
+ insopts -o root -g ${PN} -m 0640
+ doins postgrey_whitelist_clients postgrey_whitelist_recipients
+
+ # documentation
+ dodoc Changes README
+
+ # init.d + conf.d files
+ insopts -o root -g root -m 755
+ newinitd "${FILESDIR}"/${PN}.rc.new ${PN}
+ insopts -o root -g root -m 640
+ newconfd "${FILESDIR}"/${PN}.conf.new ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "To make use of greylisting, please update your postfix config:"
+ elog
+
+ elog "In order to start using postgrey, edit /etc/conf.d/postgrey, add following lines"
+ elog "to smtpd_recipient restrictions setting in your /etc/postfix/main.cf:"
+ elog "\t\"check_policy_service inet:127.0.0.1:10030\", if you're using TCP socket"
+ elog "\t\"check_policy_service unix:private/postgrey\", if you're using UNIX socket"
+ elog "Then, start postgrey and restart postfix."
+
+ elog "Also remember to make the daemon start durig system boot:"
+ elog " rc-update add postgrey default"
+
+ if use targrey ; then
+ elog "The targrey patch has been applied, read the"
+ elog "documentation for more info at"
+ elog "\thttp://k2net.hakuba.jp/targrey/index.en.html"
+ elog
+ elog "Activate targrey and set options using POSTGREY_OPTS in"
+ elog "/etc/conf.d/postgrey"
+ elog
+ fi
+
+ elog "Read postgrey documentation for more info (perldoc postgrey)."
+}