summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-07 14:37:24 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-07 14:37:24 +0000
commit685c161f966d71394ed6d23e81217c2e8fb10ddc (patch)
tree3ca8843730354e5d73eca4b5b212004c2fa401ee /mail-filter/tmda
parentTransfer Prefix keywords (diff)
downloadgentoo-2-685c161f966d71394ed6d23e81217c2e8fb10ddc.tar.gz
gentoo-2-685c161f966d71394ed6d23e81217c2e8fb10ddc.tar.bz2
gentoo-2-685c161f966d71394ed6d23e81217c2e8fb10ddc.zip
Bump for #149173, thanks to Sean C. McCord for some fixups
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter/tmda')
-rw-r--r--mail-filter/tmda/ChangeLog9
-rw-r--r--mail-filter/tmda/tmda-1.1.12.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/mail-filter/tmda/ChangeLog b/mail-filter/tmda/ChangeLog
index 0d60daf7e0aa..179283b1accb 100644
--- a/mail-filter/tmda/ChangeLog
+++ b/mail-filter/tmda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/tmda
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/ChangeLog,v 1.16 2007/02/22 01:04:04 peper Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/ChangeLog,v 1.17 2010/01/07 14:37:24 patrick Exp $
+
+*tmda-1.1.12 (07 Jan 2010)
+
+ 07 Jan 2010; Patrick Lauer <patrick@gentoo.org> +tmda-1.1.12.ebuild:
+ Bump for #149173, thanks to Sean C. McCord for some fixups
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/mail-filter/tmda/tmda-1.1.12.ebuild b/mail-filter/tmda/tmda-1.1.12.ebuild
new file mode 100644
index 000000000000..56cd830a3c14
--- /dev/null
+++ b/mail-filter/tmda/tmda-1.1.12.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/tmda/tmda-1.1.12.ebuild,v 1.1 2010/01/07 14:37:24 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.2
+ virtual/mta"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_compile () {
+ # Do not open /dev/tty when in batch mode. (bug #67150) -ticho
+ epatch ${FILESDIR}/tmda-1.0-non-interactive-tty.patch
+
+ ./compileall || die "tmda compilation failed"
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/Queue"
+ doins TMDA/Queue/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email/mime"
+ doins TMDA/pythonlib/email/mime/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+ dohtml -r htdocs/img
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe collectaddys def2html printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins ChangeLog tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+
+ insinto /usr/lib/tmda/contrib/dot-tmda
+ doins dot-tmda/*
+}