summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2013-02-18 13:17:18 +0000
committerEray Aslan <eras@gentoo.org>2013-02-18 13:17:18 +0000
commit16e8ddba63d8b8c6d776c0f01940845f346dde1d (patch)
treef86d0494d59a6f600d9bf295c3e225ee4154ea36 /mail-filter
parentMask mail-filter/opendkim-2.8.0_beta versions for testing. (diff)
downloadgentoo-2-16e8ddba63d8b8c6d776c0f01940845f346dde1d.tar.gz
gentoo-2-16e8ddba63d8b8c6d776c0f01940845f346dde1d.tar.bz2
gentoo-2-16e8ddba63d8b8c6d776c0f01940845f346dde1d.zip
Version bump for testing
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opendkim/ChangeLog10
-rw-r--r--mail-filter/opendkim/files/opendkim-2.8.0-free.patch32
-rw-r--r--mail-filter/opendkim/files/opendkim-2.8.0-gnutls.patch13
-rw-r--r--mail-filter/opendkim/files/opendkim-2.8.0-lber.patch48
-rw-r--r--mail-filter/opendkim/files/opendkim-2.8.0-libbsd.patch19
-rw-r--r--mail-filter/opendkim/files/opendkim-2.8.0-unbreak_upgrade.patch23
-rw-r--r--mail-filter/opendkim/opendkim-2.8.0_beta5.ebuild195
7 files changed, 339 insertions, 1 deletions
diff --git a/mail-filter/opendkim/ChangeLog b/mail-filter/opendkim/ChangeLog
index 5c35610b5c3c..114f505a7701 100644
--- a/mail-filter/opendkim/ChangeLog
+++ b/mail-filter/opendkim/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-filter/opendkim
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/ChangeLog,v 1.56 2013/01/22 08:11:10 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/ChangeLog,v 1.57 2013/02/18 13:17:18 eras Exp $
+
+*opendkim-2.8.0_beta5 (18 Feb 2013)
+
+ 18 Feb 2013; Eray Aslan <eras@gentoo.org> +files/opendkim-2.8.0-free.patch,
+ +files/opendkim-2.8.0-gnutls.patch, +files/opendkim-2.8.0-lber.patch,
+ +files/opendkim-2.8.0-libbsd.patch,
+ +files/opendkim-2.8.0-unbreak_upgrade.patch, +opendkim-2.8.0_beta5.ebuild:
+ Version bump for testing
*opendkim-2.7.4-r1 (22 Jan 2013)
diff --git a/mail-filter/opendkim/files/opendkim-2.8.0-free.patch b/mail-filter/opendkim/files/opendkim-2.8.0-free.patch
new file mode 100644
index 000000000000..d99fe84eff3a
--- /dev/null
+++ b/mail-filter/opendkim/files/opendkim-2.8.0-free.patch
@@ -0,0 +1,32 @@
+diff --git a/libopendkim/dkim-cache.c b/libopendkim/dkim-cache.c
+index 1321b74..1bb10e8 100644
+--- a/libopendkim/dkim-cache.c
++++ b/libopendkim/dkim-cache.c
+@@ -20,6 +20,7 @@
+ #include <errno.h>
+ #include <pthread.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ /* libdb includes */
+ #include <db.h>
+diff --git a/opendkim/util.c b/opendkim/util.c
+index e9de05e..37cdf46 100644
+--- a/opendkim/util.c
++++ b/opendkim/util.c
+@@ -1013,8 +1013,13 @@ dkimf_mkpath(char *path, size_t pathlen, char *root, char *file)
+ }
+ else if (root[0] == '\0') /* no root, use cwd */
+ {
+- (void) getcwd(path, pathlen);
+- strlcat(path, "/", pathlen);
++ char *p;
++
++ p = getcwd(path, pathlen);
++ if (p == NULL)
++ strlcpy(path, "./", pathlen);
++ else
++ strlcat(path, "/", pathlen);
+ strlcat(path, file, pathlen);
+ }
+ else /* use root */
diff --git a/mail-filter/opendkim/files/opendkim-2.8.0-gnutls.patch b/mail-filter/opendkim/files/opendkim-2.8.0-gnutls.patch
new file mode 100644
index 000000000000..c2520d3f22cf
--- /dev/null
+++ b/mail-filter/opendkim/files/opendkim-2.8.0-gnutls.patch
@@ -0,0 +1,13 @@
+--- opendkim/opendkim-testmsg.c 2013-02-15 01:36:45.000000000 +0200
++++ opendkim/opendkim-testmsg.c 2013-02-18 14:40:41.411736713 +0200
+@@ -15,6 +15,10 @@
+ #include <string.h>
+ #include <unistd.h>
+
++#ifdef USE_GNUTLS
++# include <gnutls/gnutls.h>
++#endif /* USE_GNUTLS */
++
+ /* libopendkim includes */
+ #include <dkim.h>
+
diff --git a/mail-filter/opendkim/files/opendkim-2.8.0-lber.patch b/mail-filter/opendkim/files/opendkim-2.8.0-lber.patch
new file mode 100644
index 000000000000..0fb5dc9fe7bf
--- /dev/null
+++ b/mail-filter/opendkim/files/opendkim-2.8.0-lber.patch
@@ -0,0 +1,48 @@
+only in patch2:
+unchanged:
+--- opendkim-2.8.0~beta5.orig/configure.ac
++++ opendkim-2.8.0~beta5/configure.ac
+@@ -1713,7 +1713,7 @@
+ AC_MSG_RESULT($ldappath)
+ ldap_found="yes"
+ OPENLDAP_CPPFLAGS="-I$ldappath/include"
+- OPENLDAP_LIBS="-L$ldappath/lib -lldap"
++ OPENLDAP_LIBS="-L$ldappath/lib -lldap -llber"
+ else
+ AC_MSG_ERROR(not found at $ldappath)
+ fi
+@@ -1727,7 +1727,7 @@
+ AC_MSG_RESULT($d)
+ ldap_found="yes"
+ OPENLDAP_CPPFLAGS="-I$ldappath/include"
+- OPENLDAP_LIBS="-L$ldappath/lib -lldap"
++ OPENLDAP_LIBS="-L$ldappath/lib -lldap -llber"
+ break
+ fi
+ done
+only in patch2:
+unchanged:
+--- opendkim-2.8.0~beta5.orig/opendkim/Makefile.am
++++ opendkim-2.8.0~beta5/opendkim/Makefile.am
+@@ -28,7 +28,7 @@
+ opendkim_CFLAGS = $(PTHREAD_CFLAGS) $(LIBCRYPTO_CFLAGS) $(COV_CFLAGS)
+ opendkim_CPPFLAGS = -I$(srcdir)/../libopendkim $(LIBCRYPTO_CPPFLAGS)
+ opendkim_LDFLAGS = $(LIBCRYPTO_LIBDIRS) $(LIBMILTER_LIBDIRS) $(PTHREAD_CFLAGS) $(COV_LDFLAGS)
+-opendkim_LDADD = ../libopendkim/libopendkim.la $(LIBMILTER_LIBS) $(LIBCRYPTO_LIBS) $(PTHREAD_LIBS) $(COV_LIBADD)
++opendkim_LDADD = ../libopendkim/libopendkim.la $(LIBMILTER_LIBS) $(LIBCRYPTO_LIBS) $(PTHREAD_LIBS) $(COV_LIBADD) $(LIBRESOLV)
+ if STRL
+ opendkim_CFLAGS += -I$(top_srcdir)/libstrl
+ opendkim_LDADD += ../libstrl/libstrl.la
+only in patch2:
+unchanged:
+--- opendkim-2.8.0~beta5.orig/libopendkim/tests/Makefile.am
++++ opendkim-2.8.0~beta5/libopendkim/tests/Makefile.am
+@@ -6,7 +6,7 @@
+ AM_CFLAGS += -g
+ endif
+
+-LDADD = ../libopendkim.la $(COV_LIBADD) $(LIBCRYPTO_LIBS)
++LDADD = ../libopendkim.la $(COV_LIBADD) $(LIBCRYPTO_LIBS) $(LIBRESOLV)
+ AM_CPPFLAGS = -I..
+
+ if STRL
diff --git a/mail-filter/opendkim/files/opendkim-2.8.0-libbsd.patch b/mail-filter/opendkim/files/opendkim-2.8.0-libbsd.patch
new file mode 100644
index 000000000000..1ccf0aadc3cd
--- /dev/null
+++ b/mail-filter/opendkim/files/opendkim-2.8.0-libbsd.patch
@@ -0,0 +1,19 @@
+--- libopendkim/tests/t-test153.c 2013-02-12 23:28:23.000000000 +0200
++++ libopendkim/tests/t-test153.c 2013-02-18 14:31:56.012827510 +0200
+@@ -14,6 +14,16 @@
+ #include <string.h>
+ #include <stdio.h>
+
++/* libbsd if found */
++#ifdef USE_BSD_H
++# include <bsd/string.h>
++#endif /* USE_BSD_H */
++
++/* libstrl if needed */
++#ifdef USE_STRL_H
++# include <strl.h>
++#endif /* USE_STRL_H */
++
+ #ifdef USE_GNUTLS
+ # include <gnutls/gnutls.h>
+ #endif /* USE_GNUTLS */
diff --git a/mail-filter/opendkim/files/opendkim-2.8.0-unbreak_upgrade.patch b/mail-filter/opendkim/files/opendkim-2.8.0-unbreak_upgrade.patch
new file mode 100644
index 000000000000..433d5995f4bd
--- /dev/null
+++ b/mail-filter/opendkim/files/opendkim-2.8.0-unbreak_upgrade.patch
@@ -0,0 +1,23 @@
+--- configure.ac 2013-02-12 23:29:44.000000000 +0200
++++ configure.ac 2013-02-18 13:58:28.499097605 +0200
+@@ -240,11 +240,15 @@
+ # we need to include <strl.h> if:
+ # (a) strlcat and strlcpy weren't found, since we'll be rolling our own; OR
+ # (b) an installed strl.h was found and no bsd/string.h was found
+-if test x"$strl_h_found" = x"yes" -o \( x"$strl_found" = x"no" -a x"$libstrl_found" = x"no" \) -a x"$bsdstrl_h_found" = x"no"
+-then
+- AC_DEFINE([USE_STRL_H], 1,
+- [Define to 1 if you need to include <strl.h> to get the `strlcat()' and `strlcpy()' functions.])
+-fi
++
++# Gentoo specific: Don't include strl.h - breaks upgrading from
++# <=mail-filter/opendkim-2.7.2. We link against libbsd always.
++
++#if test x"$strl_h_found" = x"yes" -o \( x"$strl_found" = x"no" -a x"$libstrl_found" = x"no" \) -a x"$bsdstrl_h_found" = x"no"
++#then
++# AC_DEFINE([USE_STRL_H], 1,
++# [Define to 1 if you need to include <strl.h> to get the `strlcat()' and `strlcpy()' functions.])
++#fi
+
+ if test x"$bsdstrl_h_found" = x"yes"
+ then
diff --git a/mail-filter/opendkim/opendkim-2.8.0_beta5.ebuild b/mail-filter/opendkim/opendkim-2.8.0_beta5.ebuild
new file mode 100644
index 000000000000..5edf50a56fe0
--- /dev/null
+++ b/mail-filter/opendkim/opendkim-2.8.0_beta5.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendkim/opendkim-2.8.0_beta5.ebuild,v 1.1 2013/02/18 13:17:18 eras Exp $
+
+EAPI=5
+inherit eutils db-use autotools user
+
+# for betas
+MY_P=${P/_b/.B}
+S=${WORKDIR}/${PN}-2.8.0
+SRC_URI="mirror://sourceforge/opendkim/${MY_P}.tar.gz"
+
+DESCRIPTION="A milter-based application to provide DKIM signing and verification"
+HOMEPAGE="http://opendkim.org"
+#SRC_URI="mirror://sourceforge/opendkim/${P}.tar.gz"
+
+LICENSE="Sendmail-Open-Source BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+berkdb gnutls ldap lua opendbx poll sasl +ssl static-libs unbound"
+
+DEPEND="|| ( mail-filter/libmilter mail-mta/sendmail )
+ dev-libs/libbsd
+ ssl? ( >=dev-libs/openssl-0.9.8 )
+ berkdb? ( >=sys-libs/db-3.2 )
+ opendbx? ( >=dev-db/opendbx-1.4.0 )
+ lua? ( dev-lang/lua )
+ ldap? ( net-nds/openldap )
+ sasl? ( dev-libs/cyrus-sasl )
+ unbound? ( >=net-dns/unbound-1.4.1 net-dns/dnssec-root )
+ !unbound? ( net-libs/ldns )
+ gnutls? ( >=net-libs/gnutls-2.11.7 )"
+
+RDEPEND="${DEPEND}
+ sys-process/psmisc"
+
+REQUIRED_USE="sasl? ( ldap )"
+
+pkg_setup() {
+ enewgroup milter
+ # mail-milter/spamass-milter creates milter user with this home directory
+ # For consistency reasons, milter user must be created here with this home directory
+ # even though this package doesn't need a home directory for this user (#280571)
+ enewuser milter -1 -1 /var/lib/milter milter
+}
+
+src_prepare() {
+ sed -i -e 's:/var/db/dkim:/etc/opendkim:g' \
+ -e 's:/var/db/opendkim:/var/lib/opendkim:g' \
+ -e 's:/etc/mail:/etc/opendkim:g' \
+ -e 's:mailnull:milter:g' \
+ -e 's:^#[[:space:]]*PidFile.*:PidFile /var/run/opendkim/opendkim.pid:' \
+ opendkim/opendkim.conf.sample opendkim/opendkim.conf.simple.in \
+ stats/opendkim-reportstats || die
+
+ sed -i -e 's:dist_doc_DATA:dist_html_DATA:' libopendkim/docs/Makefile.am \
+ || die
+
+ # don't go over the sock length and fail
+ sed -i -e '/^sock/s/t-sign-ss-macro-value-file.sock/t-s-s-m-v-f.sock/' \
+ opendkim/tests/t-sign-ss-macro-value-file.lua || die
+
+ epatch "${FILESDIR}/${PN}-2.8.0-unbreak_upgrade.patch"
+ epatch "${FILESDIR}/${PN}-2.8.0-free.patch"
+ epatch "${FILESDIR}/${PN}-2.8.0-lber.patch"
+ epatch "${FILESDIR}/${PN}-2.8.0-libbsd.patch"
+ epatch "${FILESDIR}/${PN}-2.8.0-gnutls.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use berkdb ; then
+ myconf=$(db_includedir)
+ myconf="--with-db-incdir=${myconf#-I}"
+ myconf+=" --enable-popauth"
+ myconf+=" --enable-query_cache"
+ myconf+=" --enable-stats"
+ fi
+ if use unbound; then
+ myconf+=" --with-unbound"
+ else
+ myconf+=" --with-ldns"
+ fi
+ if use ldap; then
+ myconf+=" $(use_with sasl)"
+ fi
+ econf \
+ $(use_with berkdb db) \
+ $(use_with opendbx odbx) \
+ $(use_with lua) \
+ $(use_enable lua rbl) \
+ $(use_with ldap openldap) \
+ $(use_enable poll) \
+ $(use_enable static-libs static) \
+ $(use_with gnutls) \
+ ${myconf} \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --enable-filter \
+ --enable-adsp_lists \
+ --enable-dkim_reputation \
+ --enable-identity_header \
+ --enable-rate_limit \
+ --enable-redirect \
+ --enable-resign \
+ --enable-replace_rules \
+ --enable-default_sender \
+ --enable-sender_macro \
+ --enable-vbr \
+ --disable-rpath \
+ --disable-live-testing \
+ --with-test-socket=/tmp/opendkim-S
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dosbin stats/opendkim-reportstats
+ newinitd "${FILESDIR}/opendkim.init.r3" opendkim
+ dodir /etc/opendkim /var/lib/opendkim
+ fowners milter:milter /var/lib/opendkim
+
+ # default configuration
+ if [ ! -f "${ROOT}"/etc/opendkim/opendkim.conf ]; then
+ grep ^[^#] "${S}"/opendkim/opendkim.conf.simple \
+ > "${D}"/etc/opendkim/opendkim.conf
+ if use unbound; then
+ echo TrustedAnchorFile /etc/dnssec/root-anchors.txt >> "${D}"/etc/opendkim/opendkim.conf
+ fi
+ echo UserID milter >> "${D}"/etc/opendkim/opendkim.conf
+ if use berkdb; then
+ echo Statistics /var/lib/opendkim/stats.dat >> \
+ "${D}"/etc/opendkim/opendkim.conf
+ fi
+ fi
+
+ use static-libs || find "${D}" -name "*.la" -delete
+}
+
+pkg_postinst() {
+ elog "If you want to sign your mail messages and need some help"
+ elog "please run:"
+ elog " emerge --config ${CATEGORY}/${PN}"
+ elog "It will help you create your key and give you hints on how"
+ elog "to configure your DNS and MTA."
+
+ ewarn "Make sure your MTA has r/w access to the socket file."
+ ewarn "This can be done either by setting UMask to 002 and adding MTA's user"
+ ewarn "to milter group or you can simply set UMask to 000."
+}
+
+pkg_config() {
+ local selector keysize pubkey
+
+ read -p "Enter the selector name (default ${HOSTNAME}): " selector
+ [[ -n "${selector}" ]] || selector=${HOSTNAME}
+ if [[ -z "${selector}" ]]; then
+ eerror "Oddly enough, you don't have a HOSTNAME."
+ return 1
+ fi
+ if [[ -f "${ROOT}"etc/opendkim/${selector}.private ]]; then
+ ewarn "The private key for this selector already exists."
+ else
+ keysize=1024
+ # generate the private and public keys
+ opendkim-genkey -b ${keysize} -D "${ROOT}"etc/opendkim/ \
+ -s ${selector} -d '(your domain)' && \
+ chown milter:milter \
+ "${ROOT}"etc/opendkim/"${selector}".private || \
+ { eerror "Failed to create private and public keys." ; return 1; }
+ chmod go-r "${ROOT}"etc/opendkim/"${selector}".private
+ fi
+
+ # opendkim selector configuration
+ echo
+ einfo "Make sure you have the following settings in your /etc/opendkim/opendkim.conf:"
+ einfo " Keyfile /etc/opendkim/${selector}.private"
+ einfo " Selector ${selector}"
+
+ # MTA configuration
+ echo
+ einfo "If you are using Postfix, add following lines to your main.cf:"
+ einfo " smtpd_milters = unix:/var/run/opendkim/opendkim.sock"
+ einfo " non_smtpd_milters = unix:/var/run/opendkim/opendkim.sock"
+ einfo " and read http://www.postfix.org/MILTER_README.html"
+
+ # DNS configuration
+ einfo "After you configured your MTA, publish your key by adding this TXT record to your domain:"
+ cat "${ROOT}"etc/opendkim/${selector}.txt
+ einfo "t=y signifies you only test the DKIM on your domain. See following page for the complete list of tags:"
+ einfo " http://www.dkim.org/specs/rfc4871-dkimbase.html#key-text"
+ einfo
+ einfo "Also look at the ADSP http://tools.ietf.org/html/rfc5617"
+}