summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-28 03:23:41 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-28 03:23:41 +0000
commit634af849500de4a391b372275cec754bf3cd435e (patch)
tree63e2edcf29b1d7fc38b528895070c959632775f9 /mail-filter
parentAdded ~sparc, ~mips (Manifest recommit) (diff)
downloadgentoo-2-634af849500de4a391b372275cec754bf3cd435e.tar.gz
gentoo-2-634af849500de4a391b372275cec754bf3cd435e.tar.bz2
gentoo-2-634af849500de4a391b372275cec754bf3cd435e.zip
QA - fix use invocation
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/dspam/ChangeLog5
-rw-r--r--mail-filter/dspam/dspam-3.0.0.ebuild14
2 files changed, 11 insertions, 8 deletions
diff --git a/mail-filter/dspam/ChangeLog b/mail-filter/dspam/ChangeLog
index 571259deb660..6368f2235394 100644
--- a/mail-filter/dspam/ChangeLog
+++ b/mail-filter/dspam/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-filter/dspam
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.2 2004/06/27 10:15:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.3 2004/06/28 03:23:41 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org> dspam-3.0.0.ebuild:
+ QA - fix use invocation
27 Jun 2004; David Holm <dholm@gentoo.org> dspam-3.0.0.ebuild:
Added to ~ppc.
diff --git a/mail-filter/dspam/dspam-3.0.0.ebuild b/mail-filter/dspam/dspam-3.0.0.ebuild
index e3327c2afc00..a2b3529e7cb5 100644
--- a/mail-filter/dspam/dspam-3.0.0.ebuild
+++ b/mail-filter/dspam/dspam-3.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.0.0.ebuild,v 1.2 2004/06/27 10:15:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.0.0.ebuild,v 1.3 2004/06/28 03:23:41 agriffis Exp $
inherit eutils
@@ -48,13 +48,13 @@ src_compile() {
use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
# select storage driver
- if [ `use mysql` ] ; then
+ if use mysql ; then
myconf="${myconf} --with-storage-driver=mysql_drv"
myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
# an experimental feature available with MySQL backend
- if [ `use neural` ] ; then
+ if use neural ; then
myconf="${myconf} --enable-neural-networking"
fi
else
@@ -91,7 +91,7 @@ src_install () {
# documentation
dodoc CHANGELOG LICENSE README RELEASE.NOTES
dodoc ${FILESDIR}/README.postfix ${FILESDIR}/README.qmail
- if [ `use mysql` ] ; then
+ if use mysql ; then
newdoc tools.mysql_drv/README README.MYSQL
fi
@@ -102,7 +102,7 @@ src_install () {
doins ${FILESDIR}/untrusted.mailer_args
# database related configuration and scripts
- if [ `use mysql` ] ; then
+ if use mysql ; then
local PASSWORD="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
# Replace some variables in the configuration files
@@ -180,14 +180,14 @@ src_install () {
}
pkg_postinst() {
- if [ `use mysql` ] ; then
+ if use mysql ; then
einfo "To setup dspam to run out-of-the-box on your system with a mysql database, run:"
einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
fi
}
pkg_config () {
- if [ `use mysql` ] ; then
+ if use mysql ; then
${CONFIGDIR}/mysql_install_db
mv ${CONFIGDIR}/mysql.data ${HOMEDIR}
fi