summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-01-01 22:26:57 +0000
committerTorsten Veller <tove@gentoo.org>2007-01-01 22:26:57 +0000
commit9a5b4b9e18424ba1a98dc5cc3705ca09be874239 (patch)
tree0188f50f8c646bddbc7116f75f9b2787e1bbd4ee /mail-filter
parentQuote has_version argument because of > operator. Use full atoms for built_wi... (diff)
downloadgentoo-2-9a5b4b9e18424ba1a98dc5cc3705ca09be874239.tar.gz
gentoo-2-9a5b4b9e18424ba1a98dc5cc3705ca09be874239.tar.bz2
gentoo-2-9a5b4b9e18424ba1a98dc5cc3705ca09be874239.zip
Version bump
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/bogofilter/ChangeLog9
-rw-r--r--mail-filter/bogofilter/bogofilter-1.1.4.ebuild68
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-1.1.43
3 files changed, 78 insertions, 2 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index 1008046c77d5..72da988cd0b4 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/bogofilter
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.79 2006/12/26 22:49:36 ticho Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.80 2007/01/01 22:26:57 tove Exp $
+
+*bogofilter-1.1.4 (01 Jan 2007)
+
+ 01 Jan 2007; Torsten Veller <tove@gentoo.org> +bogofilter-1.1.4.ebuild:
+ Version bump
26 Dec 2006; Andrej Kacian <ticho@gentoo.org>
-files/1.1.3-patch.1142.Makefile.am, +files/1.1.3-patch.1142.Makefile.in,
diff --git a/mail-filter/bogofilter/bogofilter-1.1.4.ebuild b/mail-filter/bogofilter/bogofilter-1.1.4.ebuild
new file mode 100644
index 000000000000..61adc7f09215
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.1.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.4.ebuild,v 1.1 2007/01/01 22:26:57 tove Exp $
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gsl berkdb sqlite"
+
+DEPEND="virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.2.6 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+src_compile() {
+ local myconf=""
+ myconf="$(use_with !gsl included-gsl)"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ einfo "Both berkdb and sqlite are in USE."
+ einfo "Choosing berkdb as default database backend."
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ elif ! use berkdb ; then
+ einfo "Using berkdb as database backend."
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite} || die "dodoc failed"
+
+ dohtml doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ echo
+}
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-1.1.4 b/mail-filter/bogofilter/files/digest-bogofilter-1.1.4
new file mode 100644
index 000000000000..a8ed949a91dd
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-1.1.4
@@ -0,0 +1,3 @@
+MD5 6c72a2e482908cf78288c3bc6b11f57b bogofilter-1.1.4.tar.bz2 797924
+RMD160 221819bcd9d190f3a1ca5bf56f6d49fa20d55895 bogofilter-1.1.4.tar.bz2 797924
+SHA256 2cd09fac0c1e425d54028415c238627847543a5c03adf7a79d71158129d2b419 bogofilter-1.1.4.tar.bz2 797924