summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-22 16:17:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-22 16:17:26 +0000
commit1b74174436aa91365a6950f113625bdcd1eacaff (patch)
tree5a670b44b653ff8f8b7e5e7cbc73dbcdf257aaea /mail-mta/ssmtp
parentBackport -openpam.patch from 0.4.2. (diff)
downloadgentoo-2-1b74174436aa91365a6950f113625bdcd1eacaff.tar.gz
gentoo-2-1b74174436aa91365a6950f113625bdcd1eacaff.tar.bz2
gentoo-2-1b74174436aa91365a6950f113625bdcd1eacaff.zip
Make mta provision optional, so that you can install ssmtp side-by-side with (some) other mta ebuilds. Closes bug #289973. Also only block msmtp if it has the equivalent mta support enabled.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'mail-mta/ssmtp')
-rw-r--r--mail-mta/ssmtp/ChangeLog10
-rw-r--r--mail-mta/ssmtp/metadata.xml11
-rw-r--r--mail-mta/ssmtp/ssmtp-2.64-r2.ebuild108
3 files changed, 123 insertions, 6 deletions
diff --git a/mail-mta/ssmtp/ChangeLog b/mail-mta/ssmtp/ChangeLog
index 323c626c7485..5f1579f846e7 100644
--- a/mail-mta/ssmtp/ChangeLog
+++ b/mail-mta/ssmtp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-mta/ssmtp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ChangeLog,v 1.110 2011/03/28 09:21:43 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ChangeLog,v 1.111 2011/04/22 16:17:26 flameeyes Exp $
+
+*ssmtp-2.64-r2 (22 Apr 2011)
+
+ 22 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org> +ssmtp-2.64-r2.ebuild,
+ metadata.xml:
+ Make mta provision optional, so that you can install ssmtp side-by-side with
+ (some) other mta ebuilds. Closes bug #289973. Also only block msmtp if it has
+ the equivalent mta support enabled.
28 Mar 2011; Eray Aslan <eras@gentoo.org> ssmtp-2.62-r8.ebuild,
ssmtp-2.64-r1.ebuild:
diff --git a/mail-mta/ssmtp/metadata.xml b/mail-mta/ssmtp/metadata.xml
index 1cd964960caa..016fb7ba847d 100644
--- a/mail-mta/ssmtp/metadata.xml
+++ b/mail-mta/ssmtp/metadata.xml
@@ -1,9 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-mail</herd>
-<use>
- <flag name='md5sum'>Enables MD5 summing for ssmtp</flag>
- <flag name='maxsysuid'>Allow to define a MinUserId</flag>
-</use>
+ <herd>net-mail</herd>
+ <use>
+ <flag name='md5sum'>Enables MD5 summing for ssmtp</flag>
+ <flag name='maxsysuid'>Allow to define a MinUserId</flag>
+ <flag name='mta'>Install symlinks for sendmail-compatible MTA.</flag>
+ </use>
</pkgmetadata>
diff --git a/mail-mta/ssmtp/ssmtp-2.64-r2.ebuild b/mail-mta/ssmtp/ssmtp-2.64-r2.ebuild
new file mode 100644
index 000000000000..3871d7b70af3
--- /dev/null
+++ b/mail-mta/ssmtp/ssmtp-2.64-r2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/ssmtp/ssmtp-2.64-r2.ebuild,v 1.1 2011/04/22 16:17:26 flameeyes Exp $
+
+EAPI="4"
+
+PATCHSET=2
+
+WANT_AUTOMAKE=none
+
+inherit eutils autotools
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
+HOMEPAGE="ftp://ftp.debian.org/debian/pool/main/s/ssmtp/"
+SRC_URI="mirror://debian/pool/main/s/ssmtp/${P/-/_}.orig.tar.bz2
+ http://dev.gentoo.org/~flameeyes/ssmtp/${P}-patches-${PATCHSET}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ipv6 +ssl gnutls +mta"
+
+DEPEND="ssl? (
+ !gnutls? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls )
+ )"
+RDEPEND="${DEPEND}
+ net-mail/mailbase
+ mta? (
+ !net-mail/mailwrapper
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp[mta]
+ !mail-mta/nbsmtp
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ )"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+pkg_setup() {
+ enewgroup ssmtp
+}
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" EPATCH_SOURCE="${WORKDIR}/patches" \
+ epatch
+
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/ssmtp \
+ $(use_enable ssl) $(use_with gnutls) \
+ $(use_enable ipv6 inet6) \
+ --enable-md5auth
+}
+
+src_compile() {
+ emake etcdir="${EPREFIX}"/etc || die
+}
+
+src_install() {
+ dosbin ssmtp
+
+ doman ssmtp.8 ssmtp.conf.5
+ dodoc ChangeLog CHANGELOG_OLD INSTALL README TLS
+ newdoc ssmtp.lsm DESC
+
+ insinto /etc/ssmtp
+ doins ssmtp.conf revaliases
+
+ local conffile="${ED}etc/ssmtp/ssmtp.conf"
+
+ # Sorry about the weird indentation, I couldn't figure out a cleverer way
+ # to do this without having horribly >80 char lines.
+ sed -i -e "s:^hostname=:\n# Gentoo bug #47562\\
+# Commenting the following line will force ssmtp to figure\\
+# out the hostname itself.\n\\
+# hostname=:" \
+ "${conffile}" || die "sed failed"
+
+ # Comment rewriteDomain (bug #243364)
+ sed -i -e "s:^rewriteDomain=:#rewriteDomain=:" "${conffile}"
+
+ # Set restrictive perms on ssmtp.conf as per #187841, #239197
+ # Protect the ssmtp configfile from being readable by regular users as it
+ # may contain login/password data to auth against a the mailhub used.
+ fowners root:ssmtp /etc/ssmtp/ssmtp.conf
+ fperms 640 /etc/ssmtp/ssmtp.conf
+
+ fowners root:ssmtp /usr/sbin/ssmtp
+ fperms 2711 /usr/sbin/ssmtp
+
+ if use mta; then
+ dosym ../sbin/ssmtp /usr/lib/sendmail
+ dosym ../sbin/ssmtp /usr/bin/sendmail
+ dosym ssmtp /usr/sbin/sendmail
+ dosym ../sbin/ssmtp /usr/bin/mailq
+ dosym ../sbin/ssmtp /usr/bin/newaliases
+ fi
+}