summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-09 11:51:36 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-09 11:51:36 +0000
commit78cd17a185b96fc91a15bd8543a2c91f09e2e141 (patch)
tree3f4b9747bcf8eb78cd7e86c116649012448920e2 /mate-base/mate-desktop
parentAdd initial emacs support. (diff)
downloadgentoo-2-78cd17a185b96fc91a15bd8543a2c91f09e2e141.tar.gz
gentoo-2-78cd17a185b96fc91a15bd8543a2c91f09e2e141.tar.bz2
gentoo-2-78cd17a185b96fc91a15bd8543a2c91f09e2e141.zip
Version bump to 1.8.1.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'mate-base/mate-desktop')
-rw-r--r--mate-base/mate-desktop/ChangeLog7
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.8.1.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/mate-base/mate-desktop/ChangeLog b/mate-base/mate-desktop/ChangeLog
index 6835f9cf03dc..59012624ac34 100644
--- a/mate-base/mate-desktop/ChangeLog
+++ b/mate-base/mate-desktop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mate-base/mate-desktop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-desktop/ChangeLog,v 1.8 2014/05/07 12:31:58 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-desktop/ChangeLog,v 1.9 2014/05/09 11:51:36 tomwij Exp $
+
+*mate-desktop-1.8.1 (09 May 2014)
+
+ 09 May 2014; Tom Wijsman <TomWij@gentoo.org> +mate-desktop-1.8.1.ebuild:
+ Version bump to 1.8.1.
*mate-desktop-1.8.0-r1 (07 May 2014)
diff --git a/mate-base/mate-desktop/mate-desktop-1.8.1.ebuild b/mate-base/mate-desktop/mate-desktop-1.8.1.ebuild
new file mode 100644
index 000000000000..7974cc920eee
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.8.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-desktop/mate-desktop-1.8.1.ebuild,v 1.1 2014/05/09 11:51:36 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit gnome2 multilib python-r1 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="X startup-notification"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libunique-1:1
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.4:2
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11:0
+ >=x11-libs/libXrandr-1.2:0
+ virtual/libintl:0
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ >=gnome-base/dconf-0.10:0
+ sys-devel/gettext:*
+ >=x11-proto/randrproto-1.2:0
+ x11-proto/xproto:0
+ virtual/pkgconfig:*"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-mate-conf-import \
+ --with-gtk=2.0 \
+ $(use_with X x) \
+ $(use_enable startup-notification)
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+src_install() {
+ gnome2_src_install
+
+ python_replicate_script "${ED}"/usr/bin/mate-conf-import
+
+ # Remove installed files that cause collissions.
+ rm -rf "${ED}"/usr/share/help/C/{lgpl,gpl,fdl}
+}