summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-22 19:47:21 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-22 19:47:21 +0000
commit7e1df896df7cbe2311e01ce4147e7fc517c88182 (patch)
tree8fde4bc66ce839593184795fbeb1763f16e72e67 /mate-extra/mate-dialogs
parentVersion bump (diff)
downloadgentoo-2-7e1df896df7cbe2311e01ce4147e7fc517c88182.tar.gz
gentoo-2-7e1df896df7cbe2311e01ce4147e7fc517c88182.tar.bz2
gentoo-2-7e1df896df7cbe2311e01ce4147e7fc517c88182.zip
Version bump to 1.8.0.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'mate-extra/mate-dialogs')
-rw-r--r--mate-extra/mate-dialogs/ChangeLog7
-rw-r--r--mate-extra/mate-dialogs/mate-dialogs-1.8.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/mate-extra/mate-dialogs/ChangeLog b/mate-extra/mate-dialogs/ChangeLog
index 5f497d66f983..6672880132a6 100644
--- a/mate-extra/mate-dialogs/ChangeLog
+++ b/mate-extra/mate-dialogs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mate-extra/mate-dialogs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mate-extra/mate-dialogs/ChangeLog,v 1.3 2014/03/10 22:01:00 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/mate-extra/mate-dialogs/ChangeLog,v 1.4 2014/04/22 19:47:21 tomwij Exp $
+
+*mate-dialogs-1.8.0 (22 Apr 2014)
+
+ 22 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +mate-dialogs-1.8.0.ebuild:
+ Version bump to 1.8.0.
10 Mar 2014; Tom Wijsman <TomWij@gentoo.org> mate-dialogs-1.6.2.ebuild:
Further review of dependencies.
diff --git a/mate-extra/mate-dialogs/mate-dialogs-1.8.0.ebuild b/mate-extra/mate-dialogs/mate-dialogs-1.8.0.ebuild
new file mode 100644
index 000000000000..079820ef0f6f
--- /dev/null
+++ b/mate-extra/mate-dialogs/mate-dialogs-1.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mate-extra/mate-dialogs/mate-dialogs-1.8.0.ebuild,v 1.1 2014/04/22 19:47:21 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Display MATE dialogs from the commandline and shell scripts"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify"
+
+RDEPEND="app-text/rarian:0
+ >=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11:0
+ virtual/libintl:0
+ libnotify? ( >=x11-libs/libnotify-0.7.0:0 )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ >=mate-base/mate-common-1.6:0
+ >=sys-devel/gettext-0.14:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ gnome2_src_configure \
+ --with-gtk=2.0 \
+ $(use_enable libnotify)
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"