summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-23 12:19:42 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-23 12:19:42 +0000
commit305fbaa54ac52895ff6ec881b9e3414b8933d44f (patch)
tree6bd2e940208fdc6b8653687e9f5576a500db1a57 /mate-extra
parent[QA] Remove obselete entries that were last rited, 30 days have passed and fo... (diff)
downloadgentoo-2-305fbaa54ac52895ff6ec881b9e3414b8933d44f.tar.gz
gentoo-2-305fbaa54ac52895ff6ec881b9e3414b8933d44f.tar.bz2
gentoo-2-305fbaa54ac52895ff6ec881b9e3414b8933d44f.zip
Version bump to 1.8.0.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-polkit/ChangeLog7
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/mate-extra/mate-polkit/ChangeLog b/mate-extra/mate-polkit/ChangeLog
index 4ea035928b75..161d687695cf 100644
--- a/mate-extra/mate-polkit/ChangeLog
+++ b/mate-extra/mate-polkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mate-extra/mate-polkit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mate-extra/mate-polkit/ChangeLog,v 1.3 2014/03/10 22:03:28 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/mate-extra/mate-polkit/ChangeLog,v 1.4 2014/04/23 12:19:42 tomwij Exp $
+
+*mate-polkit-1.8.0 (23 Apr 2014)
+
+ 23 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +mate-polkit-1.8.0.ebuild:
+ Version bump to 1.8.0.
10 Mar 2014; Tom Wijsman <TomWij@gentoo.org> mate-polkit-1.6.1.ebuild:
Further review of dependencies.
diff --git a/mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild b/mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild
new file mode 100644
index 000000000000..94ffda2b69ff
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mate-extra/mate-polkit/mate-polkit-1.8.0.ebuild,v 1.1 2014/04/23 12:19:42 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="A MATE specific DBUS session bus service that is used to bring up authentication dialogs"
+HOMEPAGE="https://github.com/mate-desktop/mate-polkit"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+introspection"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ >=sys-auth/polkit-0.102:0[introspection?]
+ >=x11-libs/gtk+-2.24:2[introspection?]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:0 )"
+
+# We call gtkdocize so we need to depend on gtk-doc.
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-1.3:0
+ >=dev-util/intltool-0.35:*
+ mate-base/mate-common:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ !<gnome-extra/polkit-gnome-0.102:0"
+
+# Entropy PMS specific. This way we can install the pkg into the build chroots.
+ENTROPY_RDEPEND="!lxde-base/lxpolkit"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+DOCS="AUTHORS HACKING NEWS README"