summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-11-07 10:45:11 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-11-07 10:45:11 +0000
commitd3fd5ff20acfa337428dcdd5dc7a67ee7b2fa188 (patch)
tree1cd82040f2e27120729e94731ac80ab3ab653d62 /media-gfx/aaphoto/aaphoto-0.43.1.ebuild
parentFixed HOMEPAGE (diff)
downloadgentoo-2-d3fd5ff20acfa337428dcdd5dc7a67ee7b2fa188.tar.gz
gentoo-2-d3fd5ff20acfa337428dcdd5dc7a67ee7b2fa188.tar.bz2
gentoo-2-d3fd5ff20acfa337428dcdd5dc7a67ee7b2fa188.zip
Initial commit, wrt bug #486110. Package will be maintained by Ferenc Erki <erkiferenc AT gmail.com> through proxy maintainers
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'media-gfx/aaphoto/aaphoto-0.43.1.ebuild')
-rw-r--r--media-gfx/aaphoto/aaphoto-0.43.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/aaphoto/aaphoto-0.43.1.ebuild b/media-gfx/aaphoto/aaphoto-0.43.1.ebuild
new file mode 100644
index 000000000000..58376b0de08b
--- /dev/null
+++ b/media-gfx/aaphoto/aaphoto-0.43.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/aaphoto/aaphoto-0.43.1.ebuild,v 1.1 2013/11/07 10:45:11 pinkbyte Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AM_OPTS="--force-missing" # overwrite old 'missing' script
+inherit autotools-utils
+
+DESCRIPTION="Automatic color correction and resizing of photos"
+HOMEPAGE="http://log69.com/aaphoto.html http://github.com/log69/aaphoto"
+SRC_URI="http://github.com/log69/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/jasper[jpeg]
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 2 ]] ) \
+ && die "Sorry, but gcc 4.2 or higher is required"
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}