summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-12-02 16:11:48 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-12-02 16:11:48 +0000
commitcaf0f716a4bfb8639b0b1682b15947f545ca4463 (patch)
tree29390cf48217f8dd2c46bb5ac010d497d4769cee /media-gfx/asymptote/files
parentFix sandbox violation, bug #243040. (diff)
downloadgentoo-2-caf0f716a4bfb8639b0b1682b15947f545ca4463.tar.gz
gentoo-2-caf0f716a4bfb8639b0b1682b15947f545ca4463.tar.bz2
gentoo-2-caf0f716a4bfb8639b0b1682b15947f545ca4463.zip
Version bump
(Portage version: 2.2_rc16/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'media-gfx/asymptote/files')
-rw-r--r--media-gfx/asymptote/files/asymptote-1.54-configure-ac.patch (renamed from media-gfx/asymptote/files/asymptote-1.52-configure-ac.patch)23
-rw-r--r--media-gfx/asymptote/files/asymptote-1.54-xdg-utils.patch (renamed from media-gfx/asymptote/files/asymptote-1.52-xdg-utils.patch)11
2 files changed, 23 insertions, 11 deletions
diff --git a/media-gfx/asymptote/files/asymptote-1.52-configure-ac.patch b/media-gfx/asymptote/files/asymptote-1.54-configure-ac.patch
index 33b0b7090059..7a09244e2db0 100644
--- a/media-gfx/asymptote/files/asymptote-1.52-configure-ac.patch
+++ b/media-gfx/asymptote/files/asymptote-1.54-configure-ac.patch
@@ -1,7 +1,9 @@
-diff -r -U2 asymptote-1.52.orig/configure.ac asymptote-1.52/configure.ac
---- asymptote-1.52.orig/configure.ac 2008-11-25 15:10:32.000000000 +0600
-+++ asymptote-1.52/configure.ac 2008-11-27 04:40:24.000000000 +0600
-@@ -80,8 +80,14 @@
+Index: asymptote-1.54/configure.ac
+===================================================================
+--- asymptote-1.54.orig/configure.ac
++++ asymptote-1.54/configure.ac
+@@ -79,10 +79,16 @@ if test "$GXX" = yes ; then
+ fi
fi
-AC_CHECK_HEADER(fftw3.h,
@@ -18,14 +20,18 @@ diff -r -U2 asymptote-1.52.orig/configure.ac asymptote-1.52/configure.ac
+fi
GCVERSION=gc-7.1
-@@ -120,5 +126,5 @@
+
+@@ -119,7 +125,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
CPPFLAGS_SAVE=$CPPFLAGS
CPPFLAGS=$CPPFLAGS" $INCL"
- AC_CHECK_HEADER(gc.h,
+ AC_CHECK_HEADER([gc/gc.h],
AC_CHECK_LIB([gc],[GC_malloc],[
LIBS=$LIBS"-lgc "
-@@ -187,5 +193,14 @@
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -186,7 +192,16 @@ AC_CHECK_LIB([ncurses], [setupterm], [AC
+ AC_CHECK_LIB([m], [sqrt])
AC_CHECK_LIB([z], [deflate])
AC_CHECK_LIB([pthread], [pthread_create])
-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
@@ -41,7 +47,9 @@ diff -r -U2 asymptote-1.52.orig/configure.ac asymptote-1.52/configure.ac
+fi
AC_CHECK_LIB([readline], [rl_completion_matches],,
-@@ -204,9 +219,15 @@
+ AC_MSG_NOTICE(*** Could not find GNU readline 4.2 or later: will compile without readline support ***))
+@@ -203,11 +218,17 @@ AC_COMPILE_IFELSE(AC_LANG_PROGRAM([#incl
+ [Define if you have a working <rpc/rpc.h> header file])],
AC_MSG_WARN([*** Broken rpc headers; XDR support disabled ***]))
-AC_CHECK_HEADER(gsl/gsl_sf.h,
@@ -58,3 +66,4 @@ diff -r -U2 asymptote-1.52.orig/configure.ac asymptote-1.52/configure.ac
+fi
case "$OSTYPE" in
+ cygwin) AC_CHECK_HEADER(GL/glut.h,
diff --git a/media-gfx/asymptote/files/asymptote-1.52-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-1.54-xdg-utils.patch
index dd249733abea..1575eda2ec4b 100644
--- a/media-gfx/asymptote/files/asymptote-1.52-xdg-utils.patch
+++ b/media-gfx/asymptote/files/asymptote-1.54-xdg-utils.patch
@@ -1,7 +1,9 @@
-diff -r -U2 asymptote-1.52.orig/settings.cc asymptote-1.52/settings.cc
---- asymptote-1.52.orig/settings.cc 2008-11-25 15:09:27.000000000 +0600
-+++ asymptote-1.52/settings.cc 2008-11-27 04:42:58.000000000 +0600
-@@ -81,12 +81,12 @@
+Index: asymptote-1.54/settings.cc
+===================================================================
+--- asymptote-1.54.orig/settings.cc
++++ asymptote-1.54/settings.cc
+@@ -80,14 +80,14 @@ const bool haveglut=false;
+ bool msdos=false;
const char *HOME="HOME";
const char pathSeparator=':';
-string defaultPSViewer="gv";
@@ -17,3 +19,4 @@ diff -r -U2 asymptote-1.52.orig/settings.cc asymptote-1.52/settings.cc
+string defaultDisplay="xdg-open";
string defaultPython;
const string docdir=ASYMPTOTE_DOCDIR;
+ void queryRegistry() {}