summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-06-20 18:11:24 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-06-20 18:11:24 +0000
commiteb74f612c2a51b5093e5cac7d3f3466e82b8007b (patch)
tree6f26d37113eaa52b79256a487523fcdd945f7ed8 /media-gfx/asymptote
parentRemove unused file (diff)
downloadgentoo-2-eb74f612c2a51b5093e5cac7d3f3466e82b8007b.tar.gz
gentoo-2-eb74f612c2a51b5093e5cac7d3f3466e82b8007b.tar.bz2
gentoo-2-eb74f612c2a51b5093e5cac7d3f3466e82b8007b.zip
Version bump
(Portage version: 2.2.0_alpha41/cvs/Linux i686)
Diffstat (limited to 'media-gfx/asymptote')
-rw-r--r--media-gfx/asymptote/ChangeLog9
-rw-r--r--media-gfx/asymptote/asymptote-2.13.ebuild192
-rw-r--r--media-gfx/asymptote/files/asymptote-2.13-configure-ac.patch32
-rw-r--r--media-gfx/asymptote/files/asymptote-2.13-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.13-xdg-utils.patch22
5 files changed, 267 insertions, 1 deletions
diff --git a/media-gfx/asymptote/ChangeLog b/media-gfx/asymptote/ChangeLog
index 3339ef9ad108..30f8e4321180 100644
--- a/media-gfx/asymptote/ChangeLog
+++ b/media-gfx/asymptote/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/asymptote
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.86 2011/06/18 12:11:32 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.87 2011/06/20 18:11:24 grozin Exp $
+
+*asymptote-2.13 (20 Jun 2011)
+
+ 20 Jun 2011; Andrey Grozin <grozin@gentoo.org> +asymptote-2.13.ebuild,
+ +files/asymptote-2.13-configure-ac.patch, +files/asymptote-2.13-info.patch,
+ +files/asymptote-2.13-xdg-utils.patch:
+ Version bump
*asymptote-2.11 (18 Jun 2011)
diff --git a/media-gfx/asymptote/asymptote-2.13.ebuild b/media-gfx/asymptote/asymptote-2.13.ebuild
new file mode 100644
index 000000000000..1f3b5dee0b33
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-2.13.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/asymptote-2.13.ebuild,v 1.1 2011/06/20 18:11:24 grozin Exp $
+EAPI=3
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.*"
+inherit eutils autotools elisp-common latex-package multilib python
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex python sigsegv vim-syntax X"
+
+RDEPEND=">=sys-libs/readline-4.3-r5
+ >=sys-libs/ncurses-5.4-r5
+ imagemagick? ( media-gfx/imagemagick[png] )
+ sigsegv? ( dev-libs/libsigsegv )
+ boehm-gc? ( >=dev-libs/boehm-gc-7.0[-nocxx,threads] )
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ gsl? ( sci-libs/gsl )
+ X? ( x11-misc/xdg-utils dev-lang/python dev-python/imaging[tk] )
+ latex? ( virtual/latex-base dev-texlive/texlive-latexextra )
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${RDEPEND}
+ doc? ( dev-lang/perl virtual/texi2dvi virtual/latex-base media-gfx/imagemagick[png] )"
+
+TEXMF=/usr/share/texmf-site
+
+src_prepare() {
+ # Fixing sigsegv enabling
+ epatch "${FILESDIR}/${P}-configure-ac.patch"
+ einfo "Patching configure.ac"
+ sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ -i configure.ac \
+ || die "sed configure.ac failed"
+
+ # Changing pdf, ps, image viewers to xdg-open
+ epatch "${FILESDIR}/${P}-xdg-utils.patch"
+
+ # Bug #322473
+ epatch "${FILESDIR}/${P}-info.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ # for the CPPFLAGS see
+ # http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ econf CPPFLAGS=-DHAVE_SYS_TYPES_H \
+ --disable-gc-debug \
+ $(use_enable boehm-gc gc system) \
+ $(use_enable fftw) \
+ $(use_enable gsl) \
+ $(use_with sigsegv)
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ cd doc
+ emake asy.1 || die "emake asy.1 failed"
+ if use doc; then
+ # info
+ einfo "Making info"
+ emake ${PN}.info || die "emake ${PN}.info failed"
+ cd FAQ
+ emake || die "emake FAQ failed"
+ cd ..
+ # pdf
+ einfo "Making pdf docs"
+ export VARTEXFONTS="${T}"/fonts
+ # see bug #260606
+ emake -j1 asymptote.pdf || die "emake asymptote.pdf failed"
+ emake CAD.pdf || die "emake CAD.pdf failed"
+ fi
+ cd ..
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile base/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ # the program
+ exeinto /usr/bin
+ doexe asy
+
+ # .asy files
+ insinto /usr/share/${PN}
+ doins base/*.asy
+
+ # documentation
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+ doman doc/asy.1
+
+ # X GUI
+ if use X; then
+ exeinto /usr/share/${PN}/GUI
+ doexe GUI/xasy.py
+ rm GUI/xasy.py
+ insinto /usr/share/${PN}/GUI
+ doins GUI/*.py
+ dosym /usr/share/${PN}/GUI/xasy.py /usr/bin/xasy
+ doman doc/xasy.1x
+ fi
+
+ # examples
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins examples/*.asy \
+ examples/*.eps \
+ doc/*.asy \
+ doc/*.csv \
+ doc/*.dat \
+ doc/extra/*.asy
+ if use X; then
+ doins GUI/*.asy
+ fi
+ insinto /usr/share/${PN}/examples/animations
+ doins examples/animations/*.asy
+ fi
+
+ # LaTeX style
+ if use latex; then
+ cd doc
+ insinto "${TEXMF}"/tex/latex/${PN}
+ doins ${PN}.sty asycolors.sty
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins latexusage.tex
+ fi
+ cd ..
+ fi
+
+ # asymptote.py
+ if use python; then
+ python_install() {
+ insinto "$(python_get_sitedir)"
+ doins base/${PN}.py
+ }
+ python_execute_function python_install
+ fi
+
+ # emacs mode
+ if use emacs; then
+ elisp-install ${PN} base/*.el base/*.elc
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ fi
+
+ # vim syntax
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/asy-ftd.vim
+ fi
+
+ # extra documentation
+ if use doc; then
+ cd doc
+ doinfo ${PN}.info*
+ cd FAQ
+ dodoc asy-faq.ascii
+ doinfo asy-faq.info
+ insinto /usr/share/doc/${PF}/html/FAQ
+ doins asy-faq.html/*
+ cd ..
+ insinto /usr/share/doc/${PF}
+ doins ${PN}.pdf CAD.pdf
+ fi
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ${PN}.py
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}.py
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+}
diff --git a/media-gfx/asymptote/files/asymptote-2.13-configure-ac.patch b/media-gfx/asymptote/files/asymptote-2.13-configure-ac.patch
new file mode 100644
index 000000000000..d31f5326cab1
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.13-configure-ac.patch
@@ -0,0 +1,32 @@
+Index: asymptote-2.13/configure.ac
+===================================================================
+--- asymptote-2.13.orig/configure.ac
++++ asymptote-2.13/configure.ac
+@@ -150,7 +150,7 @@ if test "x$ac_cv_use_gc" != "xno" ; then
+ fi
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+ AC_MSG_NOTICE([enabling system $GCNAME])],[
+@@ -223,7 +223,17 @@ AC_MSG_ERROR([*** Please install libm on
+ AC_CHECK_LIB([z], [deflate],,
+ AC_MSG_ERROR([*** Please install libz on your system ***]))
+ AC_CHECK_LIB([pthread], [pthread_create])
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER([sigsegv.h],
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
++
+ AC_CHECK_LIB([rt], [sched_yield])
+
+ AC_ARG_ENABLE(readline,
diff --git a/media-gfx/asymptote/files/asymptote-2.13-info.patch b/media-gfx/asymptote/files/asymptote-2.13-info.patch
new file mode 100644
index 000000000000..986f049e3101
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.13-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.13/doc/asymptote.texi
+===================================================================
+--- asymptote-2.13.orig/doc/asymptote.texi
++++ asymptote-2.13/doc/asymptote.texi
+@@ -21,7 +21,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.13-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.13-xdg-utils.patch
new file mode 100644
index 000000000000..83c73eaa471b
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.13-xdg-utils.patch
@@ -0,0 +1,22 @@
+Index: asymptote-2.13/settings.cc
+===================================================================
+--- asymptote-2.13.orig/settings.cc
++++ asymptote-2.13/settings.cc
+@@ -95,14 +95,14 @@ bool msdos=false;
+ string HOME="HOME";
+ string docdir=ASYMPTOTE_DOCDIR;
+ const char pathSeparator=':';
+-string defaultPSViewer="gv";
++string defaultPSViewer="xdg-open";
+ #ifdef __APPLE__
+ string defaultPDFViewer="open";
+ #else
+-string defaultPDFViewer="acroread";
++string defaultPDFViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";