summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-08-10 23:02:04 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-08-10 23:02:04 +0000
commitd21972b7bed91bdb1df52c123d381b9f4830c3b1 (patch)
tree0276414cad7d6e98fde42e589d4251415d40d94a /media-gfx/autopano-sift/autopano-sift-2.3.ebuild
parentinitial commit of hugin, thanks to everyone on bug #48269 (diff)
downloadgentoo-2-d21972b7bed91bdb1df52c123d381b9f4830c3b1.tar.gz
gentoo-2-d21972b7bed91bdb1df52c123d381b9f4830c3b1.tar.bz2
gentoo-2-d21972b7bed91bdb1df52c123d381b9f4830c3b1.zip
initial commit of autopano-sift. Thanks to everyone on bug #75192
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-gfx/autopano-sift/autopano-sift-2.3.ebuild')
-rw-r--r--media-gfx/autopano-sift/autopano-sift-2.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-gfx/autopano-sift/autopano-sift-2.3.ebuild b/media-gfx/autopano-sift/autopano-sift-2.3.ebuild
new file mode 100644
index 000000000000..7335394793ab
--- /dev/null
+++ b/media-gfx/autopano-sift/autopano-sift-2.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/autopano-sift/autopano-sift-2.3.ebuild,v 1.1 2005/08/10 23:02:04 halcy0n Exp $
+
+DESCRIPTION="SIFT algorithm for automatic panorama creation"
+HOMEPAGE="http://user.cs.tu-berlin.de/~nowozin/autopano-sift/"
+SRC_URI="http://user.cs.tu-berlin.de/~nowozin/autopano-sift/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+inherit mono eutils
+
+DEPEND=">=dev-lang/mono-1.0
+ >=dev-dotnet/glade-sharp-1.0.4
+ >=dev-dotnet/gtk-sharp-1.0.4-r1
+ >=dev-dotnet/libgdiplus-1.0.4-r1"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src
+ sed -i 's%^AUTOPANO_PATH=.*%AUTOPANO_PATH=/usr/lib/autopano-sift%' \
+ bin/autopano-complete.sh
+}
+
+src_compile() {
+ cd ${S}/src
+
+ emake -j1 || die "Compile failed"
+}
+
+src_install() {
+ insinto /usr/lib/${PN}
+ doins src/util/*.exe src/util/autopanog/*.exe src/libsift.dll
+
+ exeinto /usr/bin
+
+ doexe ${FILESDIR}/autopano
+
+ for file in autopanog generatekeys; do
+ dosym autopano /usr/bin/"$file"
+ done
+
+ doexe src/bin/autopano-complete.sh
+
+ dodoc README CHANGES LICENSE
+ cd ${S}/doc
+ dodoc *.pdf *.txt
+ doman *.1 *.7
+}