summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-17 10:53:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-17 10:53:02 +0000
commit2d7ec15bd1ff1b73c5dc9d409b574a19eda1372c (patch)
tree470fc1401110494cdf045b4918f7ea5bcab5b8f5 /media-gfx/blender
parentversion bump (diff)
downloadgentoo-2-2d7ec15bd1ff1b73c5dc9d409b574a19eda1372c.tar.gz
gentoo-2-2d7ec15bd1ff1b73c5dc9d409b574a19eda1372c.tar.bz2
gentoo-2-2d7ec15bd1ff1b73c5dc9d409b574a19eda1372c.zip
Avoid sandbox violation by disabling audio correctly (fixes bug #426950, thanks to Weihua Zhou for the report). Also move the remaining doc generation to src_compile instead of install.
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/blender')
-rw-r--r--media-gfx/blender/ChangeLog7
-rw-r--r--media-gfx/blender/blender-2.63a-r2.ebuild22
2 files changed, 17 insertions, 12 deletions
diff --git a/media-gfx/blender/ChangeLog b/media-gfx/blender/ChangeLog
index c8d0e05a94eb..8d568dd5b07f 100644
--- a/media-gfx/blender/ChangeLog
+++ b/media-gfx/blender/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/blender
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.232 2012/07/17 06:33:23 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.233 2012/07/17 10:53:02 flameeyes Exp $
+
+ 17 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> blender-2.63a-r2.ebuild:
+ Avoid sandbox violation by disabling audio correctly (fixes bug #426950,
+ thanks to Weihua Zhou for the report). Also move the remaining doc generation
+ to src_compile instead of install.
17 Jul 2012; Sergei Trofimovich <slyfox@gentoo.org>
+files/blender-2.49b-linux-3.patch, blender-2.49b-r2.ebuild:
diff --git a/media-gfx/blender/blender-2.63a-r2.ebuild b/media-gfx/blender/blender-2.63a-r2.ebuild
index d5b4affe34f3..440bab3a50c3 100644
--- a/media-gfx/blender/blender-2.63a-r2.ebuild
+++ b/media-gfx/blender/blender-2.63a-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.63a-r2.ebuild,v 1.1 2012/07/16 12:05:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.63a-r2.ebuild,v 1.2 2012/07/17 10:53:02 flameeyes Exp $
EAPI=4
PYTHON_DEPEND="3:3.2"
@@ -223,9 +223,16 @@ EOF
if use doc; then
einfo "Generating Blender C/C++ API docs ..."
- cd "${WORKDIR}"/${P}/doc/doxygen
+ cd "${S}"/doc/doxygen
doxygen -u Doxyfile
doxygen || die "doxygen failed to build API docs."
+
+ cd "${S}"
+ einfo "Generating (BPY) Blender Python API docs ..."
+ "${WORKDIR}"/install/blender --background --python doc/python_api/sphinx_doc_gen.py -noaudio || die "blender failed."
+
+ cd "${S}"/doc/python_api
+ sphinx-build sphinx-in BPY_API || die "sphinx failed."
fi
}
@@ -252,18 +259,11 @@ src_install() {
dodoc -r "${WORKDIR}"/${P}/doc/guides/*
if use doc; then
- #einfo "Generating (BPY) Blender Python API docs ..."
- "${D}"/usr/bin/blender --background --python doc/python_api/sphinx_doc_gen.py --noaudio || die "blender failed."
-
- pushd doc/python_api > /dev/null
- sphinx-build sphinx-in BPY_API || die "sphinx failed."
- popd > /dev/null
-
docinto "API/python"
- dohtml -r doc/python_api/BPY_API/*
+ dohtml -r "${S}"/doc/python_api/BPY_API/*
docinto "API/blender"
- dohtml -r "${WORKDIR}"/${P}/doc/doxygen/html/*
+ dohtml -r "${S}"/doc/doxygen/html/*
fi
# final cleanup