summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2012-12-09 16:26:16 +0000
committerMarkus Meier <maekke@gentoo.org>2012-12-09 16:26:16 +0000
commit504aaab217bae51df0bd1cf6bf34043c80dc9d58 (patch)
tree4cea6d98ebdb7890d8cf7e6e94d655fefb555e8e /media-gfx/enblend
parent[bump] dev-perl/wxperl-0.991.400 (diff)
downloadgentoo-2-504aaab217bae51df0bd1cf6bf34043c80dc9d58.tar.gz
gentoo-2-504aaab217bae51df0bd1cf6bf34043c80dc9d58.tar.bz2
gentoo-2-504aaab217bae51df0bd1cf6bf34043c80dc9d58.zip
version bump
(Portage version: 2.1.11.33/cvs/Linux x86_64, signed Manifest commit with key 072AD062)
Diffstat (limited to 'media-gfx/enblend')
-rw-r--r--media-gfx/enblend/ChangeLog7
-rw-r--r--media-gfx/enblend/enblend-4.1.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/media-gfx/enblend/ChangeLog b/media-gfx/enblend/ChangeLog
index c71f9b98e8c5..b4e726917a9c 100644
--- a/media-gfx/enblend/ChangeLog
+++ b/media-gfx/enblend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/enblend
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.48 2012/05/05 07:00:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.49 2012/12/09 16:26:16 maekke Exp $
+
+*enblend-4.1 (09 Dec 2012)
+
+ 09 Dec 2012; Markus Meier <maekke@gentoo.org> +enblend-4.1.ebuild:
+ version bump
05 May 2012; Jeff Horelick <jdhore@gentoo.org> enblend-4.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-gfx/enblend/enblend-4.1.ebuild b/media-gfx/enblend/enblend-4.1.ebuild
new file mode 100644
index 000000000000..b14a990082fd
--- /dev/null
+++ b/media-gfx/enblend/enblend-4.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/enblend-4.1.ebuild,v 1.1 2012/12/09 16:26:16 maekke Exp $
+
+EAPI=2
+
+inherit eutils
+
+MY_P="${PN}-enfuse-${PV/_rc/rc}"
+
+DESCRIPTION="Image Blending with Multiresolution Splines"
+HOMEPAGE="http://enblend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/enblend/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 VIGRA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc gpu +image-cache +openexr openmp"
+
+RDEPEND="
+ media-libs/glew
+ =media-libs/lcms-2*
+ >=media-libs/libpng-1.2.43
+ media-libs/plotutils[X]
+ media-libs/tiff
+ >=media-libs/vigra-1.8.0
+ virtual/jpeg
+ gpu? ( media-libs/freeglut )
+ openexr? ( >=media-libs/openexr-1.0 )"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.31.0
+ virtual/pkgconfig
+ doc? (
+ media-gfx/transfig
+ sci-visualization/gnuplot[gd]
+ virtual/latex-base
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use image-cache && use openmp; then
+ ewarn "the openmp and image-cache USE-flags are mutually exclusive"
+ ewarn "image-cache will be disabled in favour of openmp"
+ fi
+}
+
+src_configure() {
+ local myconf="--with-boost-filesystem"
+ if use image-cache && use openmp; then
+ myconf="${myconf} --disable-image-cache --enable-openmp"
+ else
+ myconf="${myconf} $(use_enable image-cache) $(use_enable openmp)"
+ fi
+
+ use doc && myconf="${myconf} --with-gnuplot=$(type -p gnuplot)" \
+ || myconf="${myconf} --with-gnuplot=false"
+
+ econf \
+ --with-x \
+ $(use_enable debug) \
+ $(use_enable gpu gpu-support) \
+ $(use_with openexr) \
+ ${myconf}
+}
+
+src_compile() {
+ # forcing -j1 as every parallel compilation process needs about 1 GB RAM.
+ emake -j1 || die
+ if use doc; then
+ cd doc
+ make enblend.pdf enfuse.pdf || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+ use doc && dodoc doc/en{blend,fuse}.pdf
+}