summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2009-01-19 19:38:20 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2009-01-19 19:38:20 +0000
commit7e96b651dc909053a5cab46f60a5434541681abb (patch)
tree198e7fcf51af9278b96c3ae282605384e0d7bd1d /media-gfx/eog
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-7e96b651dc909053a5cab46f60a5434541681abb.tar.gz
gentoo-2-7e96b651dc909053a5cab46f60a5434541681abb.tar.bz2
gentoo-2-7e96b651dc909053a5cab46f60a5434541681abb.zip
Bump to 2.24.3.1, and fix bug #254943. Dropping the sparc sigbus patch since it has been committed.
(Portage version: 2.2_rc22/cvs/Linux 2.6.28 i686)
Diffstat (limited to 'media-gfx/eog')
-rw-r--r--media-gfx/eog/ChangeLog11
-rw-r--r--media-gfx/eog/eog-2.24.3.1.ebuild82
-rw-r--r--media-gfx/eog/files/eog-2.24.3.1-noexif-doc.patch289
3 files changed, 380 insertions, 2 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index 2db152d5bd48..0d9b26874a16 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/eog
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.221 2008/12/28 16:32:15 bluebird Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.222 2009/01/19 19:38:20 ford_prefect Exp $
+
+*eog-2.24.3.1 (19 Jan 2009)
+
+ 19 Jan 2009; Arun Raghavan <ford_prefect@gentoo.org>
+ +files/eog-2.24.3.1-noexif-doc.patch, +eog-2.24.3.1.ebuild:
+ Bump to 2.24.3.1, and fix bug #254943. Dropping the sparc sigbus patch
+ since it has been committed.
28 Dec 2008; Friedrich Oslage <bluebird@gentoo.org> eog-2.24.2-r1.ebuild:
Add ~sparc keyword, bug #242812
diff --git a/media-gfx/eog/eog-2.24.3.1.ebuild b/media-gfx/eog/eog-2.24.3.1.ebuild
new file mode 100644
index 000000000000..0d2ec7872a9d
--- /dev/null
+++ b/media-gfx/eog/eog-2.24.3.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.24.3.1.ebuild,v 1.1 2009/01/19 19:38:20 ford_prefect Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="http://www.gnome.org/projects/eog/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="dbus doc exif lcms python xmp"
+
+RDEPEND=">=x11-libs/gtk+-2.13.1
+ >=dev-libs/glib-2.15.3
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.3.6
+ >=gnome-base/gconf-2.5.90
+ >=media-libs/libart_lgpl-2.3.16
+ >=gnome-base/gnome-desktop-2.10
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=x11-misc/shared-mime-info-0.20
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ exif? (
+ >=media-libs/libexif-0.6.14
+ media-libs/jpeg )
+ lcms? ( media-libs/lcms )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygobject-2.11.5
+ >=dev-python/pygtk-2.9.7
+ >=dev-python/gnome-python-2.18.2 )
+ xmp? ( >=media-libs/exempi-2 )"
+
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.17
+ doc? ( >=dev-util/gtk-doc-1.10 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with exif libjpeg)
+ $(use_with exif libexif)
+ $(use_with dbus)
+ $(use_with lcms cms)
+ $(use_enable python)
+ $(use_with xmp)
+ --disable-scrollkeeper
+ --disable-schemas-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix documentation with USE="-exif doc"
+ sed 's:-I$(top_srcdir)/plugins \\:\\:g' \
+ -i doc/reference/Makefile.am doc/reference/Makefile.in \
+ || die "sed failed"
+
+ # Fix build with USE="doc -exif -xmp". Bug #254943
+ epatch "${FILESDIR}/${P}-noexif-doc.patch"
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! built_with_use =x11-libs/gtk+-2* jpeg; then
+ ewarn "For JPEG file support to work, x11-libs/gtk+ must be rebuilt"
+ ewarn "with the 'jpeg' USE flag enabled."
+ fi
+
+ if ! built_with_use =x11-libs/gtk+-2* tiff; then
+ ewarn "For TIFF file support to work, x11-libs/gtk+ must be rebuilt"
+ ewarn "with the 'tiff' USE flag enabled."
+ fi
+}
diff --git a/media-gfx/eog/files/eog-2.24.3.1-noexif-doc.patch b/media-gfx/eog/files/eog-2.24.3.1-noexif-doc.patch
new file mode 100644
index 000000000000..85e467837b26
--- /dev/null
+++ b/media-gfx/eog/files/eog-2.24.3.1-noexif-doc.patch
@@ -0,0 +1,289 @@
+---
+http://bugzilla.gnome.org/show_bug.cgi?id=557662
+https://bugs.gentoo.org/show_bug.cgi?id=254943
+
+diff -urNp eog-2.24.3.1-orig/configure.ac eog-2.24.3.1/configure.ac
+--- eog-2.24.3.1-orig/configure.ac 2009-01-18 15:38:44.000000000 +0530
++++ eog-2.24.3.1/configure.ac 2009-01-18 20:20:32.000000000 +0530
+@@ -159,6 +159,17 @@ fi
+
+ AM_CONDITIONAL([HAVE_EXEMPI], [test "x$have_exempi" = "xyes"])
+
++# Build EXIF-related documentation if we really have support for it
++if test "x$have_exif" = "xyes" || test "x$have_exempi" = "xyes"; then
++ EOG_DOC_EXIF_START=""
++ EOG_DOC_EXIF_STOP=""
++else
++ EOG_DOC_EXIF_START="<!--"
++ EOG_DOC_EXIF_STOP="-->"
++fi
++
++AC_SUBST([EOG_DOC_EXIF_START])
++AC_SUBST([EOG_DOC_EXIF_STOP])
+
+ # ********************
+ # Jpeg (semi-optional)
+@@ -397,6 +408,7 @@ data/icons/scalable/apps/Makefile
+ doc/Makefile
+ doc/reference/Makefile
+ doc/reference/version.xml
++doc/reference/eog-docs.sgml
+ plugins/Makefile
+ plugins/reload/Makefile
+ plugins/fullscreen/Makefile
+diff -urNp eog-2.24.3.1-orig/doc/reference/eog-docs.sgml eog-2.24.3.1/doc/reference/eog-docs.sgml
+--- eog-2.24.3.1-orig/doc/reference/eog-docs.sgml 2009-01-18 15:38:44.000000000 +0530
++++ eog-2.24.3.1/doc/reference/eog-docs.sgml 1970-01-01 05:30:00.000000000 +0530
+@@ -1,82 +0,0 @@
+-<?xml version="1.0"?>
+-<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
+- "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+-<!ENTITY version SYSTEM "version.xml">
+-]>
+-<book id="index" xmlns:xi="http://www.w3.org/2003/XInclude">
+- <bookinfo>
+- <title>Eye of GNOME Reference Manual</title>
+- <releaseinfo>
+- for Eye of GNOME &version;
+- </releaseinfo>
+- </bookinfo>
+-
+- <chapter>
+- <title>User Interface</title>
+- <xi:include href="xml/eog-properties-dialog.xml"/>
+- <xi:include href="xml/eog-list-store.xml"/>
+- <xi:include href="xml/eog-file-chooser.xml"/>
+- <xi:include href="xml/eog-thumb-nav.xml"/>
+- <xi:include href="xml/eog-thumb-view.xml"/>
+- <xi:include href="xml/eog-scroll-view.xml"/>
+- <xi:include href="xml/eog-window.xml"/>
+- <xi:include href="xml/eog-statusbar.xml"/>
+- <xi:include href="xml/eog-exif-details.xml"/>
+- <xi:include href="xml/eog-message-area.xml"/>
+- <xi:include href="xml/eog-dialog.xml"/>
+- <xi:include href="xml/eog-sidebar.xml"/>
+- <xi:include href="xml/eog-thumbnail.xml"/>
+- <xi:include href="xml/eog-save-as-dialog-helper.xml"/>
+- <xi:include href="xml/eog-pixbuf-cell-renderer.xml"/>
+- <xi:include href="xml/eog-error-message-area.xml"/>
+- </chapter>
+-
+- <chapter>
+- <title>Image data and manipulation</title>
+- <xi:include href="xml/eog-image.xml"/>
+- <xi:include href="xml/eog-image-save-info.xml"/>
+- <xi:include href="xml/eog-transform.xml"/>
+- <xi:include href="xml/eog-metadata-reader.xml"/>
+- <xi:include href="xml/eog-metadata-reader-png.xml"/>
+- <xi:include href="xml/eog-metadata-reader-jpg.xml"/>
+- </chapter>
+-
+- <chapter>
+- <title>Printing</title>
+- <xi:include href="xml/eog-print-preview.xml"/>
+- <xi:include href="xml/eog-print-image-setup.xml"/>
+- <xi:include href="xml/eog-print.xml"/>
+- </chapter>
+-
+- <chapter>
+- <title>Application and configuration</title>
+- <xi:include href="xml/eog-preferences-dialog.xml"/>
+- <xi:include href="xml/eog-application.xml"/>
+- <xi:include href="xml/eog-session.xml"/>
+- <xi:include href="xml/eog-config-keys.xml"/>
+- </chapter>
+-
+- <chapter>
+- <title>Plugins</title>
+- <xi:include href="xml/eog-plugin.xml"/>
+- <xi:include href="xml/eog-plugin-manager.xml"/>
+- <xi:include href="xml/eog-plugin-engine.xml"/>
+- </chapter>
+-
+- <chapter>
+- <title>Utilities</title>
+- <xi:include href="xml/eog-debug.xml"/>
+- <xi:include href="xml/eog-uri-converter.xml"/>
+- <xi:include href="xml/eog-util.xml"/>
+- <xi:include href="xml/eog-exif-util.xml"/>
+- <xi:include href="xml/eog-pixbuf-util.xml"/>
+- <xi:include href="xml/zoom.xml"/>
+- <xi:include href="xml/uta.xml"/>
+- </chapter>
+-
+- <chapter>
+- <title>Asynchronous jobs</title>
+- <xi:include href="xml/eog-jobs.xml"/>
+- <xi:include href="xml/eog-job-queue.xml"/>
+- </chapter>
+-</book>
+diff -urNp eog-2.24.3.1-orig/doc/reference/eog-docs.sgml.in eog-2.24.3.1/doc/reference/eog-docs.sgml.in
+--- eog-2.24.3.1-orig/doc/reference/eog-docs.sgml.in 1970-01-01 05:30:00.000000000 +0530
++++ eog-2.24.3.1/doc/reference/eog-docs.sgml.in 2009-01-18 17:44:00.000000000 +0530
+@@ -0,0 +1,86 @@
++<?xml version="1.0"?>
++<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
++ "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
++<!ENTITY version SYSTEM "version.xml">
++]>
++<book id="index" xmlns:xi="http://www.w3.org/2003/XInclude">
++ <bookinfo>
++ <title>Eye of GNOME Reference Manual</title>
++ <releaseinfo>
++ for Eye of GNOME &version;
++ </releaseinfo>
++ </bookinfo>
++
++ <chapter>
++ <title>User Interface</title>
++ <xi:include href="xml/eog-properties-dialog.xml"/>
++ <xi:include href="xml/eog-list-store.xml"/>
++ <xi:include href="xml/eog-file-chooser.xml"/>
++ <xi:include href="xml/eog-thumb-nav.xml"/>
++ <xi:include href="xml/eog-thumb-view.xml"/>
++ <xi:include href="xml/eog-scroll-view.xml"/>
++ <xi:include href="xml/eog-window.xml"/>
++ <xi:include href="xml/eog-statusbar.xml"/>
++ @EOG_DOC_EXIF_START@
++ <xi:include href="xml/eog-exif-details.xml"/>
++ @EOG_DOC_EXIF_STOP@
++ <xi:include href="xml/eog-message-area.xml"/>
++ <xi:include href="xml/eog-dialog.xml"/>
++ <xi:include href="xml/eog-sidebar.xml"/>
++ <xi:include href="xml/eog-thumbnail.xml"/>
++ <xi:include href="xml/eog-save-as-dialog-helper.xml"/>
++ <xi:include href="xml/eog-pixbuf-cell-renderer.xml"/>
++ <xi:include href="xml/eog-error-message-area.xml"/>
++ </chapter>
++
++ <chapter>
++ <title>Image data and manipulation</title>
++ <xi:include href="xml/eog-image.xml"/>
++ <xi:include href="xml/eog-image-save-info.xml"/>
++ <xi:include href="xml/eog-transform.xml"/>
++ <xi:include href="xml/eog-metadata-reader.xml"/>
++ <xi:include href="xml/eog-metadata-reader-png.xml"/>
++ <xi:include href="xml/eog-metadata-reader-jpg.xml"/>
++ </chapter>
++
++ <chapter>
++ <title>Printing</title>
++ <xi:include href="xml/eog-print-preview.xml"/>
++ <xi:include href="xml/eog-print-image-setup.xml"/>
++ <xi:include href="xml/eog-print.xml"/>
++ </chapter>
++
++ <chapter>
++ <title>Application and configuration</title>
++ <xi:include href="xml/eog-preferences-dialog.xml"/>
++ <xi:include href="xml/eog-application.xml"/>
++ <xi:include href="xml/eog-session.xml"/>
++ <xi:include href="xml/eog-config-keys.xml"/>
++ </chapter>
++
++ <chapter>
++ <title>Plugins</title>
++ <xi:include href="xml/eog-plugin.xml"/>
++ <xi:include href="xml/eog-plugin-manager.xml"/>
++ <xi:include href="xml/eog-plugin-engine.xml"/>
++ </chapter>
++
++ <chapter>
++ <title>Utilities</title>
++ <xi:include href="xml/eog-debug.xml"/>
++ <xi:include href="xml/eog-uri-converter.xml"/>
++ <xi:include href="xml/eog-util.xml"/>
++ @EOG_DOC_EXIF_START@
++ <xi:include href="xml/eog-exif-util.xml"/>
++ @EOG_DOC_EXIF_STOP@
++ <xi:include href="xml/eog-pixbuf-util.xml"/>
++ <xi:include href="xml/zoom.xml"/>
++ <xi:include href="xml/uta.xml"/>
++ </chapter>
++
++ <chapter>
++ <title>Asynchronous jobs</title>
++ <xi:include href="xml/eog-jobs.xml"/>
++ <xi:include href="xml/eog-job-queue.xml"/>
++ </chapter>
++</book>
+diff -urNp eog-2.24.3.1-orig/doc/reference/eog.types eog-2.24.3.1/doc/reference/eog.types
+--- eog-2.24.3.1-orig/doc/reference/eog.types 2009-01-18 15:38:44.000000000 +0530
++++ eog-2.24.3.1/doc/reference/eog.types 1970-01-01 05:30:00.000000000 +0530
+@@ -1,33 +0,0 @@
+-eog_image_get_type
+-eog_preferences_dialog_get_type
+-eog_list_store_get_type
+-eog_print_preview_get_type
+-eog_transform_get_type
+-eog_file_chooser_get_type
+-eog_metadata_reader_get_type
+-eog_properties_dialog_get_type
+-eog_job_get_type
+-eog_job_thumbnail_get_type
+-eog_job_load_get_type
+-eog_job_model_get_type
+-eog_job_transform_get_type
+-eog_job_save_get_type
+-eog_job_save_as_get_type
+-eog_thumb_nav_get_type
+-eog_metadata_reader_png_get_type
+-eog_uri_converter_get_type
+-eog_print_image_setup_get_type
+-eog_pixbuf_cell_renderer_get_type
+-eog_thumb_view_get_type
+-eog_plugin_get_type
+-eog_application_get_type
+-eog_plugin_manager_get_type
+-eog_scroll_view_get_type
+-eog_window_get_type
+-eog_statusbar_get_type
+-eog_exif_details_get_type
+-eog_message_area_get_type
+-eog_metadata_reader_jpg_get_type
+-eog_dialog_get_type
+-eog_image_save_info_get_type
+-eog_sidebar_get_type
+diff -urNp eog-2.24.3.1-orig/doc/reference/Makefile.am eog-2.24.3.1/doc/reference/Makefile.am
+--- eog-2.24.3.1-orig/doc/reference/Makefile.am 2009-01-18 15:38:44.000000000 +0530
++++ eog-2.24.3.1/doc/reference/Makefile.am 2009-01-20 00:07:03.000000000 +0530
+@@ -25,7 +25,7 @@ SCANGOBJ_OPTIONS=
+
+ # Extra options to supply to gtkdoc-scan.
+ # e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
+-SCAN_OPTIONS=
++SCAN_OPTIONS=--rebuild-types
+
+ # Extra options to supply to gtkdoc-mkdb.
+ # e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
+@@ -57,6 +57,14 @@ IGNORE_HFILES= \
+ eog-module.h \
+ eog-python-module.h
+
++if !HAVE_EXIF
++if !HAVE_EXEMPI
++IGNORE_HFILES += \
++ eog-exif-util.h \
++ eog-exif-details.h
++endif
++endif
++
+ # Images to copy into HTML directory.
+ # e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
+ HTML_IMAGES=
+@@ -110,12 +118,13 @@ include $(top_srcdir)/gtk-doc.make
+
+ # Other files to distribute
+ # e.g. EXTRA_DIST += version.xml.in
+-EXTRA_DIST += version.xml.in
++EXTRA_DIST += version.xml.in \
++ $(DOC_MAIN_SGML_FILE).in
+
+ # Files not to distribute
+ # for --rebuild-types in $(SCAN_OPTIONS), e.g. $(DOC_MODULE).types
+ # for --rebuild-sections in $(SCAN_OPTIONS) e.g. $(DOC_MODULE)-sections.txt
+-#DISTCLEANFILES +=
++DISTCLEANFILES = $(DOC_MODULE).types
+
+ # Comment this out if you want your docs-status tested during 'make check'
+ #TESTS = $(GTKDOC_CHECK)