summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-21 08:54:46 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-21 08:54:46 +0000
commit4af4c4513efbd165b79514cc60c87946c0191e37 (patch)
tree44ecb8a99f644161b2a81d15d0c3b8e929a22e37 /media-gfx/exiv2
parentVersion bump, add examples use flag. (diff)
downloadgentoo-2-4af4c4513efbd165b79514cc60c87946c0191e37.tar.gz
gentoo-2-4af4c4513efbd165b79514cc60c87946c0191e37.tar.bz2
gentoo-2-4af4c4513efbd165b79514cc60c87946c0191e37.zip
Cleanup due #92799
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/ChangeLog6
-rw-r--r--media-gfx/exiv2/exiv2-0.21.1-r1.ebuild130
-rw-r--r--media-gfx/exiv2/exiv2-0.21.1-r2.ebuild130
-rw-r--r--media-gfx/exiv2/exiv2-0.23.ebuild120
-rw-r--r--media-gfx/exiv2/metadata.xml3
5 files changed, 6 insertions, 383 deletions
diff --git a/media-gfx/exiv2/ChangeLog b/media-gfx/exiv2/ChangeLog
index 9dffcdd57572..71ba2a08dd59 100644
--- a/media-gfx/exiv2/ChangeLog
+++ b/media-gfx/exiv2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/exiv2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.108 2013/04/02 20:56:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.109 2013/07/21 08:54:46 pacho Exp $
+
+ 21 Jul 2013; Pacho Ramos <pacho@gentoo.org> -exiv2-0.21.1-r1.ebuild,
+ -exiv2-0.21.1-r2.ebuild, -exiv2-0.23.ebuild, metadata.xml:
+ Cleanup due #92799
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> exiv2-0.23-r1.ebuild:
Stable for ppc64, wrt bug #462890
diff --git a/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild b/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild
deleted file mode 100644
index 65458dd42165..000000000000
--- a/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.21.1-r1.ebuild,v 1.7 2012/07/02 21:51:47 sbriesen Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-
-inherit eutils multilib toolchain-funcs python
-
-DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
-HOMEPAGE="http://www.exiv2.org/"
-SRC_URI="http://www.exiv2.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
-IUSE="contrib doc examples nls xmp zlib"
-IUSE_LINGUAS="de es fi fr pl ru sk"
-IUSE="${IUSE} $(printf 'linguas_%s ' ${IUSE_LINGUAS})"
-
-RDEPEND="
- virtual/libiconv
- nls? ( virtual/libintl )
- xmp? ( dev-libs/expat )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- contrib? ( >=dev-libs/boost-1.37 )
- doc? (
- app-doc/doxygen
- dev-libs/libxslt
- virtual/pkgconfig
- media-gfx/graphviz
- )
- nls? ( sys-devel/gettext )
-"
-
-src_prepare() {
- # exiv2 fails to build with boost-1.46 due to boost filesystem
- # API v3 becoming the default. This is easily fixed by adding a
- # #define BOOST_FILESYSTEM_VERSION 2
- # to source files that include boost/filesystem.hpp
- #
- # Implemented via sed to avoid patch-file (bug #357605)
- sed -i -e \
- 's|^\(#include <boost/filesystem.hpp>.*\)|#define BOOST_FILESYSTEM_VERSION 2\n\1|g' \
- contrib/organize/helpers.hpp
-
- # fix for off by 1 hour date error for -T option (bug #368419)
- epatch "${FILESDIR}/${P}-time-fix.patch"
-
- # convert docs to UTF-8
- for i in doc/cmd.txt; do
- einfo "Converting "${i}" to UTF-8"
- iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
- done
-
- if use doc; then
- einfo "Updating doxygen config"
- doxygen 2>&1 >/dev/null -u config/Doxyfile
- fi
-
- if use contrib; then
- # create build environment for contrib
- ln -snf ../../src contrib/organize/exiv2
- sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
- -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
- contrib/organize/boost.mk
- fi
-
- # fix python shebang
- python_convert_shebangs -r 2 doc/templates
-}
-
-src_configure() {
- local myconf="$(use_enable nls) $(use_enable xmp)"
- use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
-
- # Bug #78720. amd64/gcc-3.4/-fvisibility* fail.
- if [[ $(gcc-major-version) -lt 4 ]]; then
- use amd64 && myconf="${myconf} --disable-visibility"
- fi
-
- econf \
- --disable-static \
- ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use contrib; then
- emake -C contrib/organize \
- LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
- || die "emake organize failed"
- fi
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-
- if use contrib; then
- emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
- fi
-
- dodoc README doc/{ChangeLog,cmd.txt}
- use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
- use doc && dohtml -r doc/html/.
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.cpp
- fi
-}
-
-pkg_postinst() {
- ewarn
- ewarn "PLEASE PLEASE take note of this:"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of exiv2 -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience!"
- ewarn
-}
diff --git a/media-gfx/exiv2/exiv2-0.21.1-r2.ebuild b/media-gfx/exiv2/exiv2-0.21.1-r2.ebuild
deleted file mode 100644
index 105567934252..000000000000
--- a/media-gfx/exiv2/exiv2-0.21.1-r2.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.21.1-r2.ebuild,v 1.6 2012/07/02 21:51:47 sbriesen Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-
-inherit eutils multilib toolchain-funcs python
-
-DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
-HOMEPAGE="http://www.exiv2.org/"
-SRC_URI="http://www.exiv2.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="contrib doc examples nls xmp zlib"
-IUSE_LINGUAS="de es fi fr pl ru sk"
-IUSE="${IUSE} $(printf 'linguas_%s ' ${IUSE_LINGUAS})"
-
-RDEPEND="
- virtual/libiconv
- nls? ( virtual/libintl )
- xmp? ( dev-libs/expat )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- contrib? ( >=dev-libs/boost-1.37 )
- doc? (
- app-doc/doxygen
- dev-libs/libxslt
- virtual/pkgconfig
- media-gfx/graphviz
- )
- nls? ( sys-devel/gettext )
-"
-
-src_prepare() {
- # exiv2 fails to build with boost-1.46 due to boost filesystem
- # API v3 becoming the default. This is easily fixed by adding a
- # #define BOOST_FILESYSTEM_VERSION 2
- # to source files that include boost/filesystem.hpp
- #
- # Implemented via sed to avoid patch-file (bug #357605)
- sed -i -e \
- 's|^\(#include <boost/filesystem.hpp>.*\)|#define BOOST_FILESYSTEM_VERSION 2\n\1|g' \
- contrib/organize/helpers.hpp
-
- # fix for off by 1 hour date error for -T option (bug #368419)
- epatch "${FILESDIR}/${P}-time-fix.patch"
-
- # convert docs to UTF-8
- for i in doc/cmd.txt; do
- einfo "Converting "${i}" to UTF-8"
- iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
- done
-
- if use doc; then
- einfo "Updating doxygen config"
- doxygen 2>&1 >/dev/null -u config/Doxyfile
- fi
-
- if use contrib; then
- # create build environment for contrib
- ln -snf ../../src contrib/organize/exiv2
- sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
- -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
- contrib/organize/boost.mk
- fi
-
- # fix python shebang
- python_convert_shebangs -r 2 doc/templates
-}
-
-src_configure() {
- local myconf="$(use_enable nls) $(use_enable xmp)"
- use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
-
- # Bug #78720. amd64/gcc-3.4/-fvisibility* fail.
- if [[ $(gcc-major-version) -lt 4 ]]; then
- use amd64 && myconf="${myconf} --disable-visibility"
- fi
-
- econf \
- --disable-static \
- ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use contrib; then
- emake -C contrib/organize \
- LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
- || die "emake organize failed"
- fi
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-
- if use contrib; then
- emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
- fi
-
- dodoc README doc/{ChangeLog,cmd.txt}
- use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
- use doc && dohtml -r doc/html/.
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.cpp
- fi
-}
-
-pkg_postinst() {
- ewarn
- ewarn "PLEASE PLEASE take note of this:"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of exiv2 -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience!"
- ewarn
-}
diff --git a/media-gfx/exiv2/exiv2-0.23.ebuild b/media-gfx/exiv2/exiv2-0.23.ebuild
deleted file mode 100644
index c09cf9489935..000000000000
--- a/media-gfx/exiv2/exiv2-0.23.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.23.ebuild,v 1.3 2012/07/02 21:51:47 sbriesen Exp $
-
-EAPI=4
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit eutils autotools-utils multilib toolchain-funcs python
-
-DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
-HOMEPAGE="http://www.exiv2.org/"
-SRC_URI="http://www.exiv2.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE_LINGUAS="de es fi fr pl ru sk"
-IUSE="contrib doc examples nls xmp zlib static-libs $(printf 'linguas_%s ' ${IUSE_LINGUAS})"
-
-RDEPEND="
- virtual/libiconv
- nls? ( virtual/libintl )
- xmp? ( dev-libs/expat )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
- contrib? ( >=dev-libs/boost-1.37 )
- doc? (
- app-doc/doxygen
- dev-libs/libxslt
- virtual/pkgconfig
- media-gfx/graphviz
- =dev-lang/python-2*
- )
- nls? ( sys-devel/gettext )
-"
-
-DOCS=( README doc/ChangeLog doc/cmd.txt )
-
-src_prepare() {
- # exiv2 fails to build with boost-1.46 due to boost filesystem
- # API v3 becoming the default. This is easily fixed by adding a
- # #define BOOST_FILESYSTEM_VERSION 2
- # to source files that include boost/filesystem.hpp
- #
- # Implemented via sed to avoid patch-file (bug #357605)
- sed -i -e \
- 's|^\(#include <boost/filesystem.hpp>.*\)|#define BOOST_FILESYSTEM_VERSION 2\n\1|g' \
- contrib/organize/helpers.hpp
-
- # convert docs to UTF-8
- local i
- for i in doc/cmd.txt; do
- einfo "Converting "${i}" to UTF-8"
- iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
- done
-
- if use doc; then
- einfo "Updating doxygen config"
- doxygen 2>&1 >/dev/null -u config/Doxyfile
- python_convert_shebangs -r 2 doc/templates
- fi
-
- if use contrib; then
- # create build environment for contrib
- ln -snf ../../src contrib/organize/exiv2
- sed -i -e 's:/usr/local/include/.*:/usr/include:g' \
- -e 's:/usr/local/lib/lib:-l:g' -e 's:-gcc..-mt-._..\.a::g' \
- contrib/organize/boost.mk
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable nls)
- $(use_enable xmp)
- $(use_enable static-libs static)
- )
-
- # plain 'use_with' fails
- use zlib || myeconfargs+=("${myconf} --without-zlib")
-
- # Bug #78720. amd64/gcc-3.4/-fvisibility* fail.
- if [ $(gcc-major-version) -lt 4 ]; then
- use amd64 && myeconfargs+=("${myconf} --disable-visibility")
- fi
-
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
-
- if use contrib; then
- emake -C contrib/organize \
- LDFLAGS="\$(BOOST_LIBS) -L../../src -lexiv2 ${LDFLAGS}" \
- CPPFLAGS="${CPPFLAGS} -I\$(BOOST_INC_DIR) -I. -DEXV_HAVE_STDINT_H" \
- || die "emake organize failed"
- fi
-
- if use doc; then
- emake doc || die "emake doc failed"
- fi
-}
-
-src_install() {
- autotools-utils_src_install
-
- if use contrib; then
- emake DESTDIR="${D}" -C contrib/organize install || die "emake install organize failed"
- fi
-
- use xmp && dodoc doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt}
- use doc && dohtml -r doc/html/.
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- docompress -x /usr/share/doc/${PF}/examples
- doins samples/*.cpp
- fi
-}
diff --git a/media-gfx/exiv2/metadata.xml b/media-gfx/exiv2/metadata.xml
index 73756a9201db..f83a55405276 100644
--- a/media-gfx/exiv2/metadata.xml
+++ b/media-gfx/exiv2/metadata.xml
@@ -2,8 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>sbriesen@gentoo.org</email>
- <name>Stefan Briesenick</name>
+ <email>maintainer-needed@gentoo.org</email>
</maintainer>
<longdescription lang="en">
Exiv2 is a C++ library and a command line utility to read and