summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-01 16:24:48 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-01 16:24:48 +0000
commit736a4651bf64529e210d49b3de048e1a61a71f35 (patch)
tree678dc1b5a14706184b5f391a6f42f8806a3d07ae /media-gfx/f-spot/files
parentnew snapshot, bug #257217 (diff)
downloadgentoo-2-736a4651bf64529e210d49b3de048e1a61a71f35.tar.gz
gentoo-2-736a4651bf64529e210d49b3de048e1a61a71f35.tar.bz2
gentoo-2-736a4651bf64529e210d49b3de048e1a61a71f35.zip
Fix bugs 248630, 248633, 248634 and 252636. Respectively a QA warning, a crasher, a crasher and a sandbox violation with new sandbox. Thanks to Pacho Ramos <pacho@condmat1.ciencias.uniovi.es> for patches and QA report. Remove old versions. Also add dotnet as herd.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/f-spot/files')
-rw-r--r--media-gfx/f-spot/files/f-spot-0.1.3-mono-1.1.10.patch68
-rw-r--r--media-gfx/f-spot/files/f-spot-0.3.3-dont_eat_cpu.patch35
-rw-r--r--media-gfx/f-spot/files/f-spot-0.3.5-picasa_fix.patch12
-rw-r--r--media-gfx/f-spot/files/f-spot-0.4.2-color-adjust.patch55
-rw-r--r--media-gfx/f-spot/files/f-spot-0.5.0.3-icon-size-crash-fix.patch48
-rw-r--r--media-gfx/f-spot/files/f-spot-0.5.0.3-no-image-in-collection-crash-fix.patch17
6 files changed, 65 insertions, 170 deletions
diff --git a/media-gfx/f-spot/files/f-spot-0.1.3-mono-1.1.10.patch b/media-gfx/f-spot/files/f-spot-0.1.3-mono-1.1.10.patch
deleted file mode 100644
index 96b08bba89b2..000000000000
--- a/media-gfx/f-spot/files/f-spot-0.1.3-mono-1.1.10.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-===================================================================
-RCS file: /cvs/gnome/f-spot/src/BitConverter.cs,v
-retrieving revision 1.3
-retrieving revision 1.4
-diff -u -r1.3 -r1.4
---- src/BitConverter.cs 2005/10/13 19:57:22 1.3
-+++ src/BitConverter.cs 2005/10/25 17:54:27 1.4
-@@ -1,3 +1,6 @@
-+using System;
-+using System.Runtime.InteropServices;
-+
- namespace FSpot {
- public class BitConverter {
- public static uint Swap (uint val, bool little)
-@@ -66,6 +69,17 @@
- return Swap (val, little);
- }
-
-+ public static float ToSingle (byte [] data, int position, bool little)
-+ {
-+ float retval;
-+ unsafe {
-+ uint * ptr;
-+ ptr = (uint *)&retval;
-+ *ptr = ToUInt32 (data, position, little);
-+ }
-+ return retval;
-+ }
-+
- public static int ToInt32 (byte [] data, int position, bool little)
- {
- return unchecked ((int) ToUInt32 (data, position, little));
-===================================================================
-RCS file: /cvs/gnome/f-spot/src/Ciff.cs,v
-retrieving revision 1.8
-retrieving revision 1.9
-diff -u -r1.8 -r1.9
---- src/Ciff.cs 2005/09/25 08:37:34 1.8
-+++ src/Ciff.cs 2005/10/25 17:54:27 1.9
-@@ -1,3 +1,5 @@
-+using System;
-+
- namespace FSpot.Ciff {
- public enum Tag {
- // Byte valuesad
-@@ -83,6 +85,8 @@
- ExifInformation = 0x300b
- }
-
-+
-+
- public struct ImageSpec {
- public uint ImageWidth; // Number of horizontal pixels
- public uint ImageHeight; // Number of vertical pixels
-@@ -96,10 +100,8 @@
- {
- ImageWidth = BitConverter.ToUInt32 (data, 0, little);
- ImageHeight = BitConverter.ToUInt32 (data, 4, little);
-- unsafe {
-- float *p = &PixelAspectRatio;
-- *((uint *)p) = BitConverter.ToUInt32 (data, 8, little);
-- }
-+
-+ PixelAspectRatio = BitConverter.ToSingle (data, 8, little);
- RotationAngle = BitConverter.ToInt32 (data, 12, little);
- ComponentBitDepth = BitConverter.ToUInt32 (data, 16, little);
- ColorBitDepth = BitConverter.ToUInt32 (data, 20, little);
-
diff --git a/media-gfx/f-spot/files/f-spot-0.3.3-dont_eat_cpu.patch b/media-gfx/f-spot/files/f-spot-0.3.3-dont_eat_cpu.patch
deleted file mode 100644
index b2156b205580..000000000000
--- a/media-gfx/f-spot/files/f-spot-0.3.3-dont_eat_cpu.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/ThreadProgressDialog.cs 2007/02/01 19:28:01 2906
-+++ src/ThreadProgressDialog.cs 2007/02/11 19:23:05 2946
-@@ -132,9 +132,11 @@
- }
- }
-
-+ private bool retry_skip;
- private bool RetrySkipVisible {
- set {
-- retry_button.Visible = skip_button.Visible = value;
-+ retry_skip = value;
-+ delay.Start ();
- }
- }
-
-@@ -149,7 +151,7 @@
-
- RetrySkipVisible = false;
-
-- return error_response == Gtk.ResponseType.Yes ? true : false;
-+ return (error_response == Gtk.ResponseType.Yes);
- }
-
- private void HandleResponse (object obj, Gtk.ResponseArgs args) {
-@@ -162,8 +164,9 @@
- progress_bar.Text = progress_text;
- progress_bar.Fraction = System.Math.Min (1.0, System.Math.Max (0.0, fraction));
- button.Label = button_label;
-+ retry_button.Visible = skip_button.Visible = retry_skip;
-
-- return true;
-+ return false;
- }
-
- private void HandleDestroy (object sender, EventArgs args)
diff --git a/media-gfx/f-spot/files/f-spot-0.3.5-picasa_fix.patch b/media-gfx/f-spot/files/f-spot-0.3.5-picasa_fix.patch
deleted file mode 100644
index 1033c139b012..000000000000
--- a/media-gfx/f-spot/files/f-spot-0.3.5-picasa_fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- google-sharp/PicasaWeb.cs 2007-01-09 10:07:29.000000000 +0800
-+++ google-sharp/PicasaWeb.cs 2007-05-28 20:20:48.000000000 +0800
-@@ -260,7 +260,8 @@ namespace Mono.Google.Picasa {
- XmlNamespaceManager nsmgr = new XmlNamespaceManager (doc.NameTable);
- nsmgr.AddNamespace ("photo", "http://www.pheed.com/pheed/");
- nsmgr.AddNamespace ("media", "http://search.yahoo.com/mrss/");
-- nsmgr.AddNamespace ("gphoto", "http://picasaweb.google.com/lh/picasaweb");
-+ nsmgr.AddNamespace ("gphoto", "http://schemas.google.com/photos/2007");
-+ nsmgr.AddNamespace ("batch", "http://schemas.google.com/gdata/batch");
- node = channel.SelectSingleNode ("gphoto:user", nsmgr);
- user = node.InnerText;
- node = channel.SelectSingleNode ("gphoto:nickname", nsmgr);
diff --git a/media-gfx/f-spot/files/f-spot-0.4.2-color-adjust.patch b/media-gfx/f-spot/files/f-spot-0.4.2-color-adjust.patch
deleted file mode 100644
index d0550e874e0e..000000000000
--- a/media-gfx/f-spot/files/f-spot-0.4.2-color-adjust.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-Index: src/Makefile.am
-===================================================================
---- src/Makefile.am (revision 3689)
-+++ src/Makefile.am (working copy)
-@@ -385,7 +385,7 @@
- $(F_SPOT_DISTRESOURCES) \
- f-spot.exe.config.in \
- f-spot.in \
-- Cms.dll.config
-+ Cms.dll.config.in
-
- CLEANFILES = \
- f-spot.exe.config \
-@@ -399,7 +399,8 @@
- FSpot.Query.dll \
- FSpot.Query.dll.mdb \
- FSpot.Core.dll.mdb \
-- FSpot.Core.dll
-+ FSpot.Core.dll \
-+ Cms.dll.config
-
-
- DISTCLEANFILES = \
-Index: src/Cms.dll.config
-===================================================================
---- src/Cms.dll.config (revision 3689)
-+++ src/Cms.dll.config (working copy)
-@@ -1,4 +0,0 @@
--<configuration>
-- <dllmap dll="liblcms-1.0.0.dll" target="liblcms.so.1"/>
--</configuration>
--
-Index: src/Cms.dll.config.in
-===================================================================
---- src/Cms.dll.config.in (revision 0)
-+++ src/Cms.dll.config.in (revision 0)
-@@ -0,0 +1,5 @@
-+<configuration>
-+ <dllmap dll="liblcms-1.0.0.dll" target="liblcms.so.1"/>
-+ <dllmap dll="libfspot" target="@expanded_libdir@/f-spot/libfspot.so.0"/>
-+</configuration>
-+
-Index: configure.in
-===================================================================
---- configure.in (revision 3689)
-+++ configure.in (working copy)
-@@ -292,6 +292,7 @@
- src/Core/Defines.cs
- src/AssemblyInfo.cs
- src/f-spot.exe.config
-+src/Cms.dll.config
- src/Makefile
- glitz-sharp/Makefile
- glitz-sharp/src/Makefile
-
diff --git a/media-gfx/f-spot/files/f-spot-0.5.0.3-icon-size-crash-fix.patch b/media-gfx/f-spot/files/f-spot-0.5.0.3-icon-size-crash-fix.patch
new file mode 100644
index 000000000000..6bdf3610d7e8
--- /dev/null
+++ b/media-gfx/f-spot/files/f-spot-0.5.0.3-icon-size-crash-fix.patch
@@ -0,0 +1,48 @@
+http://bugs.gentoo.org/show_bug.cgi?id=248634
+http://bugzilla.gnome.org/show_bug.cgi?id=557793
+
+
+From efe65ac1c3ee8f3d01afaa57425926d9390b747a Mon Sep 17 00:00:00 2001
+From: sdelcroix <sdelcroix@772769d8-d925-0410-89eb-a6ffa0d40526>
+Date: Wed, 5 Nov 2008 07:59:27 +0000
+Subject: [PATCH] 2008-11-05 Stephane Delcroix <sdelcroix@novell.com>
+
+ * src/TagSelectionWidget.cs:
+ * src/Core/Tag.cs: fix for bgo 557793
+
+git-svn-id: svn+ssh://svn.gnome.org/svn/f-spot/branches/FSPOT_0_5_0_STABLE@4572 772769d8-d925-0410-89eb-a6ffa0d40526
+---
+ src/Core/Tag.cs | 3 +++
+ src/TagSelectionWidget.cs | 2 +-
+ 3 files changed, 9 insertions(+), 1 deletions(-)
+
+diff --git a/src/Core/Tag.cs b/src/Core/Tag.cs
+index 42b671a..75b2d3d 100644
+--- src/Core/Tag.cs
++++ src/Core/Tag.cs
+@@ -108,6 +108,9 @@ namespace FSpot
+ if (Math.Max (cached_icon.Width, cached_icon.Height) <= (int) tag_icon_size)
+ return cached_icon;
+ }
++ if (icon == null)
++ return null;
++
+ if (Math.Max (icon.Width, icon.Height) >= (int) tag_icon_size) { //Don't upscale
+ if (cached_icon != null)
+ cached_icon.Dispose ();
+diff --git a/src/TagSelectionWidget.cs b/src/TagSelectionWidget.cs
+index 515dc2a..3516c58 100644
+--- src/TagSelectionWidget.cs
++++ src/TagSelectionWidget.cs
+@@ -192,7 +192,7 @@ public class TagSelectionWidget : FSpot.Widgets.SaneTreeView {
+ SetBackground (renderer, tag);
+
+ // FIXME I can't set the Pixbuf to null, not sure if it's a GTK# bug...
+- if (tag.Icon != null) {
++ if (tag.SizedIcon != null) {
+ if (FSpot.ColorManagement.IsEnabled) {
+ //FIXME
+ Gdk.Pixbuf temp = tag.SizedIcon.Copy();
+--
+1.6.0.2
+
diff --git a/media-gfx/f-spot/files/f-spot-0.5.0.3-no-image-in-collection-crash-fix.patch b/media-gfx/f-spot/files/f-spot-0.5.0.3-no-image-in-collection-crash-fix.patch
new file mode 100644
index 000000000000..bd6cdb78ad04
--- /dev/null
+++ b/media-gfx/f-spot/files/f-spot-0.5.0.3-no-image-in-collection-crash-fix.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/show_bug.cgi?id=248633
+http://bugzilla.gnome.org/show_bug.cgi?id=556395
+
+Index: src/Widgets/Filmstrip.cs
+===================================================================
+--- src/Widgets/Filmstrip.cs (revisione 4485)
++++ src/Widgets/Filmstrip.cs (copia locale)
+@@ -372,6 +372,9 @@
+ if (evnt.Window != GdkWindow)
+ return true;
+
++ if (selection.Collection.Count == 0)
++ return true;
++
+ if (extendable && Allocation.Width >= BackgroundPixbuf.Width + (2 * x_offset) + BackgroundTile.Width)
+ BackgroundPixbuf = null;
+