summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-03-05 20:54:20 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-03-05 20:54:20 +0000
commit245b1c31c4b494663de70f70622672376330a2e3 (patch)
tree1a936d90aefd8d6ca572570524a50eb51771dea4 /media-gfx/fontypython
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-245b1c31c4b494663de70f70622672376330a2e3.tar.gz
gentoo-2-245b1c31c4b494663de70f70622672376330a2e3.tar.bz2
gentoo-2-245b1c31c4b494663de70f70622672376330a2e3.zip
Cleanup ebuild and drop calls to deprecated python functions.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/fontypython')
-rw-r--r--media-gfx/fontypython/ChangeLog8
-rw-r--r--media-gfx/fontypython/fontypython-0.4.2.2.ebuild25
-rw-r--r--media-gfx/fontypython/fontypython-0.4.2.3.ebuild25
3 files changed, 22 insertions, 36 deletions
diff --git a/media-gfx/fontypython/ChangeLog b/media-gfx/fontypython/ChangeLog
index 90228574fb0c..f63b57ddc834 100644
--- a/media-gfx/fontypython/ChangeLog
+++ b/media-gfx/fontypython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/fontypython
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontypython/ChangeLog,v 1.8 2009/10/26 05:25:32 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontypython/ChangeLog,v 1.9 2010/03/05 20:54:20 dirtyepic Exp $
+
+ 05 Mar 2010; Ryan Hill <dirtyepic@gentoo.org> fontypython-0.4.2.2.ebuild,
+ fontypython-0.4.2.3.ebuild:
+ Cleanup ebuild and drop calls to deprecated python functions.
*fontypython-0.4.2.3 (26 Oct 2009)
diff --git a/media-gfx/fontypython/fontypython-0.4.2.2.ebuild b/media-gfx/fontypython/fontypython-0.4.2.2.ebuild
index 464c490ac598..c0b3254a3f6d 100644
--- a/media-gfx/fontypython/fontypython-0.4.2.2.ebuild
+++ b/media-gfx/fontypython/fontypython-0.4.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontypython/fontypython-0.4.2.2.ebuild,v 1.1 2009/10/03 07:22:56 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontypython/fontypython-0.4.2.2.ebuild,v 1.2 2010/03/05 20:54:20 dirtyepic Exp $
EAPI=2
@@ -15,25 +15,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-lang/python:2.6
- dev-python/imaging
+# Crashes w/ debug build of wxGTK (#201315)
+DEPEND="dev-python/imaging
dev-python/wxpython:2.8
x11-libs/wxGTK:2.8[-debug]"
RDEPEND="${DEPEND}"
+PYTHON_DEPEND="2:2.6"
+PYTHON_MODNAME="fontypythonmodules"
+
src_install() {
- python_version
- distutils_src_install \
- --install-data=/usr/$(get_libdir)/python${PYVER}/site-packages
+ distutils_src_install
doman "${S}"/fontypython.1
}
-
-pkg_postinst() {
- pydir=/usr/$(get_libdir)/python${PYVER}/site-packages/fontypythonmodules
- python_mod_optimize ${pydir}
-}
-
-pkg_postrm() {
- pydir=/usr/$(get_libdir)/python${PYVER}/site-packages/fontypythonmodules
- python_mod_cleanup ${pydir}
-}
diff --git a/media-gfx/fontypython/fontypython-0.4.2.3.ebuild b/media-gfx/fontypython/fontypython-0.4.2.3.ebuild
index b0482af90596..7dac4c9f50b8 100644
--- a/media-gfx/fontypython/fontypython-0.4.2.3.ebuild
+++ b/media-gfx/fontypython/fontypython-0.4.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontypython/fontypython-0.4.2.3.ebuild,v 1.1 2009/10/26 05:25:32 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontypython/fontypython-0.4.2.3.ebuild,v 1.2 2010/03/05 20:54:20 dirtyepic Exp $
EAPI=2
@@ -15,25 +15,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-lang/python:2.6
- dev-python/imaging
+# Crashes w/ debug build of wxGTK (#201315)
+DEPEND="dev-python/imaging
dev-python/wxpython:2.8
x11-libs/wxGTK:2.8[-debug]"
RDEPEND="${DEPEND}"
+PYTHON_DEPEND="2:2.6"
+PYTHON_MODNAME="fontypythonmodules"
+
src_install() {
- python_version
- distutils_src_install \
- --install-data=/usr/$(get_libdir)/python${PYVER}/site-packages
+ distutils_src_install
doman "${S}"/fontypython.1
}
-
-pkg_postinst() {
- pydir=/usr/$(get_libdir)/python${PYVER}/site-packages/fontypythonmodules
- python_mod_optimize ${pydir}
-}
-
-pkg_postrm() {
- pydir=/usr/$(get_libdir)/python${PYVER}/site-packages/fontypythonmodules
- python_mod_cleanup ${pydir}
-}