summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-31 14:08:53 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-31 14:08:53 +0000
commitd3cb277316b0375433302b18a6366de320f7f546 (patch)
treeee6733eead68d1e971b7f8e729411168607af916 /media-gfx/gimp-print/gimp-print-4.2.5-r2.ebuild
parentupdate to stable series (diff)
downloadgentoo-2-d3cb277316b0375433302b18a6366de320f7f546.tar.gz
gentoo-2-d3cb277316b0375433302b18a6366de320f7f546.tar.bz2
gentoo-2-d3cb277316b0375433302b18a6366de320f7f546.zip
update to stable series
Diffstat (limited to 'media-gfx/gimp-print/gimp-print-4.2.5-r2.ebuild')
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.5-r2.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/media-gfx/gimp-print/gimp-print-4.2.5-r2.ebuild b/media-gfx/gimp-print/gimp-print-4.2.5-r2.ebuild
new file mode 100644
index 000000000000..ae9e5fee4a5a
--- /dev/null
+++ b/media-gfx/gimp-print/gimp-print-4.2.5-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5-r2.ebuild,v 1.1 2003/07/31 14:08:41 lanius Exp $
+
+IUSE="nls gtk readline cups foomaticdb ppds"
+
+DESCRIPTION="Gimp Print Drivers"
+HOMEPAGE="http://gimp-print.sourceforge.net"
+KEYWORDS="x86 ppc alpha sparc hppa amd64"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.gz"
+
+DEPEND="cups? ( >=net-print/cups-1.1.14 )
+ media-gfx/imagemagick
+ >=app-text/ghostscript-7.05.6-r3
+ sys-libs/readline
+ gtk? ( =x11-libs/gtk+-1.2* )
+ dev-lang/perl
+ !media-gfx/gimp-print-cups
+ foomaticdb? ( net-print/foomatic-db-engine )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ use gtk \
+ && myconf="${myconf} --enable-lexmarkutil" \
+ || myconf="${myconf} --disable-lexmarkutil"
+
+ has_version =media-gfx/gimp-1.2* \
+ && myconf="${myconf} --with-gimp" \
+ || myconf="${myconf} --without-gimp"
+
+ if [ `use cups` ]; then
+ myconf="${myconf} --with-cups"
+ else
+ myconf="${myconf} --without-cups"
+ fi
+
+ use foomaticdb \
+ && myconf="${myconf} --with-foomatic3" \
+ || myconf="${myconf} --without-foomatic"
+
+ # --without-translated-ppds enabled \
+ econf \
+ --enable-test \
+ --with-ghosts \
+ --with-user-guide \
+ --with-samples \
+ --with-escputil \
+ $myconf || die
+
+ # IJS Patch
+ cp src/ghost/ijsgimpprint.c src/ghost/ijsgimpprint.c.org
+ sed -e "s/<ijs/<ijs\/ijs/g" src/ghost/ijsgimpprint.c.org > src/ghost/ijsgimpprint.c
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ make install DESTDIR=${D} || die
+
+ exeinto /usr/share/gimp-print
+ doexe test/{unprint,pcl-unprint,bjc-unprint,parse-escp2,curve,escp2-weavetest,run-testdither,run-weavetest,testdither}
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README \
+ doc/users_guide/users-guide.ps doc/users_guide/users-guide.pdf \
+ ${D}/usr/share/gimp-print/doc/gimpprint.ps
+ dohtml doc/FAQ.html
+ dohtml -r doc/users_guide/html doc/developer/developer-html
+ rm -fR ${D}/usr/share/gimp-print/doc
+}