summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-17 20:07:09 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-17 20:07:09 +0000
commit77660d358c6083176c1cfcb8a2a700ff1e918742 (patch)
tree30fabed86d5d9187e380aa068095d55a0974ba83 /media-gfx/gimp-print
parentnew version (diff)
downloadgentoo-2-77660d358c6083176c1cfcb8a2a700ff1e918742.tar.gz
gentoo-2-77660d358c6083176c1cfcb8a2a700ff1e918742.tar.bz2
gentoo-2-77660d358c6083176c1cfcb8a2a700ff1e918742.zip
New dependancy on foomatic which has just been added to portage. Also
simplified the make install routine. Should fix bug #9014
Diffstat (limited to 'media-gfx/gimp-print')
-rw-r--r--media-gfx/gimp-print/ChangeLog6
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.2.ebuild32
2 files changed, 18 insertions, 20 deletions
diff --git a/media-gfx/gimp-print/ChangeLog b/media-gfx/gimp-print/ChangeLog
index 7896d4ba78af..5d92e5be4d40 100644
--- a/media-gfx/gimp-print/ChangeLog
+++ b/media-gfx/gimp-print/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for media-gfx/gimp-print
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.5 2002/09/30 03:46:16 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.6 2002/10/17 20:07:09 raker Exp $
*gimp-print-4.2.2 (25 Sep 2002)
+ 17 Oct 2002; Nick Hadaway <raker@gentoo.org> gimp-print-4.2.2.ebuild :
+ Added dependancy on foomatic and it now installs with a much simpler
+ make install routine. Should fix bug #9014
+
29 Sep 2002; Nick Hadaway <raker@gentoo.org> gimp-print-4.2.2.ebuild :
Tightened gimp dependancy to the 1.2* series.
diff --git a/media-gfx/gimp-print/gimp-print-4.2.2.ebuild b/media-gfx/gimp-print/gimp-print-4.2.2.ebuild
index 24b50b6bb8f2..fbf85d503ffb 100644
--- a/media-gfx/gimp-print/gimp-print-4.2.2.ebuild
+++ b/media-gfx/gimp-print/gimp-print-4.2.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.2.ebuild,v 1.6 2002/10/16 19:10:17 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.2.ebuild,v 1.7 2002/10/17 20:07:09 raker Exp $
-IUSE="cups doc nls gtk"
+IUSE="cups doc nls"
inherit libtool
@@ -17,11 +17,12 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc alpha"
-DEPEND="=media-gfx/gimp-1.2*
+DEPEND="=x11-libs/gtk+-1.2*
+ =media-gfx/gimp-1.2*
app-text/ghostscript
+ net-print/foomatic
doc? ( app-text/texi2html )
- gtk? ( =x11-libs/gtk+-1.2* )
- cups? ( >=net-print/cups-1.1.14 )"
+ cups? ( >=net-print/cups-1.1.16 )"
RDEPEND="virtual/glibc"
src_compile() {
@@ -47,6 +48,7 @@ src_compile() {
--with-ghost \
--sysconfdir=/etc/gimp/1.2/ \
--with-gimp-exec-prefix=/usr \
+ --with-testpattern \
${myconf} || die
cp src/gimp/Makefile src/gimp/Makefile.orig
@@ -59,21 +61,13 @@ src_compile() {
src_install() {
- dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins
-
- make prefix=${D}/usr \
- bindir=${D}/usr/bin \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- sysconfdir=${D}/etc/gimp/1.2 \
- libdir=${D}/usr/lib \
- datadir=${D}/usr/share \
- cups_conf_serverbin=${D}/usr/lib/cups \
- cups_conf_datadir=${D}/usr/share/cups \
- cups_conf_serverroot=${D}/etc/cups \
- HOME=${D}/usr/lib/gimp/1.2 \
- install || die
+ dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins/print
+ make \
+ DESTDIR=${D} \
+ HOME=/usr/lib/gimp/1.2 \
+ install || die "make install failed"
+
# NOTE: this build uses gimptool to install the plugin, so
# if we dont do it this way, it will install to / no
# matter what.