summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-02-12 15:46:59 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-02-12 15:46:59 +0000
commit2ab64c6c22df62fce83c59fe9439ad0c8c6a3c6e (patch)
tree0bdc594eb5c83846e737e8d0fc1d0d1c5e374956 /media-gfx/gphoto2
parentinitial build of libgphoto2, previously part of gphoto2 (diff)
downloadgentoo-2-2ab64c6c22df62fce83c59fe9439ad0c8c6a3c6e.tar.gz
gentoo-2-2ab64c6c22df62fce83c59fe9439ad0c8c6a3c6e.tar.bz2
gentoo-2-2ab64c6c22df62fce83c59fe9439ad0c8c6a3c6e.zip
heavily updated gphoto2 ebuild
Diffstat (limited to 'media-gfx/gphoto2')
-rw-r--r--media-gfx/gphoto2/ChangeLog11
-rw-r--r--media-gfx/gphoto2/files/digest-gphoto2-2.1.11
-rw-r--r--media-gfx/gphoto2/gphoto2-2.1.1.ebuild57
3 files changed, 68 insertions, 1 deletions
diff --git a/media-gfx/gphoto2/ChangeLog b/media-gfx/gphoto2/ChangeLog
index 0f951f8f9e65..8a18f02dbdc5 100644
--- a/media-gfx/gphoto2/ChangeLog
+++ b/media-gfx/gphoto2/ChangeLog
@@ -1,7 +1,16 @@
# ChangeLog for media-gfx/gphoto2
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto2/ChangeLog,v 1.8 2003/02/12 07:01:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto2/ChangeLog,v 1.9 2003/02/12 15:46:59 spider Exp $
+*gphoto2-2.1.1 (12 feb 2003)
+
+ 12 feb 2003; Spider <spider@gentoo.org> gphoto2-2.1.1.ebuild :
+ lots of changes, libgphoto2 dependency, added aalib? useflag (jpeg is only
+ used to transfer data to aalib for previews.) added ncurses for the
+ configurator frontend, added readline optional diable switch. Marked popt
+ as a fixed dep, since it will become the defacto standard
+
+
*gphoto2-2.1.0 (23 Oct 2002)
diff --git a/media-gfx/gphoto2/files/digest-gphoto2-2.1.1 b/media-gfx/gphoto2/files/digest-gphoto2-2.1.1
new file mode 100644
index 000000000000..69902ae090b0
--- /dev/null
+++ b/media-gfx/gphoto2/files/digest-gphoto2-2.1.1
@@ -0,0 +1 @@
+MD5 ce77b9c9ce25a57990c61f9e301e74b9 gphoto2-2.1.1.tar.bz2 274275
diff --git a/media-gfx/gphoto2/gphoto2-2.1.1.ebuild b/media-gfx/gphoto2/gphoto2-2.1.1.ebuild
new file mode 100644
index 000000000000..c9b6ce4f8e2a
--- /dev/null
+++ b/media-gfx/gphoto2/gphoto2-2.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto2/gphoto2-2.1.1.ebuild,v 1.1 2003/02/12 15:46:59 spider Exp $
+
+inherit libtool
+inherit flag-o-matic
+
+IUSE="nls jpeg"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="free, redistributable digital camera software application"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.bz2"
+HOMEPAGE="http://www.gphoto.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=dev-libs/libusb-0.1.6
+ =dev-libs/glib-1.2*
+ >=sys-libs/zlib-1.1.4
+ ncurses? ( dev-libs/cdk )
+ aalib? (
+ media-libs/aalib
+ media-libs/jpeg )
+ readline? ( sys-libs/readline )
+ dev-libs/popt
+ >=media-libs/libgphoto2-2.1.1"
+
+src_compile() {
+
+ elibtoolize
+ aclocal
+
+ # -pipe does no work
+ filter-flags -pipe
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ncurses || myconf="${myconf} --without-cdk"
+ use aalib || myconf="${myconf} --without-aalib --without-jpeg"
+ use readline || myconf="${myconf} --without-readline"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+
+ einstall
+ gphotodocdir=${D}/usr/share/doc/${PF} \
+ HTML_DIR=${D}/usr/share/doc/${PF}/sgml \
+ || die
+
+ dodoc ChangeLog NEWS* README AUTHORS COPYING
+ rm -rf ${D}/usr/share/doc/${PF}/sgml/gphoto2
+}