summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2009-06-28 17:35:31 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2009-06-28 17:35:31 +0000
commit811374ae368905db33f2a8defa63a2418a7efc31 (patch)
tree5b05de241a44f1b69597a08a1c04472636a6778b /media-gfx/jhead
parentx11-base/xorg-server: backport some more patches from upstream's 1.6 nominati... (diff)
downloadgentoo-2-811374ae368905db33f2a8defa63a2418a7efc31.tar.gz
gentoo-2-811374ae368905db33f2a8defa63a2418a7efc31.tar.bz2
gentoo-2-811374ae368905db33f2a8defa63a2418a7efc31.zip
2.87 version bump, patch to respect flags and change mktemp to mkstemp for bug 275200. Thanks to Zeev
Tarantov <zeev dot tarantov at gmail dot com>. (Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-gfx/jhead')
-rw-r--r--media-gfx/jhead/ChangeLog10
-rw-r--r--media-gfx/jhead/files/jhead-2.87-mkstemp.patch11
-rw-r--r--media-gfx/jhead/files/jhead-2.87-respect_flags.patch23
-rw-r--r--media-gfx/jhead/jhead-2.87.ebuild34
4 files changed, 77 insertions, 1 deletions
diff --git a/media-gfx/jhead/ChangeLog b/media-gfx/jhead/ChangeLog
index 68039089a4f5..6514808dee96 100644
--- a/media-gfx/jhead/ChangeLog
+++ b/media-gfx/jhead/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/jhead
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.108 2009/05/21 08:59:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/ChangeLog,v 1.109 2009/06/28 17:35:31 vanquirius Exp $
+
+*jhead-2.87 (28 Jun 2009)
+
+ 28 Jun 2009; Marcelo Goes <vanquirius@gentoo.org>
+ +files/jhead-2.87-mkstemp.patch, +files/jhead-2.87-respect_flags.patch,
+ +jhead-2.87.ebuild:
+ 2.87 version bump, patch to respect flags and change mktemp to mkstemp for
+ bug 275200. Thanks to Zeev Tarantov <zeev dot tarantov at gmail dot com>.
21 May 2009; Markus Meier <maekke@gentoo.org> -jhead-2.84-r1.ebuild,
-files/jhead-2.84-bug243238.patch:
diff --git a/media-gfx/jhead/files/jhead-2.87-mkstemp.patch b/media-gfx/jhead/files/jhead-2.87-mkstemp.patch
new file mode 100644
index 000000000000..c08bf06f7713
--- /dev/null
+++ b/media-gfx/jhead/files/jhead-2.87-mkstemp.patch
@@ -0,0 +1,11 @@
+--- jhead.c.orig 2009-06-23 17:25:41.545847706 +0300
++++ jhead.c 2009-06-23 17:27:36.621854286 +0300
+@@ -351,7 +351,7 @@
+ while(a > 0 && FileName[a-1] != SLASH) a--;
+ memcpy(TempName, FileName, a);
+ strcpy(TempName+a, "XXXXXX");
+- mktemp(TempName);
++ mkstemp(TempName);
+ if(!TempName[0]) {
+ ErrFatal("Cannot find available temporary file name");
+ }
diff --git a/media-gfx/jhead/files/jhead-2.87-respect_flags.patch b/media-gfx/jhead/files/jhead-2.87-respect_flags.patch
new file mode 100644
index 000000000000..202b6ce8b622
--- /dev/null
+++ b/media-gfx/jhead/files/jhead-2.87-respect_flags.patch
@@ -0,0 +1,23 @@
+--- makefile.orig 2009-06-23 17:08:18.017847256 +0300
++++ makefile 2009-06-23 17:10:32.682853270 +0300
+@@ -3,7 +3,6 @@
+ #--------------------------------
+ OBJ=.
+ SRC=.
+-CFLAGS= -O3 -Wall
+
+ all: jhead
+
+@@ -11,10 +10,10 @@
+ $(OBJ)/exif.o $(OBJ)/iptc.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
+
+ $(OBJ)/%.o:$(SRC)/%.c
+- ${CC} $(CFLAGS) -c $< -o $@
++ ${CC} ${CFLAGS} -c $< -o $@
+
+ jhead: $(objs) jhead.h
+- ${CC} -o jhead $(objs) -lm
++ ${CC} ${LDFLAGS} -o jhead $(objs) -lm
+
+ clean:
+ rm -f $(objs) jhead
diff --git a/media-gfx/jhead/jhead-2.87.ebuild b/media-gfx/jhead/jhead-2.87.ebuild
new file mode 100644
index 000000000000..a10905258841
--- /dev/null
+++ b/media-gfx/jhead/jhead-2.87.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.87.ebuild,v 1.1 2009/06/28 17:35:31 vanquirius Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-${PV}-respect_flags.patch
+ epatch "${FILESDIR}"/${PN}-${PV}-mkstemp.patch
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ dodoc *.txt
+ dohtml *.html
+ doman ${PN}.1
+}