summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2011-04-05 14:18:20 +0000
committerJustin Bronder <jsbronder@gentoo.org>2011-04-05 14:18:20 +0000
commitbf86d1e453211e3a850eee2f1b4eff5f76f880dc (patch)
treeaa81987243a9a989df778e100cfff1265fdda46b /media-gfx/openmesh/openmesh-2.0_rc5.ebuild
parentStable on amd64, bug #360595 (diff)
downloadgentoo-2-bf86d1e453211e3a850eee2f1b4eff5f76f880dc.tar.gz
gentoo-2-bf86d1e453211e3a850eee2f1b4eff5f76f880dc.tar.bz2
gentoo-2-bf86d1e453211e3a850eee2f1b4eff5f76f880dc.zip
Use correct flag for installing static libraries (#361661).
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/openmesh/openmesh-2.0_rc5.ebuild')
-rw-r--r--media-gfx/openmesh/openmesh-2.0_rc5.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-gfx/openmesh/openmesh-2.0_rc5.ebuild b/media-gfx/openmesh/openmesh-2.0_rc5.ebuild
index 44e1155b6afb..4aa64ef61c90 100644
--- a/media-gfx/openmesh/openmesh-2.0_rc5.ebuild
+++ b/media-gfx/openmesh/openmesh-2.0_rc5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-2.0_rc5.ebuild,v 1.2 2010/09/16 17:10:08 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-2.0_rc5.ebuild,v 1.3 2011/04/05 14:18:20 jsbronder Exp $
EAPI="3"
inherit eutils cmake-utils
@@ -17,7 +17,7 @@ SRC_URI="http://openmesh.org/fileadmin/${PN}-files/${MY_PV/-RC/RC}/${MY_PN}-${MY
LICENSE="LGPL-3 as-is"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="qt4 debug static"
+IUSE="qt4 debug static-libs"
RDEPEND="qt4? ( x11-libs/qt-gui:4
x11-libs/qt-opengl:4
@@ -50,7 +50,7 @@ src_configure() {
src_install() {
cmake-utils_src_install
- if ! use static; then
+ if ! use static-libs; then
# No way to set this in the build system as of 2.0_rc5
rm -f "${D}"/usr/$(get_libdir)/*.a \
|| die "Failed to remove static libraries."