summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-08 22:43:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-08 22:43:32 +0000
commitc60b8020f671b6487e70e8d3bc0ea8aa4e80346c (patch)
tree090c3a5277ebbe114057c2723b7cebda5e7f8b5e /media-gfx/pngtools
parentVersion bump. Small bug fixes. (diff)
downloadgentoo-2-c60b8020f671b6487e70e8d3bc0ea8aa4e80346c.tar.gz
gentoo-2-c60b8020f671b6487e70e8d3bc0ea8aa4e80346c.tar.bz2
gentoo-2-c60b8020f671b6487e70e8d3bc0ea8aa4e80346c.zip
Fix building with -Wl,--as-needed and libpng14.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/pngtools')
-rw-r--r--media-gfx/pngtools/ChangeLog8
-rw-r--r--media-gfx/pngtools/files/pngtools-0.4-libpng14.patch34
-rw-r--r--media-gfx/pngtools/pngtools-0.4.ebuild20
3 files changed, 51 insertions, 11 deletions
diff --git a/media-gfx/pngtools/ChangeLog b/media-gfx/pngtools/ChangeLog
index 9639bbf4669d..96b34b8969fc 100644
--- a/media-gfx/pngtools/ChangeLog
+++ b/media-gfx/pngtools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/pngtools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/ChangeLog,v 1.7 2009/11/26 09:22:33 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/ChangeLog,v 1.8 2010/03/08 22:43:31 ssuominen Exp $
+
+ 08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> pngtools-0.4.ebuild,
+ +files/pngtools-0.4-libpng14.patch:
+ Fix building with -Wl,--as-needed and libpng14.
26 Nov 2009; Markus Meier <maekke@gentoo.org> pngtools-0.4.ebuild:
add trailing slash to HOMEPAGE by Mr. Anderson in bug #293205
diff --git a/media-gfx/pngtools/files/pngtools-0.4-libpng14.patch b/media-gfx/pngtools/files/pngtools-0.4-libpng14.patch
new file mode 100644
index 000000000000..f849549bae13
--- /dev/null
+++ b/media-gfx/pngtools/files/pngtools-0.4-libpng14.patch
@@ -0,0 +1,34 @@
+diff -ur pngtools-0.4.orig/Makefile.am pngtools-0.4/Makefile.am
+--- pngtools-0.4.orig/Makefile.am 2008-11-27 01:14:17.000000000 +0200
++++ pngtools-0.4/Makefile.am 2010-03-09 00:51:10.000000000 +0200
+@@ -4,3 +4,6 @@
+ pngcp_SOURCES = pngcp.c pngread.c pngwrite.c inflateraster.c
+ pngchunkdesc_SOURCES = pngchunkdesc.c
+ pngchunks_SOURCES = pngchunks.c
++
++pnginfo_LDADD = -lpng
++pngcp_LDADD = -lpng
+diff -ur pngtools-0.4.orig/pnginfo.c pngtools-0.4/pnginfo.c
+--- pngtools-0.4.orig/pnginfo.c 2008-11-27 01:14:17.000000000 +0200
++++ pngtools-0.4/pnginfo.c 2010-03-09 00:42:58.000000000 +0200
+@@ -152,7 +152,7 @@
+
+ // Check that it really is a PNG file
+ fread (sig, 1, 8, image);
+- if (!png_check_sig (sig, 8))
++ if (!png_sig_cmp(sig, 0, 8) == 0)
+ {
+ printf (" This file is not a valid PNG file\n");
+ fclose (image);
+diff -ur pngtools-0.4.orig/pngread.c pngtools-0.4/pngread.c
+--- pngtools-0.4.orig/pngread.c 2008-11-27 01:14:17.000000000 +0200
++++ pngtools-0.4/pngread.c 2010-03-09 00:43:27.000000000 +0200
+@@ -26,7 +26,7 @@
+
+ // Check that it really is a PNG file
+ fread(sig, 1, 8, image);
+- if(!png_check_sig(sig, 8)){
++ if(!png_sig_cmp(sig, 0, 8) == 0){
+ fprintf(stderr, "This file is not a valid PNG file\n");
+ goto error;
+ }
diff --git a/media-gfx/pngtools/pngtools-0.4.ebuild b/media-gfx/pngtools/pngtools-0.4.ebuild
index 86b2b986e27a..ba912110adeb 100644
--- a/media-gfx/pngtools/pngtools-0.4.ebuild
+++ b/media-gfx/pngtools/pngtools-0.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/pngtools-0.4.ebuild,v 1.5 2009/11/26 09:22:33 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/pngtools-0.4.ebuild,v 1.6 2010/03/08 22:43:31 ssuominen Exp $
-inherit eutils
+EAPI=2
+inherit autotools eutils
MY_PV=${PV/./_}
@@ -15,16 +16,17 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=media-libs/libpng-1.2.8-r1"
+DEPEND=">=media-libs/libpng-1.2.40"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.3-implicit-declarations.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3-implicit-declarations.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+
+ eautoreconf
}
src_install() {
- emake -j1 install DESTDIR="${D}" || die "emake install failed."
+ emake -j1 install DESTDIR="${D}" || die
dodoc ABOUT AUTHORS ChangeLog NEWS README chunks.txt
insinto /usr/share/doc/${PF}/examples
doins *.png