summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-01-07 03:52:57 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-01-07 03:52:57 +0000
commitee802af1ede070d7e4c9c725582d4d1728da49ae (patch)
tree8495cf4f63c6d141cf5b4e6d670d9a2c7a59c062 /media-gfx/quickplot/quickplot-0.8.5.ebuild
parentAdd patch by comabug@gmail.com for the -w flag (dont truncate hostnames) #537... (diff)
downloadgentoo-2-ee802af1ede070d7e4c9c725582d4d1728da49ae.tar.gz
gentoo-2-ee802af1ede070d7e4c9c725582d4d1728da49ae.tar.bz2
gentoo-2-ee802af1ede070d7e4c9c725582d4d1728da49ae.zip
Added sndfile USE flag, tidied up doc installation.
Diffstat (limited to 'media-gfx/quickplot/quickplot-0.8.5.ebuild')
-rw-r--r--media-gfx/quickplot/quickplot-0.8.5.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/media-gfx/quickplot/quickplot-0.8.5.ebuild b/media-gfx/quickplot/quickplot-0.8.5.ebuild
index 02937506d22b..74d2f9bd83ee 100644
--- a/media-gfx/quickplot/quickplot-0.8.5.ebuild
+++ b/media-gfx/quickplot/quickplot-0.8.5.ebuild
@@ -1,29 +1,34 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/quickplot/quickplot-0.8.5.ebuild,v 1.1 2005/01/06 07:42:35 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/quickplot/quickplot-0.8.5.ebuild,v 1.2 2005/01/07 03:52:57 cryos Exp $
DESCRIPTION="A fast interactive 2D plotter."
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
HOMEPAGE="http://quickplot.sourceforge.net/"
-IUSE=""
+IUSE="sndfile"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64"
-DEPEND=">=dev-util/pkgconfig-0.15
- >=dev-cpp/gtkmm-2.4.5
- >=media-libs/libsndfile-1.0.5"
+RDEPEND=">=dev-cpp/gtkmm-2.4.5
+ sndfile? ( >=media-libs/libsndfile-1.0.5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
src_compile() {
- econf || die "econf step failed."
- emake || die "emake step failed."
+ econf `use_with sndfile libsndfile` || die "econf step failed."
+ emake htmldir=/usr/share/doc/${PF}/html || die "emake step failed."
}
src_install () {
- make install DESTDIR=${D} || die "make install step failed."
- # Remove the licence as it is specified in LICENCE
- rm ${D}/usr/share/doc/${PN}/COPYING
- # Move the docs to the correct location
- mv ${D}/usr/share/doc/${PN} ${D}/usr/share/doc/${PF}
+ make install DESTDIR=${D} htmldir=/usr/share/doc/${PF}/html \
+ || die "make install step failed."
+ dodoc AUTHORS ChangeLog README README.devel TODO
+ # Remove COPYING as it is specified in LICENCE. Move other stuff.
+ cd ${D}/usr/share/doc/${PF}/html
+ rm COPYING quickplot_icon.png ChangeLog
+ mv ${D}/usr/share/pixmaps/quickplot_icon.png \
+ ${D}/usr/share/pixmaps/quickplot.png
}