summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-03-08 23:40:49 +0000
committerMichael Januszewski <spock@gentoo.org>2005-03-08 23:40:49 +0000
commit0cb9496fb78daeb752469ca7d448773522c1e605 (patch)
tree5f6bf1701d5f71f5fc474f1d030017ce1e3cbdd9 /media-gfx/splashutils
parentNew ebuild - net client library for OCaml. (Manifest recommit) (diff)
downloadgentoo-2-0cb9496fb78daeb752469ca7d448773522c1e605.tar.gz
gentoo-2-0cb9496fb78daeb752469ca7d448773522c1e605.tar.bz2
gentoo-2-0cb9496fb78daeb752469ca7d448773522c1e605.zip
Added a development version of splashutils.
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog8
-rw-r--r--media-gfx/splashutils/files/digest-splashutils-1.1.9.15
-rw-r--r--media-gfx/splashutils/splashutils-1.1.9.1.ebuild136
3 files changed, 148 insertions, 1 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 61933ed703f8..3a54ab0b73bb 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.19 2005/03/08 17:34:22 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.20 2005/03/08 23:40:49 spock Exp $
+
+*splashutils-1.1.9.1 (09 Mar 2005)
+
+ 09 Mar 2005; Michael Januszewski <spock@gentoo.org>
+ +splashutils-1.1.9.1.ebuild:
+ Added a development version of splashutils.
08 Mar 2005; Michael Januszewski <spock@gentoo.org>
splashutils-0.9.1.ebuild, -splashutils-0.9_pre09.ebuild,
diff --git a/media-gfx/splashutils/files/digest-splashutils-1.1.9.1 b/media-gfx/splashutils/files/digest-splashutils-1.1.9.1
new file mode 100644
index 000000000000..0ff70046caa8
--- /dev/null
+++ b/media-gfx/splashutils/files/digest-splashutils-1.1.9.1
@@ -0,0 +1,5 @@
+MD5 e7bb456b7f5ac2ff194206b4c37cedc6 splashutils-1.1.9.1.tar.bz2 2649372
+MD5 c9f3ded0d9ee20429ee8a3aabd23e01d splashutils-gentoo-0.1.5.tar.bz2 6669
+MD5 71f85c661c144665ff5d4a8bbef1936e miscsplashutils-0.1.2.tar.bz2 91301
+MD5 53437014b3e4ddd2d72de7f6e88e1486 fbsplash-theme-emergence-r2.tar.bz2 4794297
+MD5 a63484ca6ce645cfbacc30c91bbf746c fbsplash-theme-gentoo-r1.tar.bz2 5266047
diff --git a/media-gfx/splashutils/splashutils-1.1.9.1.ebuild b/media-gfx/splashutils/splashutils-1.1.9.1.ebuild
new file mode 100644
index 000000000000..142f694df906
--- /dev/null
+++ b/media-gfx/splashutils/splashutils-1.1.9.1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.1.ebuild,v 1.1 2005/03/08 23:40:49 spock Exp $
+
+MISCSPLASH="miscsplashutils-0.1.2"
+GENTOOSPLASH="splashutils-gentoo-0.1.5"
+KLIBC_VERSION="0.199"
+
+DESCRIPTION="Framebuffer splash utilities."
+HOMEPAGE="http://dev.gentoo.org/~spock/"
+SRC_URI="mirror://gentoo/${P/_/-}.tar.bz2
+ mirror://gentoo/${GENTOOSPLASH}.tar.bz2
+ mirror://gentoo/${MISCSPLASH}.tar.bz2
+ mirror://gentoo/fbsplash-theme-emergence-r2.tar.bz2
+ mirror://gentoo/fbsplash-theme-gentoo-r1.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="hardened"
+RDEPEND=">=media-libs/freetype-2
+ >=media-libs/libpng-1.2.7
+ >=media-libs/jpeg-6b
+ >=sys-apps/baselayout-1.9.4-r5
+ !media-gfx/bootsplash"
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+
+S="${WORKDIR}/${P/_/-}"
+SG="${WORKDIR}/${GENTOOSPLASH}"
+SM="${WORKDIR}/${MISCSPLASH}"
+
+pkg_setup() {
+ if use hardened; then
+ ewarn "Due to problems with klibc, it is currently impossible to compile splashutils"
+ ewarn "with 'hardened' GCC flags. As a workaround, the package will be compiled with"
+ ewarn "-fno-stack-protector. Hardened GCC features will not be used while building"
+ ewarn "the fbsplash kernel helper."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ ln -s /usr/src/linux ${S}/linux
+ if [[ ! -e /usr/src/linux/include/linux/console_splash.h ]]; then
+ eerror "Your kernel in /usr/src/linux has not been patched with a compatible version"
+ eerror "of fbsplash. Please download the latest patch from http://dev.gentoo.org/~spock/"
+ eerror "and patch your kernel."
+ die "Fbsplash not found"
+ fi
+
+ if [ ! -e /usr/src/linux/include/asm ]; then
+ if [ -z "${KBUILD_OUTPUT}" ] ||
+ [ ! -e "${KBUILD_OUTPUT}/include/asm" ]; then
+ eerror "It appears that your kernel has not been configured. Please run at least"
+ eerror "\`make prepare\` before merging splashutils."
+ die "Kernel not configured"
+ else
+ t=$(readlink ${KBUILD_OUTPUT}/include/asm)
+ ln -s /usr/src/linux/include/${t} ${T}/asm
+ fi
+ fi
+
+ # this should make this version of splashutils compile on hardened systems
+ if use hardened; then
+ sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i ${S}/Makefile
+ sed -e 's@CFLAGS =@CFLAGS = -fno-stack-protector@' -i ${S}/libs/klibc-${KLIBC_VERSION}/klibc/MCONFIG
+ fi
+
+ mkdir ${S}/kernel
+}
+
+src_compile() {
+ local miscincs
+
+ if [ -n "${KBUILD_OUTPUT}" ]; then
+ miscincs="-I${T} -I${KBUILD_OUTPUT}/include"
+ fi
+
+ emake -j1 MISCINCS="${miscincs}" || die "failed to build splashutils"
+
+ cd ${SM}
+ emake || die "failed to build miscsplashutils"
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install || die
+
+ cd ${SM}
+ make DESTDIR=${D} install || die
+
+ exeinto /sbin
+ doexe ${SG}/splash
+
+ exeinto /etc/init.d
+ newexe ${SG}/init-splash splash
+
+ insinto /sbin
+ doins ${SG}/splash-functions.sh
+
+ insinto /etc/conf.d
+ newins ${SG}/splash.conf splash
+
+ dodir /etc/splash/{emergence,gentoo}
+ cp -pR ${WORKDIR}/{emergence,gentoo} ${D}/etc/splash
+ ln -s emergence ${D}/etc/splash/default
+ dodoc docs/* README AUTHORS
+
+ if [ ! -e ${ROOT}/etc/splash/default ]; then
+ dosym /etc/splash/emergence /etc/splash/default
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Due to a change in the splash protocol you will have to rebuild"
+ ewarn "all initrds created with previous versions of splashutils. This"
+ ewarn "can be done with the splash_geninitramsfs script."
+ echo ""
+ einfo "For best effects, this new version of splashutils requires some"
+ einfo "slight modifications to the kernel command line arguments in"
+ einfo "GRUB/LILO/whatever bootloader you use."
+ echo ""
+ einfo "It is required that you add 'CONSOLE=/dev/tty1', to make sure all"
+ einfo "init messages are printed to the first tty, and not the current one."
+ einfo "It is advised that you add 'quiet' as an additional, standalone"
+ einfo "parameter."
+ echo ""
+ einfo "After these modifications, the relevant part of the kernel command"
+ einfo "line might look like:"
+ einfo " splash=silent,fadein,tty:8,theme:emergence quiet CONSOLE=/dev/tty1"
+ echo ""
+ einfo "'tty:x' is used to specify the silent tty number. Use it to adjust"
+ einfo "the silent splash so that there are no conflicts with services like"
+ einfo "consolefont."
+}