summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-04-06 19:18:43 +0000
committerMichael Januszewski <spock@gentoo.org>2009-04-06 19:18:43 +0000
commit41a26cac8ed7407e43e2eaccf3d4263ab7d523ac (patch)
treebe7058123695d26c4a8ed05e3be5addb0d3fb4b9 /media-gfx/splashutils
parentStable on sparc, bug #251832 (diff)
downloadgentoo-2-41a26cac8ed7407e43e2eaccf3d4263ab7d523ac.tar.gz
gentoo-2-41a26cac8ed7407e43e2eaccf3d4263ab7d523ac.tar.bz2
gentoo-2-41a26cac8ed7407e43e2eaccf3d4263ab7d523ac.zip
Fix the problem of the progress bar not reaching 100% during reboot.
(Portage version: 2.1.6.11/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog7
-rw-r--r--media-gfx/splashutils/files/splashutils-1.5.4.3-openrc-umount-fix.patch29
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4.3.ebuild6
3 files changed, 39 insertions, 3 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index e3d5134d7d14..107244f47a1d 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.155 2009/03/25 21:43:41 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.156 2009/04/06 19:18:43 spock Exp $
+
+ 06 Apr 2009; Michał Januszewski <spock@gentoo.org>
+ +files/splashutils-1.5.4.3-openrc-umount-fix.patch,
+ splashutils-1.5.4.3.ebuild:
+ Fix the problem of the progress bar not reaching 100% during reboot.
25 Mar 2009; Michał Januszewski <spock@gentoo.org>
+files/splashutils-openrc-0.4.3-runlevel-fix.patch,
diff --git a/media-gfx/splashutils/files/splashutils-1.5.4.3-openrc-umount-fix.patch b/media-gfx/splashutils/files/splashutils-1.5.4.3-openrc-umount-fix.patch
new file mode 100644
index 000000000000..dcb1ef99440c
--- /dev/null
+++ b/media-gfx/splashutils/files/splashutils-1.5.4.3-openrc-umount-fix.patch
@@ -0,0 +1,29 @@
+commit ae4b5cc9c2d904e18db51876d9bd292504714600
+Author: Michał Januszewski <spock@gentoo.org>
+Date: Mon Apr 6 20:59:48 2009 +0200
+
+ Prevent umounting of theme directories.
+
+ Some themes dynamically modify themselves during boot. In order to be
+ able to do that, they mount a tmpfs in their main directory. Prevent
+ openrc from umounting this directory when rebooting.
+
+diff --git a/gentoo/splash.c b/gentoo/splash.c
+index 048e0ec..d831d0c 100644
+--- a/gentoo/splash.c
++++ b/gentoo/splash.c
+@@ -968,10 +968,10 @@ do_start:
+ if (name && !strcmp(name, "localmount")) {
+ char *umounts = getenv("RC_NO_UMOUNTS");
+
+- if (umounts)
+- fprintf(rc_environ_fd, "RC_NO_UMOUNTS=%s:%s", umounts, FBSPLASH_CACHEDIR);
+- else
+- fprintf(rc_environ_fd, "RC_NO_UMOUNTS=%s", FBSPLASH_CACHEDIR);
++ if (umounts)
++ fprintf(rc_environ_fd, "RC_NO_UMOUNTS=%s:" FBSPLASH_CACHEDIR ":/etc/splash/%s", umounts, config->theme);
++ else
++ fprintf(rc_environ_fd, "RC_NO_UMOUNTS=" FBSPLASH_CACHEDIR ":/etc/splash/%s", config->theme);
+ }
+ i = splash_svc_handle(name, "svc_stop", false);
+ break;
diff --git a/media-gfx/splashutils/splashutils-1.5.4.3.ebuild b/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
index 635d3b39142e..2cd72d9aa01f 100644
--- a/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.3.ebuild,v 1.8 2009/03/25 21:43:41 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.3.ebuild,v 1.9 2009/04/06 19:18:43 spock Exp $
EAPI="1"
@@ -94,6 +94,7 @@ src_unpack() {
fi
fi
epatch "${FILESDIR}"/splashutils-1.5.4.3-fix_rc_var.patch
+ epatch "${FILESDIR}"/splashutils-1.5.4.3-openrc-umount-fix.patch
cd "${S}"
rm -f m4/*
@@ -116,7 +117,8 @@ src_compile() {
--with-freetype2-src=${FT2SRC} \
--with-jpeg-src=${JPEGSRC} \
--with-lpng-src=${LPNGSRC} \
- --with-zlib-src=${ZLIBSRC} || die "failed to configure splashutils"
+ --with-zlib-src=${ZLIBSRC} \
+ --with-essential-libdir=/$(get_libdir) || die "failed to configure splashutils"
emake CC="${CC}" STRIP="true" || die "failed to build splashutils"