summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-11-12 21:33:31 +0000
committerMichael Januszewski <spock@gentoo.org>2004-11-12 21:33:31 +0000
commit91f93006496ab1448d378b062fd834b98926bfc1 (patch)
tree71fbefef23939582ee13dd1fb8184dd953750bb4 /media-gfx/splashutils
parentold (Manifest recommit) (diff)
downloadgentoo-2-91f93006496ab1448d378b062fd834b98926bfc1.tar.gz
gentoo-2-91f93006496ab1448d378b062fd834b98926bfc1.tar.bz2
gentoo-2-91f93006496ab1448d378b062fd834b98926bfc1.zip
Version bump.
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog9
-rw-r--r--media-gfx/splashutils/files/digest-splashutils-0.9_rc15
-rw-r--r--media-gfx/splashutils/splashutils-0.9_rc1.ebuild103
3 files changed, 116 insertions, 1 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index fd88ed3f0ee6..fe436084bec1 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.10 2004/10/20 10:28:00 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.11 2004/11/12 21:33:31 spock Exp $
+
+*splashutils-0.9_rc1 (12 Nov 2004)
+
+ 12 Nov 2004; Michal Januszewski <spock@gentoo.org>
+ +splashutils-0.9_rc1.ebuild:
+ A new bugfix release. Closes #68853 and #70029. Fixes some theme issues
+ (wrong images for 8bpp, wrong box coordinates for the gentoo theme).
20 Oct 2004; Michal Januszewski <spock@gentoo.org>
splashutils-0.9_pre10.ebuild:
diff --git a/media-gfx/splashutils/files/digest-splashutils-0.9_rc1 b/media-gfx/splashutils/files/digest-splashutils-0.9_rc1
new file mode 100644
index 000000000000..e6553540ac65
--- /dev/null
+++ b/media-gfx/splashutils/files/digest-splashutils-0.9_rc1
@@ -0,0 +1,5 @@
+MD5 997191fb6dfc2d6161a8203383396ad8 splashutils-0.9-rc1.tar.bz2 1614534
+MD5 71f85c661c144665ff5d4a8bbef1936e miscsplashutils-0.1.2.tar.bz2 91301
+MD5 f9fd3f0be4251f14f01e689c11bdc68f splashutils-gentoo-0.1.3.tar.bz2 3650
+MD5 53437014b3e4ddd2d72de7f6e88e1486 fbsplash-theme-emergence-r2.tar.bz2 4794297
+MD5 a63484ca6ce645cfbacc30c91bbf746c fbsplash-theme-gentoo-r1.tar.bz2 5266047
diff --git a/media-gfx/splashutils/splashutils-0.9_rc1.ebuild b/media-gfx/splashutils/splashutils-0.9_rc1.ebuild
new file mode 100644
index 000000000000..249ae1dccbe5
--- /dev/null
+++ b/media-gfx/splashutils/splashutils-0.9_rc1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-0.9_rc1.ebuild,v 1.1 2004/11/12 21:33:31 spock Exp $
+
+MISCSPLASH="miscsplashutils-0.1.2"
+GENTOOSPLASH="splashutils-gentoo-0.1.3"
+
+DESCRIPTION="Framebuffer splash utilities."
+HOMEPAGE="http://dev.gentoo.org/~spock/"
+SRC_URI="mirror://gentoo/${P/_/-}.tar.bz2
+ mirror://gentoo/${MISCSPLASH}.tar.bz2
+ mirror://gentoo/${GENTOOSPLASH}.tar.bz2
+ mirror://gentoo/fbsplash-theme-emergence-r2.tar.bz2
+ mirror://gentoo/fbsplash-theme-gentoo-r1.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=">=media-libs/freetype-2
+ media-libs/libpng
+ media-libs/jpeg
+ >=sys-apps/baselayout-1.9.4-r5
+ !media-gfx/bootsplash"
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+
+S="${WORKDIR}/${P/_/-}"
+SM="${WORKDIR}/${MISCSPLASH}"
+SG="${WORKDIR}/${GENTOOSPLASH}"
+
+src_unpack() {
+ unpack ${A}
+ ln -s /usr/src/linux ${S}/linux
+ if [ ! -e /usr/src/linux/include/linux/console_splash.h ]; then
+ eerror "Your kernel in /usr/src/linux has not been patched with a compatible version"
+ eerror "of fbsplash. Please download the latest patch from http://dev.gentoo.org/~spock/"
+ eerror "and patch your kernel."
+ die "Fbsplash not found"
+ fi
+
+ if [ ! -e /usr/src/linux/include/asm ]; then
+
+ t=$(readlink /usr/src/linux)
+ t=${t#/usr/src/}
+
+ if [ -z "${KBUILD_OUTPUT_PREFIX}" ] ||
+ [ ! -e "${KBUILD_OUTPUT_PREFIX}/${t/linux-}/include/asm" ]; then
+ eerror "It appears that your kernel has not been configured. Please run at least"
+ eerror "\`make prepare\` before merging splashutils."
+ die "Kernel not configured"
+ else
+ t2=$(readlink ${KBUILD_OUTPUT_PREFIX}/${t/linux-}/include/asm)
+ ln -s /usr/src/linux/include/${t2} ${T}/asm
+ sed -e "s@#CHANGEME#@${T}/@" -i ${S}/libs/klibc-0.179/klibc/makeerrlist.pl
+ fi
+ fi
+}
+
+src_compile() {
+
+ local miscincs
+
+ if [ -n "${KBUILD_OUTPUT_PREFIX}" ]; then
+ t=$(readlink /usr/src/linux)
+ t=${t#/usr/src/}
+ miscincs="-I${T} -I${KBUILD_OUTPUT_PREFIX}/${t/linux-}/include"
+ fi
+
+ emake -j1 MISCINCS="${miscincs}"
+
+ cd ${SM}
+ emake
+}
+
+src_install() {
+ cd ${SM}
+ make DESTDIR=${D} install || die
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+
+ exeinto /sbin
+ doexe ${SG}/splash
+
+ exeinto /etc/init.d
+ newexe ${SG}/init-splash splash
+
+ insinto /sbin
+ doins ${SG}/splash-functions.sh
+
+ insinto /etc/conf.d
+ newins ${SG}/splash.conf splash
+
+ dodir /etc/splash/{emergence,gentoo}
+ cp -pR ${WORKDIR}/{emergence,gentoo} ${D}/etc/splash
+ ln -s emergence ${D}/etc/splash/default
+ dodoc docs/* README AUTHORS
+
+ if [ ! -e ${ROOT}/etc/splash/default ]; then
+ dosym /etc/splash/emergence /etc/splash/default
+ fi
+}