summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-08-26 10:40:37 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-08-26 10:40:37 +0000
commitaa0b55dd918cbe48b57f26eb25267df0036c1719 (patch)
tree939328786e21ae83174f034bbce90ba82cec30c0 /media-gfx/symboleditor
parentFix build failure against stable freetype (bug #506124 by Nathan Caldwell and... (diff)
downloadgentoo-2-aa0b55dd918cbe48b57f26eb25267df0036c1719.tar.gz
gentoo-2-aa0b55dd918cbe48b57f26eb25267df0036c1719.tar.bz2
gentoo-2-aa0b55dd918cbe48b57f26eb25267df0036c1719.zip
New package.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'media-gfx/symboleditor')
-rw-r--r--media-gfx/symboleditor/ChangeLog10
-rw-r--r--media-gfx/symboleditor/files/symboleditor-1.5.0-cflags.patch25
-rw-r--r--media-gfx/symboleditor/metadata.xml5
-rw-r--r--media-gfx/symboleditor/symboleditor-1.5.0.ebuild26
4 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/symboleditor/ChangeLog b/media-gfx/symboleditor/ChangeLog
new file mode 100644
index 000000000000..8ae886d971a3
--- /dev/null
+++ b/media-gfx/symboleditor/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/symboleditor
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/symboleditor/ChangeLog,v 1.1 2014/08/26 10:40:37 kensington Exp $
+
+*symboleditor-1.5.0 (26 Aug 2014)
+
+ 26 Aug 2014; Michael Palimaka <kensington@gentoo.org>
+ +files/symboleditor-1.5.0-cflags.patch, +metadata.xml,
+ +symboleditor-1.5.0.ebuild:
+ New package.
diff --git a/media-gfx/symboleditor/files/symboleditor-1.5.0-cflags.patch b/media-gfx/symboleditor/files/symboleditor-1.5.0-cflags.patch
new file mode 100644
index 000000000000..177fd180d56a
--- /dev/null
+++ b/media-gfx/symboleditor/files/symboleditor-1.5.0-cflags.patch
@@ -0,0 +1,25 @@
+From a495671be994a32f4b52840f7e5c358916a378dc Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Tue, 26 Aug 2014 20:17:22 +1000
+Subject: [PATCH] Respect user-defined CFLAGS.
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3166676..50786be 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -43,7 +43,7 @@ kde4_add_executable (SymbolEditor ${SymbolEditor_SRCS})
+
+ target_link_libraries (SymbolEditor ${KDE4_KDEUI_LIBS} ${KDE4_KIO_LIBS})
+
+-set (CMAKE_CXX_FLAGS "-DQT_NO_COMPAT -DKDE_NO_COMPAT")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexceptions -DQT_NO_COMPAT -DKDE_NO_COMPAT")
+
+ install (TARGETS SymbolEditor DESTINATION ${BIN_INSTALL_DIR})
+ install (FILES SymbolEditorui.rc DESTINATION ${DATA_INSTALL_DIR}/SymbolEditor)
+--
+1.8.5.5
+
diff --git a/media-gfx/symboleditor/metadata.xml b/media-gfx/symboleditor/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/media-gfx/symboleditor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/media-gfx/symboleditor/symboleditor-1.5.0.ebuild b/media-gfx/symboleditor/symboleditor-1.5.0.ebuild
new file mode 100644
index 000000000000..9daa2edb5787
--- /dev/null
+++ b/media-gfx/symboleditor/symboleditor-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/symboleditor/symboleditor-1.5.0.ebuild,v 1.1 2014/08/26 10:40:37 kensington Exp $
+
+EAPI=5
+
+KDE_DOC_DIRS="doc-translations/%lingua_${PN}"
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="ca cs da de en_GB es et lt nl pl pt pt_BR sk sv uk"
+MY_P="SymbolEditor-${PV}"
+inherit kde4-base
+
+DESCRIPTION="Program to create libraries of QPainterPath objects with hints on how to render them"
+HOMEPAGE="http://userbase.kde.org/SymbolEditor"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${MY_P}-1.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-cflags.patch" )