summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-07-21 18:00:24 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-07-21 18:00:24 +0000
commit12a08c3959e52ad48684ec8467bf2473644f33de (patch)
tree1b328d4343877d451e247fd9b90364357de9a6f3 /media-gfx
parentfix deps (diff)
downloadgentoo-2-12a08c3959e52ad48684ec8467bf2473644f33de.tar.gz
gentoo-2-12a08c3959e52ad48684ec8467bf2473644f33de.tar.bz2
gentoo-2-12a08c3959e52ad48684ec8467bf2473644f33de.zip
install executables in /usr, prefix support (bug #476142)
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fondu/ChangeLog10
-rw-r--r--media-gfx/fondu/fondu-20060102-r1.ebuild33
2 files changed, 40 insertions, 3 deletions
diff --git a/media-gfx/fondu/ChangeLog b/media-gfx/fondu/ChangeLog
index 9c1312df9ae6..4de20fc88377 100644
--- a/media-gfx/fondu/ChangeLog
+++ b/media-gfx/fondu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/fondu
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fondu/ChangeLog,v 1.9 2010/06/26 13:36:13 nixnut Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fondu/ChangeLog,v 1.10 2013/07/21 18:00:24 ottxor Exp $
+
+*fondu-20060102-r1 (21 Jul 2013)
+
+ 21 Jul 2013; Christoph Junghans <ottxor@gentoo.org> +fondu-20060102-r1.ebuild:
+ install executables in /usr, prefix support (bug #476142)
26 Jun 2010; <nixnut@gentoo.org> fondu-20060102.ebuild:
ppc stable #317247
@@ -40,4 +45,3 @@
+fondu-20040527.ebuild:
Initial import. Ebuild submitted by Jose Sia Jr. <jsia@id.iit.edu>,
closing bug #24732
-
diff --git a/media-gfx/fondu/fondu-20060102-r1.ebuild b/media-gfx/fondu/fondu-20060102-r1.ebuild
new file mode 100644
index 000000000000..84f56b416f11
--- /dev/null
+++ b/media-gfx/fondu/fondu-20060102-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fondu/fondu-20060102-r1.ebuild,v 1.1 2013/07/21 18:00:24 ottxor Exp $
+
+EAPI="5"
+
+inherit eutils
+
+MY_PV=${PV:2:6}
+
+DESCRIPTION="Utilities for converting between and manipulating mac fonts and unix fonts"
+HOMEPAGE="http://fondu.sourceforge.net/"
+SRC_URI="http://fondu.sourceforge.net/${PN}_src-${MY_PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ sed -e 's:^CFLAGS =:CFLAGS +=:' \
+ -e 's:$(CFLAGS) -o:$(CFLAGS) $(LDFLAGS) -o:' \
+ -e 's:wilprefix:prefix:' \
+ -i Makefile.in || die "failed to sed"
+ epatch "${FILESDIR}/${P}-build-fix.patch"
+}
+
+src_install() {
+ default
+ doman *.1
+}