summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-27 15:51:25 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-27 15:51:25 +0000
commit1caa7380ce4f8b7e8cdc65c6d744b628de8ff74b (patch)
tree10238b06251733da5eedb691d1beafda5877fb31 /media-gfx
parentRemove older version (diff)
downloadgentoo-2-1caa7380ce4f8b7e8cdc65c6d744b628de8ff74b.tar.gz
gentoo-2-1caa7380ce4f8b7e8cdc65c6d744b628de8ff74b.tar.bz2
gentoo-2-1caa7380ce4f8b7e8cdc65c6d744b628de8ff74b.zip
Revision bump to fix multilib strictness. Fixes bug #376627.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphite2/ChangeLog9
-rw-r--r--media-gfx/graphite2/files/graphite2-multilib-strict.patch21
-rw-r--r--media-gfx/graphite2/graphite2-0.9.4-r1.ebuild (renamed from media-gfx/graphite2/graphite2-0.9.4.ebuild)3
3 files changed, 31 insertions, 2 deletions
diff --git a/media-gfx/graphite2/ChangeLog b/media-gfx/graphite2/ChangeLog
index 7d5ace21621b..5b4726c590b1 100644
--- a/media-gfx/graphite2/ChangeLog
+++ b/media-gfx/graphite2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/graphite2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.3 2011/07/27 10:06:52 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/ChangeLog,v 1.4 2011/07/27 15:51:25 scarabeus Exp $
+
+*graphite2-0.9.4-r1 (27 Jul 2011)
+
+ 27 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/graphite2-multilib-strict.patch, -graphite2-0.9.4.ebuild,
+ +graphite2-0.9.4-r1.ebuild:
+ Revision bump to fix multilib strictness. Fixes bug #376627.
27 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org> graphite2-0.9.4.ebuild:
Fix CFLAGS parameters. Should fix build on gcc-4.6. Fixes bug #376567.
diff --git a/media-gfx/graphite2/files/graphite2-multilib-strict.patch b/media-gfx/graphite2/files/graphite2-multilib-strict.patch
new file mode 100644
index 000000000000..66d849a63369
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-multilib-strict.patch
@@ -0,0 +1,21 @@
+diff -urN graphite2-0.9.4.old/CMakeLists.txt graphite2-0.9.4/CMakeLists.txt
+--- graphite2-0.9.4.old/CMakeLists.txt 2011-07-27 17:45:26.000000000 +0200
++++ graphite2-0.9.4/CMakeLists.txt 2011-07-27 17:48:30.000000000 +0200
+@@ -68,5 +68,5 @@
+
+ configure_file(graphite2.pc.in graphite2.pc)
+
+-install(FILES ${PROJECT_BINARY_DIR}/graphite2.pc DESTINATION lib/pkgconfig)
++install(FILES ${PROJECT_BINARY_DIR}/graphite2.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)
+
+diff -urN graphite2-0.9.4.old/src/CMakeLists.txt graphite2-0.9.4/src/CMakeLists.txt
+--- graphite2-0.9.4.old/src/CMakeLists.txt 2011-07-27 17:45:26.000000000 +0200
++++ graphite2-0.9.4/src/CMakeLists.txt 2011-07-27 17:48:04.000000000 +0200
+@@ -182,6 +182,6 @@
+ endif (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+
+
+-install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib ARCHIVE DESTINATION lib PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
++install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
+ install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
+
diff --git a/media-gfx/graphite2/graphite2-0.9.4.ebuild b/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild
index 4f50cb2cf399..7e3741d712a3 100644
--- a/media-gfx/graphite2/graphite2-0.9.4.ebuild
+++ b/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-0.9.4.ebuild,v 1.3 2011/07/27 10:06:52 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphite2/graphite2-0.9.4-r1.ebuild,v 1.1 2011/07/27 15:51:25 scarabeus Exp $
EAPI=4
@@ -31,6 +31,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-includes-libs-perl.patch"
"${FILESDIR}/${PN}-disablefonttest.patch"
+ "${FILESDIR}/${PN}-multilib-strict.patch"
)
pkg_setup() {