summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-12 18:36:25 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-12 18:36:25 +0000
commit35cabe6bbafd1d382547772e3157cc82a03d3cc7 (patch)
tree26f44212d3fd761b1e562f0f82d3bd4da22e355d /media-gfx
parentFix LICENSE, see notices in source files, bug 448274. (diff)
downloadgentoo-2-35cabe6bbafd1d382547772e3157cc82a03d3cc7.tar.gz
gentoo-2-35cabe6bbafd1d382547772e3157cc82a03d3cc7.tar.bz2
gentoo-2-35cabe6bbafd1d382547772e3157cc82a03d3cc7.zip
Version bump. Add graphicsmagick/jpeg2k use flags and update the desktop mime database on install. Add pax_kernel use flag to work around hardened issue (bug #448692 by prometheanfire).
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/darktable/ChangeLog12
-rw-r--r--media-gfx/darktable/darktable-1.1.2.ebuild120
-rw-r--r--media-gfx/darktable/darktable-9999.ebuild23
-rw-r--r--media-gfx/darktable/metadata.xml1
4 files changed, 150 insertions, 6 deletions
diff --git a/media-gfx/darktable/ChangeLog b/media-gfx/darktable/ChangeLog
index 6e8bff16fa48..d0815b667079 100644
--- a/media-gfx/darktable/ChangeLog
+++ b/media-gfx/darktable/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/darktable
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/darktable/ChangeLog,v 1.32 2012/12/19 19:15:46 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/darktable/ChangeLog,v 1.33 2013/01/12 18:36:25 radhermit Exp $
+
+*darktable-1.1.2 (12 Jan 2013)
+
+ 12 Jan 2013; Tim Harder <radhermit@gentoo.org> +darktable-1.1.2.ebuild,
+ darktable-9999.ebuild, metadata.xml:
+ Version bump. Add graphicsmagick/jpeg2k use flags and update the desktop mime
+ database on install. Add pax_kernel use flag to work around hardened issue
+ (bug #448692 by prometheanfire).
19 Dec 2012; Tim Harder <radhermit@gentoo.org> darktable-9999.ebuild,
metadata.xml:
diff --git a/media-gfx/darktable/darktable-1.1.2.ebuild b/media-gfx/darktable/darktable-1.1.2.ebuild
new file mode 100644
index 000000000000..9458766365a9
--- /dev/null
+++ b/media-gfx/darktable/darktable-1.1.2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/darktable/darktable-1.1.2.ebuild,v 1.1 2013/01/12 18:36:25 radhermit Exp $
+
+EAPI="5"
+
+inherit cmake-utils toolchain-funcs gnome2-utils fdo-mime pax-utils eutils
+
+DESCRIPTION="A virtual lighttable and darkroom for photographers"
+HOMEPAGE="http://www.darktable.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${PN}-usermanual-1.1.1.pdf )"
+
+LICENSE="GPL-3 CCPL-Attribution-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="colord doc facebook flickr geo gnome-keyring gphoto2 graphicsmagick jpeg2k kde
+nls opencl openmp pax_kernel +rawspeed +slideshow"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/libxml2:2
+ colord? ( x11-misc/colord )
+ facebook? ( dev-libs/json-glib )
+ flickr? ( media-libs/flickcurl )
+ geo? ( net-libs/libsoup:2.4 )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ gnome-base/librsvg:2
+ gphoto2? ( media-libs/libgphoto2 )
+ graphicsmagick? ( media-gfx/graphicsmagick )
+ jpeg2k? ( media-libs/openjpeg )
+ kde? (
+ dev-libs/dbus-glib
+ kde-base/kwalletd
+ )
+ media-gfx/exiv2[xmp]
+ media-libs/lcms:2
+ >=media-libs/lensfun-0.2.3
+ media-libs/libpng
+ media-libs/openexr
+ media-libs/tiff
+ net-misc/curl
+ opencl? ( virtual/opencl )
+ slideshow? (
+ media-libs/libsdl
+ virtual/glu
+ virtual/opengl
+ )
+ virtual/jpeg
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_prepare() {
+ sed -e "s:\(/share/doc/\)darktable:\1${PF}:" \
+ -e "s:LICENSE::" \
+ -i doc/CMakeLists.txt || die
+
+ epatch_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use colord COLORD)
+ $(cmake-utils_use_use facebook GLIBJSON)
+ $(cmake-utils_use_use flickr FLICKR)
+ $(cmake-utils_use_use geo GEO)
+ $(cmake-utils_use_use gnome-keyring GNOME_KEYRING)
+ $(cmake-utils_use_use gphoto2 CAMERA_SUPPORT)
+ $(cmake-utils_use_use graphicsmagick GRAPHICSMAGICK)
+ $(cmake-utils_use_use jpeg2k OPENJPEG)
+ $(cmake-utils_use_use kde KWALLET)
+ $(cmake-utils_use_use nls NLS)
+ $(cmake-utils_use_use opencl OPENCL)
+ $(cmake-utils_use_use openmp OPENMP)
+ $(cmake-utils_use !rawspeed DONT_USE_RAWSPEED)
+ $(cmake-utils_use_build slideshow SLIDESHOW)
+ -DCUSTOM_CFLAGS=ON
+ -DINSTALL_IOP_EXPERIMENTAL=ON
+ -DINSTALL_IOP_LEGACY=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc "${DISTDIR}"/${PN}-usermanual-1.1.1.pdf
+
+ if use pax_kernel && use opencl ; then
+ pax-mark Cm "${ED}"/usr/bin/${PN} || die
+ eqawarn "USE=pax_kernel is set meaning that ${PN} will be run"
+ eqawarn "under a PaX enabled kernel. To do so, the ${PN} binary"
+ eqawarn "must be modified and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/darktable/darktable-9999.ebuild b/media-gfx/darktable/darktable-9999.ebuild
index b5966c3a8b81..2a38d0fa3e5e 100644
--- a/media-gfx/darktable/darktable-9999.ebuild
+++ b/media-gfx/darktable/darktable-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/darktable/darktable-9999.ebuild,v 1.4 2012/12/19 19:15:46 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/darktable/darktable-9999.ebuild,v 1.5 2013/01/12 18:36:25 radhermit Exp $
EAPI="5"
-inherit cmake-utils toolchain-funcs gnome2-utils git-2 eutils
+inherit cmake-utils toolchain-funcs gnome2-utils fdo-mime git-2 pax-utils eutils
EGIT_REPO_URI="git://github.com/darktable-org/darktable.git"
@@ -15,7 +15,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="colord facebook flickr geo gnome-keyring gphoto2 graphicsmagick jpeg2k kde
-nls opencl openmp +rawspeed +slideshow"
+nls opencl openmp pax_kernel +rawspeed +slideshow"
RDEPEND="
dev-db/sqlite:3
@@ -91,14 +91,29 @@ src_configure() {
cmake-utils_src_configure
}
+src_install() {
+ cmake-utils_src_install
+
+ if use pax_kernel && use opencl ; then
+ pax-mark Cm "${ED}"/usr/bin/${PN} || die
+ eqawarn "USE=pax_kernel is set meaning that ${PN} will be run"
+ eqawarn "under a PaX enabled kernel. To do so, the ${PN} binary"
+ eqawarn "must be modified and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
pkg_preinst() {
gnome2_icon_savelist
}
pkg_postinst() {
gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
}
pkg_postrm() {
gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
}
diff --git a/media-gfx/darktable/metadata.xml b/media-gfx/darktable/metadata.xml
index e78c0b77cb72..6251beedd193 100644
--- a/media-gfx/darktable/metadata.xml
+++ b/media-gfx/darktable/metadata.xml
@@ -13,6 +13,7 @@
<flag name="flickr">Add support for uploading photos to flickr</flag>
<flag name="geo">Enable geotagging support</flag>
<flag name="opencl">Enable opencl support</flag>
+ <flag name="pax_kernel">Triggers paxmarking of main darktable binary</flag>
<flag name="rawspeed">Enable the rawspeed backend</flag>
<flag name="slideshow">Build the opengl slideshow viewer</flag>
</use>