summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-14 15:17:16 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-14 15:17:16 +0000
commit478210fdabc992245062c58752de60e9ef1c51e4 (patch)
treef6acf93bd9c1f4f93167f4876067bb8e14ce74bc /media-gfx
parentRemove old version. (diff)
downloadgentoo-2-478210fdabc992245062c58752de60e9ef1c51e4.tar.gz
gentoo-2-478210fdabc992245062c58752de60e9ef1c51e4.tar.bz2
gentoo-2-478210fdabc992245062c58752de60e9ef1c51e4.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/splashutils/ChangeLog9
-rw-r--r--media-gfx/splashutils/splashutils-1.5.2.1.ebuild11
-rw-r--r--media-gfx/splashutils/splashutils-1.5.3.4.ebuild14
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4-r1.ebuild14
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4.1.ebuild14
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4.ebuild14
6 files changed, 60 insertions, 16 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index df48f4695248..27947b837740 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.137 2008/04/27 19:49:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.138 2008/06/14 15:17:16 zmedico Exp $
+
+ 14 Jun 2008; Zac Medico <zmedico@gentoo.org> splashutils-1.5.2.1.ebuild,
+ splashutils-1.5.3.4.ebuild, splashutils-1.5.4.ebuild,
+ splashutils-1.5.4-r1.ebuild, splashutils-1.5.4.1.ebuild:
+ Bug #226505 - For compatibility with phase execution order in
+ >=portage-2.1.5, call has_version inside pkg_preinst instead of
+ pkg_postinst.
27 Apr 2008; Markus Meier <maekke@gentoo.org> splashutils-1.5.3.4.ebuild:
amd64 stable, bug #210588
diff --git a/media-gfx/splashutils/splashutils-1.5.2.1.ebuild b/media-gfx/splashutils/splashutils-1.5.2.1.ebuild
index e4ececcdc5ff..a0a4eb3603b7 100644
--- a/media-gfx/splashutils/splashutils-1.5.2.1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.2.1.ebuild,v 1.6 2007/12/21 15:09:30 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.2.1.ebuild,v 1.7 2008/06/14 15:17:16 zmedico Exp $
inherit eutils multilib toolchain-funcs
@@ -174,6 +174,11 @@ src_install() {
dosym /${LIB}/splash/bin/fbres /sbin/fbres
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-1.0"
+ previous_less_than_1_0=$?
+}
+
pkg_postinst() {
if has_version sys-fs/devfsd || ! has_version sys-fs/udev ; then
elog "This package has been designed with udev in mind. Other solutions, such as"
@@ -184,7 +189,7 @@ pkg_postinst() {
elog ""
fi
- if has_version '<media-gfx/splashutils-1.0' ; then
+ if [[ $previous_less_than_1_0 = 0 ]] ; then
elog "Since you are upgrading from a pre-1.0 version, please make sure that you"
elog "rebuild your initrds. You can use the splash_geninitramfs script to do that."
elog ""
diff --git a/media-gfx/splashutils/splashutils-1.5.3.4.ebuild b/media-gfx/splashutils/splashutils-1.5.3.4.ebuild
index 3fadec368d99..18a7d2642b52 100644
--- a/media-gfx/splashutils/splashutils-1.5.3.4.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.3.4.ebuild,v 1.5 2008/04/27 19:49:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.3.4.ebuild,v 1.6 2008/06/14 15:17:16 zmedico Exp $
EAPI="1"
@@ -147,6 +147,14 @@ src_install() {
dosym /${LIB}/splash/bin/fbres /sbin/fbres
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-1.0"
+ previous_less_than_1_0=$?
+
+ has_version "<${CATEGORY}/${PN}-1.5.3"
+ previous_less_than_1_5_3=$?
+}
+
pkg_postinst() {
if has_version sys-fs/devfsd || ! has_version sys-fs/udev ; then
elog "This package has been designed with udev in mind. Other solutions, such as"
@@ -157,13 +165,13 @@ pkg_postinst() {
elog ""
fi
- if has_version '<media-gfx/splashutils-1.0' ; then
+ if [[ $previous_less_than_1_0 = 0 ]] ; then
elog "Since you are upgrading from a pre-1.0 version, please make sure that you"
elog "rebuild your initrds. You can use the splash_geninitramfs script to do that."
elog ""
fi
- if has_version '<media-gfx/splashutils-1.5.3' && ! use fbcondecor ; then
+ if [[ $previous_less_than_1_5_3 = 0 ]] && ! use fbcondecor ; then
elog "Starting with splashutils-1.5.3, support for the fbcondecor kernel patch"
elog "is optional and dependent on the the 'fbcondecor' USE flag. If you wish"
elog "to use fbcondecor, run:"
diff --git a/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild b/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild
index 83e1e7736c26..b15fd1420526 100644
--- a/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild,v 1.4 2008/04/17 13:11:34 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild,v 1.5 2008/06/14 15:17:16 zmedico Exp $
EAPI="1"
@@ -158,6 +158,14 @@ src_install() {
dosym /${LIB}/splash/bin/fbres /sbin/fbres
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-1.0"
+ previous_less_than_1_0=$?
+
+ has_version "<${CATEGORY}/${PN}-1.5.3"
+ previous_less_than_1_5_3=$?
+}
+
pkg_postinst() {
if has_version sys-fs/devfsd || ! has_version sys-fs/udev ; then
elog "This package has been designed with udev in mind. Other solutions, such as"
@@ -168,13 +176,13 @@ pkg_postinst() {
elog ""
fi
- if has_version '<media-gfx/splashutils-1.0' ; then
+ if [[ $previous_less_than_1_0 = 0 ]] ; then
elog "Since you are upgrading from a pre-1.0 version, please make sure that you"
elog "rebuild your initrds. You can use the splash_geninitramfs script to do that."
elog ""
fi
- if has_version '<media-gfx/splashutils-1.5.3' && ! use fbcondecor ; then
+ if [[ $previous_less_than_1_5_3 = 0 ]] && ! use fbcondecor ; then
elog "Starting with splashutils-1.5.3, support for the fbcondecor kernel patch"
elog "is optional and dependent on the the 'fbcondecor' USE flag. If you wish"
elog "to use fbcondecor, run:"
diff --git a/media-gfx/splashutils/splashutils-1.5.4.1.ebuild b/media-gfx/splashutils/splashutils-1.5.4.1.ebuild
index ac4333332af4..5724ab91aec8 100644
--- a/media-gfx/splashutils/splashutils-1.5.4.1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.1.ebuild,v 1.1 2008/04/20 09:04:41 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.1.ebuild,v 1.2 2008/06/14 15:17:16 zmedico Exp $
EAPI="1"
@@ -148,6 +148,14 @@ src_install() {
dosym /${LIB}/splash/bin/fbres /sbin/fbres
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-1.0"
+ previous_less_than_1_0=$?
+
+ has_version "<${CATEGORY}/${PN}-1.5.3"
+ previous_less_than_1_5_3=$?
+}
+
pkg_postinst() {
if has_version sys-fs/devfsd || ! has_version sys-fs/udev ; then
elog "This package has been designed with udev in mind. Other solutions, such as"
@@ -158,13 +166,13 @@ pkg_postinst() {
elog ""
fi
- if has_version '<media-gfx/splashutils-1.0' ; then
+ if [[ $previous_less_than_1_0 = 0 ]] ; then
elog "Since you are upgrading from a pre-1.0 version, please make sure that you"
elog "rebuild your initrds. You can use the splash_geninitramfs script to do that."
elog ""
fi
- if has_version '<media-gfx/splashutils-1.5.3' && ! use fbcondecor ; then
+ if [[ $previous_less_than_1_5_3 = 0 ]] && ! use fbcondecor ; then
elog "Starting with splashutils-1.5.3, support for the fbcondecor kernel patch"
elog "is optional and dependent on the the 'fbcondecor' USE flag. If you wish"
elog "to use fbcondecor, run:"
diff --git a/media-gfx/splashutils/splashutils-1.5.4.ebuild b/media-gfx/splashutils/splashutils-1.5.4.ebuild
index 991497bb6f63..299bf94009bc 100644
--- a/media-gfx/splashutils/splashutils-1.5.4.ebuild
+++ b/media-gfx/splashutils/splashutils-1.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.ebuild,v 1.1 2008/02/25 23:03:56 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.ebuild,v 1.2 2008/06/14 15:17:16 zmedico Exp $
EAPI="1"
@@ -147,6 +147,14 @@ src_install() {
dosym /${LIB}/splash/bin/fbres /sbin/fbres
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-1.0"
+ previous_less_than_1_0=$?
+
+ has_version "<${CATEGORY}/${PN}-1.5.3"
+ previous_less_than_1_5_3=$?
+}
+
pkg_postinst() {
if has_version sys-fs/devfsd || ! has_version sys-fs/udev ; then
elog "This package has been designed with udev in mind. Other solutions, such as"
@@ -157,13 +165,13 @@ pkg_postinst() {
elog ""
fi
- if has_version '<media-gfx/splashutils-1.0' ; then
+ if [[ $previous_less_than_1_0 = 0 ]] ; then
elog "Since you are upgrading from a pre-1.0 version, please make sure that you"
elog "rebuild your initrds. You can use the splash_geninitramfs script to do that."
elog ""
fi
- if has_version '<media-gfx/splashutils-1.5.3' && ! use fbcondecor ; then
+ if [[ $previous_less_than_1_5_3 = 0 ]] && ! use fbcondecor ; then
elog "Starting with splashutils-1.5.3, support for the fbcondecor kernel patch"
elog "is optional and dependent on the the 'fbcondecor' USE flag. If you wish"
elog "to use fbcondecor, run:"