summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-11-05 08:40:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-11-05 08:40:16 +0000
commit59e1edac5fa9ab0a670879b98ce5ef3b42718a94 (patch)
tree4f623bd76cce806cbcd234a134f2a0f479d0690d /media-gfx
parentBump to 3.2.1.1 from the gnome overlay. Notable changes: new gnome-shell base... (diff)
downloadgentoo-2-59e1edac5fa9ab0a670879b98ce5ef3b42718a94.tar.gz
gentoo-2-59e1edac5fa9ab0a670879b98ce5ef3b42718a94.tar.bz2
gentoo-2-59e1edac5fa9ab0a670879b98ce5ef3b42718a94.zip
Fix missing USE="threads" depend for x11-libs/fltk wrt #297699. Fix building with recent boost and gcc by using Debian patchset wrt bugs #362625 and #362939. Thanks to Diego Elio Pettenò and Sebastian Luther for reporting these issues.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/aqsis/ChangeLog8
-rw-r--r--media-gfx/aqsis/aqsis-1.6.0.ebuild15
2 files changed, 18 insertions, 5 deletions
diff --git a/media-gfx/aqsis/ChangeLog b/media-gfx/aqsis/ChangeLog
index 930075c8a7ab..cc9e3c2e9a17 100644
--- a/media-gfx/aqsis/ChangeLog
+++ b/media-gfx/aqsis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/aqsis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/aqsis/ChangeLog,v 1.22 2011/03/22 09:48:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/aqsis/ChangeLog,v 1.23 2011/11/05 08:40:16 ssuominen Exp $
+
+ 05 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> aqsis-1.6.0.ebuild:
+ Fix missing USE="threads" depend for x11-libs/fltk wrt #297699. Fix building
+ with recent boost and gcc by using Debian patchset wrt bugs #362625 and
+ #362939. Thanks to Diego Elio Pettenò and Sebastian Luther for reporting
+ these issues.
22 Mar 2011; Justin Lecher <jlec@gentoo.org> aqsis-1.6.0.ebuild:
Restrict fltk version being able to return includedir
diff --git a/media-gfx/aqsis/aqsis-1.6.0.ebuild b/media-gfx/aqsis/aqsis-1.6.0.ebuild
index 91204dd94365..00d61686f509 100644
--- a/media-gfx/aqsis/aqsis-1.6.0.ebuild
+++ b/media-gfx/aqsis/aqsis-1.6.0.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/aqsis/aqsis-1.6.0.ebuild,v 1.3 2011/03/22 09:48:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/aqsis/aqsis-1.6.0.ebuild,v 1.4 2011/11/05 08:40:16 ssuominen Exp $
-EAPI="1"
+EAPI=2
+
+patch_level=8
inherit versionator multilib eutils cmake-utils
@@ -17,7 +19,8 @@ if [[ "${P}" == *_p* ]] ; then
SRC_URI="http://download.aqsis.org/builds/testing/source/tar/${MY_P}.tar.gz"
S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
else
- SRC_URI="mirror://sourceforge/aqsis/${P}.tar.gz"
+ SRC_URI="mirror://sourceforge/aqsis/${P}.tar.gz
+ mirror://debian/pool/main/a/${PN}/${PN}_${PV}-${patch_level}.debian.tar.gz"
fi
LICENSE="GPL-2"
@@ -29,7 +32,7 @@ RDEPEND="
>=dev-libs/boost-1.34.0
>=media-libs/tiff-3.7.1
>=sys-libs/zlib-1.1.4
- fltk? ( >=x11-libs/fltk-1.1.10-r2:1 )
+ fltk? ( >=x11-libs/fltk-1.1.10-r2:1[threads] )
openexr? ( media-libs/openexr )"
DEPEND="
@@ -39,6 +42,10 @@ DEPEND="
>=sys-devel/bison-1.35
>=sys-devel/flex-2.5.4"
+src_prepare() {
+ epatch "${WORKDIR}"/debian/patches/*ftbfs*
+}
+
src_compile() {
if use fltk ; then
# hack to get fltk library/include paths