summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2010-10-26 20:06:05 +0000
committerMarkus Meier <maekke@gentoo.org>2010-10-26 20:06:05 +0000
commit62485a233f2924b1480b7a607d7507dfd3f967d2 (patch)
treee987975fac482c8a460c60ed4de9caa4f69ffc51 /media-gfx
parentInitial import (diff)
downloadgentoo-2-62485a233f2924b1480b7a607d7507dfd3f967d2.tar.gz
gentoo-2-62485a233f2924b1480b7a607d7507dfd3f967d2.tar.bz2
gentoo-2-62485a233f2924b1480b7a607d7507dfd3f967d2.zip
fix automagic dep on aspell, bug #327891
(Portage version: 2.2.0_alpha1/cvs/Linux i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/inkscape/ChangeLog6
-rw-r--r--media-gfx/inkscape/files/inkscape-0.48.0-spell.patch45
-rw-r--r--media-gfx/inkscape/inkscape-0.48.0.ebuild12
3 files changed, 60 insertions, 3 deletions
diff --git a/media-gfx/inkscape/ChangeLog b/media-gfx/inkscape/ChangeLog
index 209c29323903..ab52e0566504 100644
--- a/media-gfx/inkscape/ChangeLog
+++ b/media-gfx/inkscape/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/inkscape
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.144 2010/09/05 13:54:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/ChangeLog,v 1.145 2010/10/26 20:06:05 maekke Exp $
+
+ 26 Oct 2010; Markus Meier <maekke@gentoo.org> inkscape-0.48.0.ebuild,
+ +files/inkscape-0.48.0-spell.patch:
+ fix automagic dep on aspell, bug #327891
05 Sep 2010; Markus Meier <maekke@gentoo.org> inkscape-0.48.0.ebuild:
raise gtkmm dep to >=dev-cpp/gtkmm-2.18 by aisomur in bug #335423
diff --git a/media-gfx/inkscape/files/inkscape-0.48.0-spell.patch b/media-gfx/inkscape/files/inkscape-0.48.0-spell.patch
new file mode 100644
index 000000000000..946222276b72
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.48.0-spell.patch
@@ -0,0 +1,45 @@
+--- inkscape-0.48.0/configure.ac.orig 2010-10-26 21:22:06.000000000 +0200
++++ inkscape-0.48.0/configure.ac 2010-10-26 21:33:39.000000000 +0200
+@@ -433,10 +433,15 @@
+ fi
+ AM_CONDITIONAL(INKJAR, test "$with_ij" = "yes")
+
++AC_ARG_WITH([gtkspell],
++ AS_HELP_STRING([--without-gtkspell], [disable gtk spelling widget]),[with_gtkspell=$withval], [with_gtkspell=yes])
++
+ ink_spell_pkg=
+-if pkg-config --exists gtkspell-2.0; then
+- ink_spell_pkg=gtkspell-2.0
+- AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++if test "x$with_gtkspell" = "xyes"; then
++ if pkg-config --exists gtkspell-2.0; then
++ ink_spell_pkg=gtkspell-2.0
++ AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ fi
+ fi
+
+ dnl ******************************
+@@ -758,12 +763,17 @@
+ dnl **************************
+ dnl Check for aspell
+ dnl ******************************
+-AC_CHECK_LIB(aspell, new_aspell_config, [AC_CHECK_HEADER(aspell.h, aspell_ok=yes, aspell_ok=no)], aspell_ok=no, -lz -lm)
+-if test "x$aspell_ok" = "xyes"; then
+- AC_DEFINE(HAVE_ASPELL, 1, [Use aspell for built-in spellchecker])
+- INKSCAPE_LIBS="$INKSCAPE_LIBS -laspell"
+-else
+- AC_MSG_CHECKING([Aspell not found, spell checker will be disabled])
++AC_ARG_WITH([aspell],
++ AS_HELP_STRING([--without-aspell], [disable aspell spell checker]),[with_aspell=$withval], [with_aspell=yes])
++
++if test "x$with_aspell" = "xyes"; then
++ AC_CHECK_LIB(aspell, new_aspell_config, [AC_CHECK_HEADER(aspell.h, aspell_ok=yes, aspell_ok=no)], aspell_ok=no, -lz -lm)
++ if test "x$aspell_ok" = "xyes"; then
++ AC_DEFINE(HAVE_ASPELL, 1, [Use aspell for built-in spellchecker])
++ INKSCAPE_LIBS="$INKSCAPE_LIBS -laspell"
++ else
++ AC_MSG_CHECKING([Aspell not found, spell checker will be disabled])
++ fi
+ fi
+
+ dnl Check for bind_textdomain_codeset, including -lintl if GLib brings it in.
diff --git a/media-gfx/inkscape/inkscape-0.48.0.ebuild b/media-gfx/inkscape/inkscape-0.48.0.ebuild
index 805d6e8b7622..ac9ddba1c5e9 100644
--- a/media-gfx/inkscape/inkscape-0.48.0.ebuild
+++ b/media-gfx/inkscape/inkscape-0.48.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.48.0.ebuild,v 1.2 2010/09/05 13:54:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.48.0.ebuild,v 1.3 2010/10/26 20:06:05 maekke Exp $
EAPI=2
-inherit eutils flag-o-matic gnome2
+inherit eutils flag-o-matic autotools gnome2
MY_P="${P/_/}"
S="${WORKDIR}/${MY_P}"
@@ -73,9 +73,17 @@ pkg_setup() {
G2CONF="${G2CONF} $(use_with inkjar)"
G2CONF="${G2CONF} $(use_enable lcms)"
G2CONF="${G2CONF} $(use_enable nls)"
+ G2CONF="${G2CONF} $(use_with spell aspell)"
+ G2CONF="${G2CONF} $(use_with spell gtkspell)"
DOCS="AUTHORS ChangeLog NEWS README*"
}
+src_prepare() {
+ gnome2_src_prepare
+ epatch "${FILESDIR}"/${P}-spell.patch
+ eautoreconf
+}
+
src_configure() {
# aliasing unsafe wrt #310393
append-flags -fno-strict-aliasing