summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLina Pezzella <j4rg0n@gentoo.org>2005-05-28 03:54:48 +0000
committerLina Pezzella <j4rg0n@gentoo.org>2005-05-28 03:54:48 +0000
commit69261361a28eabf44b915106ddc2da2f4be2cfc3 (patch)
tree5f43aa7f4001729610fa73e8492a8d0636eed889 /media-gfx
parent(#90672) Add die for combo of USE="sdk -dlloader," pending a fix. (diff)
downloadgentoo-2-69261361a28eabf44b915106ddc2da2f4be2cfc3.tar.gz
gentoo-2-69261361a28eabf44b915106ddc2da2f4be2cfc3.tar.bz2
gentoo-2-69261361a28eabf44b915106ddc2da2f4be2cfc3.zip
Stable ppc-macos
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xv/ChangeLog6
-rw-r--r--media-gfx/xv/files/xv-3.10a-r11-xv-osx.patch29
-rw-r--r--media-gfx/xv/xv-3.10a-r11.ebuild15
3 files changed, 46 insertions, 4 deletions
diff --git a/media-gfx/xv/ChangeLog b/media-gfx/xv/ChangeLog
index 2596d223c490..f3369d5ad52f 100644
--- a/media-gfx/xv/ChangeLog
+++ b/media-gfx/xv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/xv
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/ChangeLog,v 1.61 2005/05/28 03:01:30 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/ChangeLog,v 1.62 2005/05/28 03:54:48 j4rg0n Exp $
+
+ 27 May 2005; Lina Pezzella <j4rg0n@gentoo.org>
+ +files/xv-3.10a-r11-xv-osx.patch, xv-3.10a-r11.ebuild:
+ Fix for Bug 88742.
27 May 2005; Lina Pezzella <j4rg0n@gentoo.org> xv-3.10a-r10.ebuild:
Fixed Bug with -ffast-math flag on OSX
diff --git a/media-gfx/xv/files/xv-3.10a-r11-xv-osx.patch b/media-gfx/xv/files/xv-3.10a-r11-xv-osx.patch
new file mode 100644
index 000000000000..e0c3f92ea51b
--- /dev/null
+++ b/media-gfx/xv/files/xv-3.10a-r11-xv-osx.patch
@@ -0,0 +1,29 @@
+--- xv.h.orig 2005-05-27 23:35:19.000000000 -0400
++++ xv.h 2005-05-27 23:37:18.000000000 -0400
+@@ -137,7 +137,7 @@
+ #ifndef VMS
+ # include <errno.h>
+ extern int errno; /* SHOULD be in errno.h, but often isn't */
+-# if !defined(__NetBSD__) && !(defined(__linux__) && defined(__USE_BSD))
++# if !defined(__NetBSD__) && !(defined(__linux__) && defined(__USE_BSD)) && !defined(__APPLE__)
+ extern char *sys_errlist[]; /* this too... */
+ # endif
+ #endif
+@@ -147,7 +147,7 @@
+ #ifdef VMS
+ # define ERRSTR(x) strerror(x, vaxc$errno)
+ #else
+-# if defined(__BEOS__) || defined(__linux__) /* or all modern/glibc systems? */
++# if defined(__BEOS__) || defined(__linux__) || defined(__APPLE__) /* or all modern/glibc systems? */
+ # define ERRSTR(x) strerror(x)
+ # else
+ # define ERRSTR(x) sys_errlist[x]
+@@ -191,6 +191,8 @@
+
+ # if defined(hp300) || defined(hp800) || defined(NeXT)
+ # include <sys/malloc.h> /* it's in 'sys' on HPs and NeXT */
++# elif defined(__APPLE__)
++# include <malloc/malloc.h>
+ # else
+ # include <malloc.h>
+ # endif
diff --git a/media-gfx/xv/xv-3.10a-r11.ebuild b/media-gfx/xv/xv-3.10a-r11.ebuild
index fae5baeef1e0..5ac1a7d5afd7 100644
--- a/media-gfx/xv/xv-3.10a-r11.ebuild
+++ b/media-gfx/xv/xv-3.10a-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/xv-3.10a-r11.ebuild,v 1.10 2005/04/19 00:15:11 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xv/xv-3.10a-r11.ebuild,v 1.11 2005/05/28 03:54:48 j4rg0n Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/png-mng/${P}-jumbo-patches-${JUMBOV}.tar.bz2 ftp:/
LICENSE="xv"
SLOT="0"
-KEYWORDS="amd64 x86 sparc ppc ppc64 alpha ia64"
+KEYWORDS="amd64 x86 sparc ppc ppc64 alpha ia64 ppc-macos"
IUSE="jpeg tiff png"
DEPEND="virtual/x11
@@ -31,6 +31,11 @@ src_unpack() {
epatch ${FILESDIR}/${P}-bmpfix.patch.bz2 || die
epatch ${FILESDIR}/${P}-yaos.dif.bz2 || die
+ if use ppc-macos; then
+ epatch ${FILESDIR}/${PF}-xv-osx.patch
+ epatch ${FILESDIR}/${P}-vdcomp-osx.patch
+ fi
+
sed -i -e 's/\(^JPEG.*\)/#\1/g' \
-e 's/\(^PNG.*\)/#\1/g' \
-e 's/\(^TIFF.*\)/#\1/g' \
@@ -42,7 +47,11 @@ src_unpack() {
}
src_compile() {
- append-flags -DUSE_GETCWD -DLINUX -DUSLEEP
+ if use ppc-macos; then
+ append-flags -DUSE_GETCWD -DUSLEEP
+ else
+ append-flags -DUSE_GETCWD -DLINUX -DUSLEEP
+ fi
einfo "Enabling Optional Features..."
if use jpeg; then