summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-05 03:08:54 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-05 03:08:54 +0000
commit8a04403ca3d121a9c2da513181c237486791f221 (patch)
tree5705719ffc7358f9b08495a1eaed2b3af88d891c /media-gfx
parentAdded ebuild for rdist (diff)
downloadgentoo-2-8a04403ca3d121a9c2da513181c237486791f221.tar.gz
gentoo-2-8a04403ca3d121a9c2da513181c237486791f221.tar.bz2
gentoo-2-8a04403ca3d121a9c2da513181c237486791f221.zip
Fixes to ebuild... In testing.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/povray/ChangeLog7
-rw-r--r--media-gfx/povray/povray-3.50a.ebuild21
2 files changed, 22 insertions, 6 deletions
diff --git a/media-gfx/povray/ChangeLog b/media-gfx/povray/ChangeLog
index 908c9a8b0e90..0e051ffc1efa 100644
--- a/media-gfx/povray/ChangeLog
+++ b/media-gfx/povray/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.8 2002/08/02 19:03:10 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.9 2002/08/05 03:08:54 rphillips Exp $
*povray-3.5a (2 Aug 2002)
+ 4 Aug 2002; Ryan Phillips <rphillips@gentoo.org> povray-3.5a.ebuild :
+
+ Compiles and runs now on my system. Needs testing for PPC, et al platforms
+ and on the ICC compiler.
+
2 Aug 2002; Ryan Phillips <rphillips@gentoo.org> povray-3.5a.ebuild :
Preliminary ebuild for povray 3.5. The application errors out with an
diff --git a/media-gfx/povray/povray-3.50a.ebuild b/media-gfx/povray/povray-3.50a.ebuild
index ca2ddef187d2..3a675a96638a 100644
--- a/media-gfx/povray/povray-3.50a.ebuild
+++ b/media-gfx/povray/povray-3.50a.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.50a.ebuild,v 1.1 2002/08/02 19:03:10 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.50a.ebuild,v 1.2 2002/08/05 03:08:54 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="POV Ray- The Persistance of Vision Ray Tracer"
SRC_URI="ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz"
-# ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_d.tgz"
HOMEPAGE="http://www.povray.org/"
SLOT="0"
@@ -22,10 +21,10 @@ DEPEND="media-libs/libpng
src_compile() {
econf || die
-
+
# fix system default povray.ini to point to install directory
cp povray.ini povray.ini.orig
- sed -e "s:\(/usr/\)local/\(share\):\1\2:" povray.ini.orig > povray.ini
+ sed -e "s:\(/usr/\)local/\(lib\):\1share:" povray.ini.orig > povray.ini
cd src
cp Makefile makefile.orig
@@ -94,5 +93,17 @@ src_compile() {
src_install ()
{
emake DESTDIR=${D} install || die
- ln -s /usr/share/povray-3.5/povray.ini /etc/povray.ini
+
+ mkdir -p ${D}/etc
+ dosym /usr/share/povray-3.5/povray.ini /etc/povray.ini
+}
+
+pkg_postinst ()
+{
+ einfo "Installing configuration files"
+ einfo "*Warning* I/O Security disabled by default"
+ einfo " Check /etc/povray.conf to enable"
+
+ echo -e "[File I/O Security]\nnone" > /etc/povray.conf
+
}