summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-29 09:45:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-29 09:45:47 +0000
commita9b83edcacdc80b0b7c85de84a0623a524fb9519 (patch)
treedeb9deae367d6561e7c9e2b07c2f9babc8cf2a39 /media-libs/allegro
parentmake it stable baby (diff)
downloadgentoo-2-a9b83edcacdc80b0b7c85de84a0623a524fb9519.tar.gz
gentoo-2-a9b83edcacdc80b0b7c85de84a0623a524fb9519.tar.bz2
gentoo-2-a9b83edcacdc80b0b7c85de84a0623a524fb9519.zip
take filter-flags out of global scope
Diffstat (limited to 'media-libs/allegro')
-rw-r--r--media-libs/allegro/allegro-4.0.3.ebuild4
-rw-r--r--media-libs/allegro/allegro-4.1.11.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/allegro/allegro-4.0.3.ebuild b/media-libs/allegro/allegro-4.0.3.ebuild
index 1af09c37a775..dc0f1d357ce5 100644
--- a/media-libs/allegro/allegro-4.0.3.ebuild
+++ b/media-libs/allegro/allegro-4.0.3.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.5 2003/09/24 21:51:32 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.3.ebuild,v 1.6 2004/02/29 09:45:47 vapier Exp $
inherit flag-o-matic
-filter-flags -fPIC
DESCRIPTION="cross-platform multimedia library"
SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
@@ -28,6 +27,7 @@ src_unpack() {
}
src_compile() {
+ filter-flags -fPIC
econf \
--enable-linux \
--enable-vga \
diff --git a/media-libs/allegro/allegro-4.1.11.ebuild b/media-libs/allegro/allegro-4.1.11.ebuild
index 4fd8b9a3dd8e..7976d908da89 100644
--- a/media-libs/allegro/allegro-4.1.11.ebuild
+++ b/media-libs/allegro/allegro-4.1.11.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.1.11.ebuild,v 1.3 2003/09/24 21:51:32 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.1.11.ebuild,v 1.4 2004/02/29 09:45:47 vapier Exp $
inherit flag-o-matic
-filter-flags -fPIC
DESCRIPTION="cross-platform multimedia library"
SRC_URI="mirror://sourceforge/alleg/${P}.tar.gz"
@@ -31,6 +30,7 @@ src_unpack() {
}
src_compile() {
+ filter-flags -fPIC
econf \
--enable-linux \
--enable-vga \