summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-09-01 17:48:15 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-09-01 17:48:15 +0000
commit77f89b724cd03107c42adf7cab636ff118f54315 (patch)
treed476852cd47d2297e623033c66b3519aa99dab67 /media-libs/alsa-lib
parentVersion bumped. Text and translation updates. (diff)
downloadgentoo-2-77f89b724cd03107c42adf7cab636ff118f54315.tar.gz
gentoo-2-77f89b724cd03107c42adf7cab636ff118f54315.tar.bz2
gentoo-2-77f89b724cd03107c42adf7cab636ff118f54315.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog8
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.17a.ebuild99
2 files changed, 106 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 39c52ef9e416..59283bfb8280 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.262 2008/08/03 17:12:33 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.263 2008/09/01 17:48:15 betelgeuse Exp $
+
+*alsa-lib-1.0.17a (01 Sep 2008)
+
+ 01 Sep 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +alsa-lib-1.0.17a.ebuild:
+ Version bump.
*alsa-lib-1.0.17-r1 (03 Aug 2008)
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.17a.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.17a.ebuild
new file mode 100644
index 000000000000..0fa1fa45ff95
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.17a.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.17a.ebuild,v 1.1 2008/09/01 17:48:15 betelgeuse Exp $
+
+inherit eutils libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug alisp midi python"
+
+RDEPEND="python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ >=media-sound/alsa-headers-1.0.17
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file
+null empty share meter mmap_emul hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+pkg_setup() {
+ if [ -z "${ALSA_PCM_PLUGINS}" ] ; then
+ ewarn "You haven't selected _any_ PCM plugins. Either you set it to something like the default"
+ ewarn "(which is being set in the profile UNLESS you unset them) or alsa based applications"
+ ewarn "are going to *misbehave* !"
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+ use elibc_uclibc && myconf="--without-versioned"
+
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable python) \
+ $(use_enable midi rawmidi) \
+ $(use_enable midi seq) \
+ $(use_enable midi aload) \
+ --with-pcm-plugins="${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO || die
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try in-kernel ALSA drivers instead of the alsa-drivers ebuild."
+ elog "If alsa-drivers works for you where a recent kernel does not, we want "
+ elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
+ elog "However, if you notice no sound output or instability, please try to "
+ elog "upgrade your kernel to a newer version first."
+}