summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-09-09 08:32:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-09-09 08:32:27 +0000
commit83c3ad69148eb8996c1d429a128ce2e15490892c (patch)
tree36fdc776889b345f1cea03c7d7cf18d1bdf40bc2 /media-libs/alsa-lib
parentUse sed instead of patch broken on whitespace, fixing bug 434188. Make sure t... (diff)
downloadgentoo-2-83c3ad69148eb8996c1d429a128ce2e15490892c.tar.gz
gentoo-2-83c3ad69148eb8996c1d429a128ce2e15490892c.tar.bz2
gentoo-2-83c3ad69148eb8996c1d429a128ce2e15490892c.zip
Punt base.eclass from inherit because it was never used and PATCHES was ignored because of custom src_prepare(). Remove obsolete pkg_postinst() message wrt #434370 by William Throwe.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog7
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.26.ebuild35
2 files changed, 18 insertions, 24 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 498b154a529b..445a44b90686 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.333 2012/09/07 12:57:19 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.334 2012/09/09 08:32:27 ssuominen Exp $
+
+ 09 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> alsa-lib-1.0.26.ebuild:
+ Punt base.eclass from inherit because it was never used and PATCHES was
+ ignored because of custom src_prepare(). Remove obsolete pkg_postinst()
+ message wrt #434370 by William Throwe.
*alsa-lib-1.0.26 (07 Sep 2012)
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild
index 7f1050706b18..04d930172003 100644
--- a/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild
@@ -1,37 +1,35 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild,v 1.1 2012/09/07 12:57:19 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild,v 1.2 2012/09/09 08:32:27 ssuominen Exp $
EAPI=4
-PYTHON_DEPEND="python? 2"
+PYTHON_DEPEND="python? 2:2.6"
-inherit autotools base python multilib
-
-MY_P=${P/_rc/rc}
-S=${WORKDIR}/${MY_P}
+inherit autotools eutils multilib python
DESCRIPTION="Advanced Linux Sound Architecture Library"
HOMEPAGE="http://www.alsa-project.org/"
-SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc debug alisp python"
+RDEPEND=""
DEPEND=">=media-sound/alsa-headers-1.0.25
doc? ( >=app-doc/doxygen-1.2.6 )"
-RDEPEND=""
-PATCHES=( "${FILESDIR}/${PV}-extraneous-cflags.diff" )
pkg_setup() {
if use python; then
python_set_active_version 2
+ python_pkg_setup
fi
}
src_prepare() {
+ epatch "${FILESDIR}"/1.0.25-extraneous-cflags.diff
eautoreconf
epunt_cxx
}
@@ -49,34 +47,25 @@ src_configure() {
$(use_with debug) \
$(use_enable alisp) \
$(use_enable python) \
- --disable-dependency-tracking \
${myconf}
}
src_compile() {
- emake || die
+ emake
if use doc; then
- emake doc || die "failed to generate docs"
+ emake doc
fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
xargs -0 sed -i -e "s:${S}::"
fi
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
- find "${ED}" -name '*.la' -exec rm -f {} +
+ prune_libtool_files --all
find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
- dodoc ChangeLog TODO || die
+ dodoc ChangeLog TODO
use doc && dohtml -r doc/doxygen/html/*
}
-
-pkg_postinst() {
- elog "Please try in-kernel ALSA drivers instead of the alsa-driver ebuild."
- elog "If alsa-driver works for you where a *recent* kernel does not, we want "
- elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
- elog "However, if you notice no sound output or instability, please try to "
- elog "upgrade your kernel to a newer version first."
-}