summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-23 19:01:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-23 19:01:17 +0000
commitd504899ce7b9004e86804afadb3ca94a7f8c4fb8 (patch)
treefe02c7b2f16cc4bae7a2e3b4cbcdedb956a5f5f7 /media-libs/ctl
parentVersion bump dev-python/sphinx to 1.0.3. (diff)
downloadgentoo-2-d504899ce7b9004e86804afadb3ca94a7f8c4fb8.tar.gz
gentoo-2-d504899ce7b9004e86804afadb3ca94a7f8c4fb8.tar.bz2
gentoo-2-d504899ce7b9004e86804afadb3ca94a7f8c4fb8.zip
Punt .la files. USE="static-libs".
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/ctl')
-rw-r--r--media-libs/ctl/ChangeLog7
-rw-r--r--media-libs/ctl/ctl-1.4.1.ebuild28
2 files changed, 22 insertions, 13 deletions
diff --git a/media-libs/ctl/ChangeLog b/media-libs/ctl/ChangeLog
index a35f6fd43cf4..fb69e1046cfd 100644
--- a/media-libs/ctl/ChangeLog
+++ b/media-libs/ctl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/ctl
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ChangeLog,v 1.16 2008/08/08 22:05:35 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ChangeLog,v 1.17 2010/08/23 19:01:17 ssuominen Exp $
+
+ 23 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> ctl-1.4.1.ebuild:
+ Punt .la files. USE="static-libs".
08 Aug 2008; Alexis Ballier <aballier@gentoo.org> -ctl-1.4.0.ebuild:
remove old
diff --git a/media-libs/ctl/ctl-1.4.1.ebuild b/media-libs/ctl/ctl-1.4.1.ebuild
index 031d6d8abd39..3f5f9c139aac 100644
--- a/media-libs/ctl/ctl-1.4.1.ebuild
+++ b/media-libs/ctl/ctl-1.4.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ctl-1.4.1.ebuild,v 1.10 2008/08/08 22:04:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ctl-1.4.1.ebuild,v 1.11 2010/08/23 19:01:17 ssuominen Exp $
-inherit base
+EAPI=2
+inherit eutils libtool
DESCRIPTION="AMPAS' Color Transformation Language"
HOMEPAGE="http://sourceforge.net/projects/ampasctl"
@@ -11,21 +12,26 @@ SRC_URI="mirror://sourceforge/ampasctl/${P}.tar.gz"
LICENSE="AMPAS"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc"
+IUSE=""
RDEPEND="media-libs/ilmbase"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install || die
dodoc AUTHORS ChangeLog NEWS README
- if use doc ; then
- insinto "/usr/share/doc/${PF}"
- doins doc/*.pdf
- fi
- rm -frv "${D}usr/share/doc/CTL"*
+ find "${D}" -name '*.la' -exec rm -f '{}' +
}