summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-04-04 23:00:38 +0000
committerOlivier Crête <tester@gentoo.org>2008-04-04 23:00:38 +0000
commitb3d3ca7e45ab95ea354b83c07d2b554c8c92ae8c (patch)
tree4731e98dd74fc05ef1ccd9d76d7675bf0cba32d8 /media-libs/farsight
parent- stable for bug 214593 (diff)
downloadgentoo-2-b3d3ca7e45ab95ea354b83c07d2b554c8c92ae8c.tar.gz
gentoo-2-b3d3ca7e45ab95ea354b83c07d2b554c8c92ae8c.tar.bz2
gentoo-2-b3d3ca7e45ab95ea354b83c07d2b554c8c92ae8c.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-libs/farsight')
-rw-r--r--media-libs/farsight/ChangeLog7
-rw-r--r--media-libs/farsight/farsight-0.1.26.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/media-libs/farsight/ChangeLog b/media-libs/farsight/ChangeLog
index 0c4e13420850..0cbc37d50ab8 100644
--- a/media-libs/farsight/ChangeLog
+++ b/media-libs/farsight/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/farsight
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/farsight/ChangeLog,v 1.16 2008/03/10 22:55:58 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/farsight/ChangeLog,v 1.17 2008/04/04 23:00:38 tester Exp $
+
+*farsight-0.1.26 (04 Apr 2008)
+
+ 04 Apr 2008; Olivier Crête <tester@gentoo.org> +farsight-0.1.26.ebuild:
+ Version bump
10 Mar 2008; Olivier Crête <tester@gentoo.org> farsight-0.1.24.ebuild,
farsight-0.1.25.ebuild:
diff --git a/media-libs/farsight/farsight-0.1.26.ebuild b/media-libs/farsight/farsight-0.1.26.ebuild
new file mode 100644
index 000000000000..fc29fc374e05
--- /dev/null
+++ b/media-libs/farsight/farsight-0.1.26.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/farsight/farsight-0.1.26.ebuild,v 1.1 2008/04/04 23:00:38 tester Exp $
+
+DESCRIPTION="FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE="http://farsight.freedesktop.org/"
+SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
+#EDARCS_REPO_URI="http://projects.collabora.co.uk/darcs/farsight/farsight"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="jingle doc test"
+# msn yahoo
+SLOT="0"
+
+RDEPEND="=media-libs/gstreamer-0.10*
+ >=media-libs/gstreamer-0.10.13
+ =media-plugins/gst-plugins-farsight-0.12.6
+ >=dev-libs/glib-2.6
+ !<net-voip/telepathy-stream-engine-0.5.0
+ dev-libs/libxml2
+ doc? ( >=dev-util/gtk-doc-1.5 )
+ jingle? ( >=net-libs/libjingle-0.3.11 )
+ test? ( >=dev-libs/check-0.9.4 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ # I'm disabling clinkc because it sucks, isnt in portage
+ # and I couldnt care less for upnp
+ econf --enable-rtp \
+ --disable-clinkc \
+ $(use_enable doc) \
+ $(use_enable jingle jingle-p2p) || die "econf failed"
+ # Not yet ported to the new version
+ # $(use_enable msn msnwebcam) \
+ # $(use_enable msn msnavconf) \
+ # $(use_enable yahoo yahoowebcam) \
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS README TODO
+}