summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-15 18:59:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-15 18:59:19 +0000
commit399edf61274f96fa20de43a950e320ddc1231f37 (patch)
tree776677c6788f190df671d37e59e87cfeee0b56e6 /media-libs/flac
parentold (diff)
downloadgentoo-2-399edf61274f96fa20de43a950e320ddc1231f37.tar.gz
gentoo-2-399edf61274f96fa20de43a950e320ddc1231f37.tar.bz2
gentoo-2-399edf61274f96fa20de43a950e320ddc1231f37.zip
touchups
Diffstat (limited to 'media-libs/flac')
-rw-r--r--media-libs/flac/flac-1.1.0-r1.ebuild20
-rw-r--r--media-libs/flac/flac-1.1.0.ebuild11
2 files changed, 13 insertions, 18 deletions
diff --git a/media-libs/flac/flac-1.1.0-r1.ebuild b/media-libs/flac/flac-1.1.0-r1.ebuild
index 9ac3f8c68c1b..078c36d540f7 100644
--- a/media-libs/flac/flac-1.1.0-r1.ebuild
+++ b/media-libs/flac/flac-1.1.0-r1.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0-r1.ebuild,v 1.2 2004/04/08 02:30:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0-r1.ebuild,v 1.3 2004/04/15 18:59:19 vapier Exp $
inherit libtool
DESCRIPTION="free lossless audio encoder which includes an XMMS plugin"
-SRC_URI="mirror://sourceforge/flac/${P}.tar.gz"
-RESTRICT="nomirror"
HOMEPAGE="http://flac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/flac/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2 LGPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
IUSE="sse xmms X"
RDEPEND=">=media-libs/libogg-1.0_rc2
media-libs/id3lib
X? ( xmms? ( media-sound/xmms ) )"
-
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )
sys-apps/gawk"
@@ -38,15 +36,13 @@ src_unpack() {
}
src_compile() {
- local myconf="--with-pic"
- use sse && myconf="--enable-sse"
-
- econf ${myconf} || die
- cp Makefile Makefile.orig
+ econf \
+ --with-pic \
+ `use_enable sse` \
+ || die
#the man page ebuild requires docbook2man... yick!
- sed -e 's:include man:include:g' Makefile.orig > Makefile
-
+ sed -i -e 's:include man:include:g' Makefile
#emake seems to mess up the building of the xmms input plugin
make || die
}
diff --git a/media-libs/flac/flac-1.1.0.ebuild b/media-libs/flac/flac-1.1.0.ebuild
index 0161db1340a0..3202007afa02 100644
--- a/media-libs/flac/flac-1.1.0.ebuild
+++ b/media-libs/flac/flac-1.1.0.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0.ebuild,v 1.18 2004/03/16 01:15:37 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0.ebuild,v 1.19 2004/04/15 18:59:19 vapier Exp $
inherit libtool
DESCRIPTION="free lossless audio encoder which includes an XMMS plugin"
-SRC_URI="mirror://sourceforge/flac/${P}.tar.gz"
-RESTRICT="nomirror"
HOMEPAGE="http://flac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/flac/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2 LGPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64 ~mips"
IUSE="sse xmms X"
@@ -32,11 +31,11 @@ src_unpack() {
cp src/Makefile.in src/Makefile.in.orig
sed -e '/^@FLaC__HAS_XMMS_TRUE/d' src/Makefile.in.orig > src/Makefile.in || die
fi
-}
-src_compile() {
elibtoolize --reverse-deps
+}
+src_compile() {
# hppa need -fPIC for to compile when X and xmss are in USE
if use xmms && use X && [ "${ARCH}" = "hppa" ]
then