summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-01-05 10:37:39 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-01-05 10:37:39 +0000
commit22f7c0bc6c2e38c94f038102e5f01f5698e56aac (patch)
treedbda96047a33bd8c583ae5ed806dc1722cd1b38c /media-libs/gle/files
parentFix maintainer mode called automake. Per bug #350100. (diff)
downloadgentoo-2-22f7c0bc6c2e38c94f038102e5f01f5698e56aac.tar.gz
gentoo-2-22f7c0bc6c2e38c94f038102e5f01f5698e56aac.tar.bz2
gentoo-2-22f7c0bc6c2e38c94f038102e5f01f5698e56aac.zip
Properly fix as-needed issues, fix man pages, migrate to autotools-utils.eclass. Drop old
(Portage version: 2.2.0_alpha10_p22/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gle/files')
-rw-r--r--media-libs/gle/files/gle-3.1.0-autotools-r1.patch118
-rw-r--r--media-libs/gle/files/gle-3.1.0-autotools.patch54
2 files changed, 118 insertions, 54 deletions
diff --git a/media-libs/gle/files/gle-3.1.0-autotools-r1.patch b/media-libs/gle/files/gle-3.1.0-autotools-r1.patch
new file mode 100644
index 000000000000..8f6e8f649fac
--- /dev/null
+++ b/media-libs/gle/files/gle-3.1.0-autotools-r1.patch
@@ -0,0 +1,118 @@
+* Fix buildsystem to work with modern automake, allows building with
+ libtool-2.4 (by flameeyes)
+* don't install docs
+* use pkg-config to detect libs
+* fix as-needed issues
+
+--- a/doc/html/Makefile.am
++++ b/doc/html/Makefile.am
+@@ -87,5 +87,5 @@
+
+ EXTRA_DIST = .cvsignore $(doc_DATA)
+
+-SUFFIXES += .html .gif .jpg
++SUFFIXES = .html .gif .jpg
+
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -7,5 +7,5 @@
+
+ EXTRA_DIST = .cvsignore COPYING.artistic gle-3.0.lsm
+
+-SUFFIXES += .lsm
++SUFFIXES = .lsm
+
+--- a/man/Makefile.am
++++ b/man/Makefile.am
+@@ -22,7 +22,7 @@
+ $(man_RAW) \
+ Makefile.sgi
+
+-SUFFIXES += .man .3gle
++SUFFIXES = .man .3gle
+
+ # for the ordinary install, just copy the raw files ....
+ .man.3gle:
+@@ -38,4 +38,4 @@
+ psroff -t -man < $< > $*.ps
+
+
+-CLEANFILES += $(man_MANS)
++CLEANFILES = $(man_MANS)
+--- a/configure.in
++++ b/configure.in
+@@ -31,6 +31,8 @@
+ AC_PROG_INSTALL
+ AM_PROG_LIBTOOL
+
++PKG_PROG_PKG_CONFIG
++
+ AC_ISC_POSIX
+ AC_PROG_MAKE_SET
+ AC_HEADER_STDC
+@@ -95,46 +97,15 @@
+ AC_ERROR([Can not find X11 development headers or libraries.])
+ fi
+
+-# AC_CHECK_HEADER(GL/gl.h)
+-# AC_CHECK_HEADER(GL/glut.h)
+-
+-# configure seems to work best when tested subroutines take no arguments
+-AC_CHECK_LIB(GL, glGetError,
+- X_LIBS="-lGL $X_LIBS",
+- AC_MSG_ERROR([Cannot find required GL library]),
+- $X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS)
+-
+-AC_CHECK_LIB(GLU, gluNewQuadric,
+- X_LIBS="-lGLU $X_LIBS",
+- AC_MSG_ERROR([Cannot find required GLU library]),
+- $X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS)
+-
++PKG_CHECK_MODULES([GLU], [glu])
++PKG_CHECK_MODULES([XI], [xi])
++PKG_CHECK_MODULES([XMU], [xmu])
+ # ----------------------------------------------------------
+-# Newest versions of glut require Xmu, which doesn't show up
+-# by default in X_LIBS
+-AC_CHECK_LIB(Xmu, XmuLookupStandardColormap,
+- X_LIBS="-lXmu $X_LIBS",
+- AC_MSG_ERROR([Cannot find required Xmu library]),
+- $X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS)
+-
+-AC_CHECK_LIB(Xi, XListInputDevices,
+- X_LIBS="-lXi -lXext $X_LIBS",
+- AC_MSG_ERROR([Cannot find required Xi (X11 Input Extension) library]),
+- $X_PRE_LIBS $X_LIBS -lX11 $X_EXTRA_LIBS)
+
+-# latest versions of glut also use Xi the XInput extension
+ AC_CHECK_LIB(glut, glutSwapBuffers,
+- X_LIBS="-lglut $X_LIBS",
++ [],
+ AC_MSG_ERROR([Cannot find required glut library]),
+- $X_PRE_LIBS -lXmu $X_LIBS -lX11 $X_EXTRA_LIBS)
+-
+-
+-# This is how to use the variables set by AC_PATH_XTRA:
+-# cc @X_CFLAGS@ -c -o foo.o foo.c
+-# cc @X_LIBS@ (-lfoo...) @X_PRE_LIBS@ -lX11 @X_EXTRA_LIBS@
+-# (Perhaps X_LIBS should have been called X_LDFLAGS.)
+-
+-X_LIBS="-lgle $X_LIBS -lXt -lX11"
++ )
+
+ AC_OUTPUT(
+ Makefile
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,10 +1,6 @@
+
+-SUBDIRS = src doc examples man ms-visual-c swig
++SUBDIRS = src
+
+ EXTRA_DIST = \
+ .cvsignore \
+ gle.spec
+-
+-docdir = $(datadir)/doc/gle/
+-
+-doc_DATA = AUTHORS README COPYING
diff --git a/media-libs/gle/files/gle-3.1.0-autotools.patch b/media-libs/gle/files/gle-3.1.0-autotools.patch
deleted file mode 100644
index 40359d85d54c..000000000000
--- a/media-libs/gle/files/gle-3.1.0-autotools.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Index: gle-3.1.0/doc/Makefile.am
-===================================================================
---- gle-3.1.0.orig/doc/Makefile.am
-+++ gle-3.1.0/doc/Makefile.am
-@@ -7,5 +7,5 @@ doc_DATA = COPYING.artistic gle-3.0.lsm
-
- EXTRA_DIST = .cvsignore COPYING.artistic gle-3.0.lsm
-
--SUFFIXES += .lsm
-+SUFFIXES = .lsm
-
-Index: gle-3.1.0/doc/html/Makefile.am
-===================================================================
---- gle-3.1.0.orig/doc/html/Makefile.am
-+++ gle-3.1.0/doc/html/Makefile.am
-@@ -87,5 +87,5 @@ doc_DATA = $(html_HTML) $(gif_HTML) $(g
-
- EXTRA_DIST = .cvsignore $(doc_DATA)
-
--SUFFIXES += .html .gif .jpg
-+SUFFIXES = .html .gif .jpg
-
-Index: gle-3.1.0/man/Makefile.am
-===================================================================
---- gle-3.1.0.orig/man/Makefile.am
-+++ gle-3.1.0/man/Makefile.am
-@@ -22,7 +22,7 @@ EXTRA_DIST = \
- $(man_RAW) \
- Makefile.sgi
-
--SUFFIXES += .man .3gle
-+SUFFIXES = .man .3gle
-
- # for the ordinary install, just copy the raw files ....
- .man.3gle:
-@@ -38,4 +38,4 @@ SUFFIXES += .man .3gle
- psroff -t -man < $< > $*.ps
-
-
--CLEANFILES += $(man_MANS)
-+CLEANFILES = $(man_MANS)
-Index: gle-3.1.0/src/Makefile.am
-===================================================================
---- gle-3.1.0.orig/src/Makefile.am
-+++ gle-3.1.0/src/Makefile.am
-@@ -49,7 +49,7 @@ EXTRA_DIST = \
- INCLUDES = \
- @X_CFLAGS@
-
--CFLAGS = @CFLAGS@ -Wall -pedantic -Wstrict-prototypes -Wconversion
-+AM_CFLAGS = -Wall -pedantic -Wstrict-prototypes -Wconversion
-
- docdir = $(datadir)/doc/gle/
-