summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-14 15:08:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-14 15:08:33 +0000
commit6756eddbc726df2adf1e22a46b7f1dfe6817c431 (patch)
treee1f396eabaaada76f0d5b8f0e9d8bf426e3c6866 /media-libs/gmtk
parentold (diff)
downloadgentoo-2-6756eddbc726df2adf1e22a46b7f1dfe6817c431.tar.gz
gentoo-2-6756eddbc726df2adf1e22a46b7f1dfe6817c431.tar.bz2
gentoo-2-6756eddbc726df2adf1e22a46b7f1dfe6817c431.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gmtk')
-rw-r--r--media-libs/gmtk/ChangeLog7
-rw-r--r--media-libs/gmtk/gmtk-1.0.6.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/media-libs/gmtk/ChangeLog b/media-libs/gmtk/ChangeLog
index cf3687a6e09b..4f84bf91e3b5 100644
--- a/media-libs/gmtk/ChangeLog
+++ b/media-libs/gmtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gmtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gmtk/ChangeLog,v 1.5 2012/01/28 03:11:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gmtk/ChangeLog,v 1.6 2012/04/14 15:08:33 ssuominen Exp $
+
+*gmtk-1.0.6 (14 Apr 2012)
+
+ 14 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> +gmtk-1.0.6.ebuild:
+ Version bump.
28 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> gmtk-1.0.5.ebuild:
x86 stable wrt #399847
diff --git a/media-libs/gmtk/gmtk-1.0.6.ebuild b/media-libs/gmtk/gmtk-1.0.6.ebuild
new file mode 100644
index 000000000000..27f99528efee
--- /dev/null
+++ b/media-libs/gmtk/gmtk-1.0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gmtk/gmtk-1.0.6.ebuild,v 1.1 2012/04/14 15:08:33 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="GTK+ widget and function libraries for gnome-mplayer"
+HOMEPAGE="http://code.google.com/p/gmtk/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa +dconf pulseaudio"
+
+COMMON_DEPEND=">=dev-libs/glib-2.26
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+RDEPEND="${COMMON_DEPEND}
+ dconf? ( gnome-base/dconf )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-gtk3 \
+ $(use_enable dconf gsettings) \
+ --disable-gconf \
+ $(use_enable !dconf keystore) \
+ --with-gio \
+ $(use_with alsa) \
+ $(use_with pulseaudio)
+}
+
+src_install() {
+ default
+
+ rm -rf \
+ "${ED}"usr/share/doc/${PN} \
+ "${ED}"usr/lib*/*.la
+}